mmh avatar image
mmh asked

High frequency issue when grid fails

I work in a hospital in Mulanje (Malawi). We have recently connected 6 Quattro (6x15kW) with 6 Fronius Symo (6x15kW) AC-coupled. We have 6 battery banks (29 batteries in total). Each bank has a BMV and battery capacity of 500Ah (5x100Ah). 1 bank is different with 400Ah (4x100Ah). It is in Malawi not allowed to feed back to the grid. The system is running pretty good but we are dealing with one issue.

When we have low voltage (<180v) the Victron will switch from grid to the battery. Then the frequency goes up briefly to 52,9Hz or 53,1Hz. The next thing is that the Fronius-inverters shut down because of high frequency (error state 105). We have the correct county-settings in the Fronius (MG50). I know that it happens when there is no place to store the energy. But it happens also when the battery is at 40% and the hospital load is 40-60kW. The Fronius-inverters try to start up again and again but gives error until the grid-voltage is good enough for the Victron to go back to the grid. Normally it happens, between 11-2, when the sun is very strong and we need the Fronius-inverters to charge the batteries for the night. In the ESS is the possibility to change the frequency range but the advice to leave it like it is. I added some pictures for clarification. What can we do to solve this issue?

Thanks in advance, Gerwin Habermehl




2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alexandra avatar image Alexandra ♦ commented ·


Do you have a grid meter installed?

What is set to monitor the SOC in the system?

Do the fronius units still remain connected on grid falure?

0 Likes 0 ·
mmh avatar image mmh Alexandra ♦ commented ·


Yes we have a grid meter (Carlo gavazzi). The SOC is monitored by Victron BMV's who communicate with a cerbo GX. The settings are now that we use the batteries by night until 40% and charge during the day if possible with solar. The Fronius inverters do continue by grid failure. Actually by normal grid failure the continue very good. Only when one of the phases has low voltage and the Victrons switched to batteries the Fronius inverters shut down due high frequency.
0 Likes 0 ·
marekp avatar image marekp commented ·


Since you have Quatro units, how is the anty-islanding done in your system?

Is single input relay allowed in your country?

0 Likes 0 ·
2 Answers
marekp avatar image
marekp answered ·


I had a similar problem when only one phase was missing (I think it was L3).

System switched to inverting.

Battery was not full (57%) but Fronius was frequency shifted off.

The only solution was to disconnect the system from grid on all 3 phases.

When I did that Fronius came back to life.

Later on, Victron Service confirmed that this is expected behavior.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

mmh avatar image mmh commented ·

That is indeed de same issue. We are now changing some battery voltage settings to see if that makes any difference. I will let you know when it helps. So you are still switch manual when you deal with this voltage issue? Or can you maybe program a relay switch?

0 Likes 0 ·
marekp avatar image marekp mmh commented ·


Before you start looking for solution please read the answer I got from Victron Service regarding that problem.

In the last sentence they suggest the solution that works.

"That frequency shifting issue is how it has always worked. Yes it could be better and it will be looked at in the feature.
As long as some AC input is present, the units keep "getting ready" to connect as soon as voltage is within limits.
This means that to prevent overvoltage on the output, the PV inverters are shut down by periodically raising frequency.
We hope to change this in de feature, but if that happens it won't be soon.
To overcome the issue, in locations with a lot of grid disturbance sometimes a grid safety relay is used."

0 Likes 0 ·
mmh avatar image mmh marekp commented ·
Thanks for sharing
0 Likes 0 ·
mmh avatar image
mmh answered ·

Hi all, help appreciated again for this system running in a rural african hospital;

Following up on above, the issue seems to be more complicated then low voltage on one grid phase.

I checked the VE.Bus monitor when:

A. state 105 error appears on fronius and B. At the same time Quattro's refuse to connect AC-input 1 (grid in our case, genset sits on AC-input 2).

VE.Bus monitor in this case shows that AC1 voltage is perfectly normal 220V on 3 phases with normal frequency-in of 50.1 Hz. So we can't blame the utility company.

Frequency-out is 52.9 Hz - I suspect due to upregulation by the Quattro to reduce PV power.

Result: no PV (Fronius downregulated through frequency shifting) and no AC-1 (grid) input as frequency in and out do not match! this unhelpful situation exists for many hours every day mostly during sunny hours.

My only solution until now is to close main grid switch and make this an off-grid system, then everything works well.

All modbus settings in Fronius datamanager are correct, grid-feed in is not allowed on GX device settings (ESS) and works well.

System has 6x15Kw fronius symo on AC-output and 2x15Kw symo on AC-input.

6x Quattro 15kW, all properly sized cabling done by professionals.

1x Fronius and 1x Carlo Gavazzi grid meter and Cerbo as GX device.

Other details above.

I tried:

- allow grid feed-in with limit of 5000W, this made no difference

Considering now:

- Delete ESS assistent and use the ignore AC1-input virtual switch. However shame to lose all good ESS features, also not sure if this would help.

Any ideas?

A second problem is that our new 65kVA diesel genset is accepted on AC2-in, without the GX device (cerbo) connected. The moment I plug in the Cerbo, it disconnects. Suspecting again that the ESS assistent does this as there seems to be no physical issue with the genset.

Here I tried all options for genset issues as per documentation (weak AC input checked, UPS unchecked, accept wide frequency checked) but not yet 'disable LOM on AC-input 2.'

Comments on these two issues would be much appreciated. Thanks

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.