question

jcarnouil avatar image
jcarnouil asked

Easysolar-II GX ESS Error in DDC Program

Hi there !
I just installed an Easysolar-II GX with 2 x Pylontech US2000 batteries and have "Error in DDC program" alarm.
I added the ESS Assistant with VE-Configure but it does not appears on the GX Remote Console.
Also, on the Easysolar LCD, HUB-1 is displayed.
So maybe there is a conflit between HUB-1 an ESS Assistant ? (But I do not have HUB-1 assistant setup in VE-Configure).
Any help is welcome
Thanks in advance

PS/ Public access to my installation : https://vrm.victronenergy.com/installation/181865/share/b5dfc2b8


capture-decran-2022-06-05-a-084808.jpg


capture-decran-2022-06-02-a-093758.jpg


capture-decran-2022-06-02-a-093831.jpg


capture-decran-2022-06-02-a-094101.jpg



Multiplus-IIESSEasySolar All-in-One
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

5 Answers
jcarnouil avatar image
jcarnouil answered ·

I tried to "clean" the Assistants with VE-Configure and reinstall the ESS one, but the problem is the same.
I got "#6 DDC program error" alarm ..
I really don't know what can cause this error :-(

capture-decran-2022-06-02-a-171037.jpg


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jcarnouil avatar image
jcarnouil answered ·

@Matthias Lange - DE or @Thierry Cortassa (Victron Energy Staff) , may be have you an idea to solve my problem ? Thanks in advance -Jean-Claude (Bergerac - France)

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

netrange avatar image
netrange answered ·

Are the Pylontech Batteries correctly connected to the GX Device and shown in the Remote Console ? Correct Communication Cable ... Type A or B ... used ?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes, they are well connected and they are charged by the MPPT, which is stopped because they are full. It's the Multiplus II who is in a strange state alternating between "OFF" and "UNKNOW" state.

capture-decran-2022-06-05-a-081439.jpgcapture-decran-2022-06-05-a-081324.jpgcapture-decran-2022-06-05-a-081308.jpg

0 Likes 0 ·
Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

Never saw that error.
https://www.victronenergy.com/live/ve.bus:ve.bus_error_codes

All FW up to date?

What components do you have (list all)?

Check the data wiring. Do you use DIY cables?

4 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes, all firmware up to date.

- EasySolar II GX :
-> SmartSolar Charger MPPT 250/70 v1.59
-> MultiPlus-II 48/3000/35-32 (ACOut2 switchable) v497
-> Venus GX v2,87

- 2 x Pylontech US2000C :
- VE.Can to Bus-CAN Type A Cable (with dongle on 2nd RJ45 GX side)

- ET112 meter on grid side
- Only AC In used (for now) on the MultiPlus (parallel installation)

The GX sees the Pylontech batteries BMS.
The GX does not see the ESS assistant installed via VE-Configure.

I can give you remote access if you want to take a look ?
(I've someone on site if any manipulation is needed)
Thanks !
- Jean-Claude


0 Likes 0 ·

I deleted ESS Assistant and now DDC Program error is gone, BUT .. there is 2 alarms :

capture-decran-2022-06-05-a-192458.jpg

Any idea why those alarms ?


0 Likes 0 ·

I just noticed that you have 2 MultiPlus (the EasySolar is basically a MultiPlus).

Do you have configured them to work together (parallel, split-phase, or whatever)?

https://www.victronenergy.com/live/ve.bus:manual_parallel_and_three_phase_systems

If not that is the problem.

0 Likes 0 ·
jcarnouil avatar image jcarnouil Matthias Lange - DE ♦ ·

Both system are totally independent. (my house and a friend's one)
I finally disconnected the BMS cable from the Pylontech batteries and reconfigured the EasySolar the same way as my installation, which use a DIY LiFe4po battery pack, and it works now in ESS mode.
I'll take time later to connect it back and see if the problems are back too !
Thanks for your help

0 Likes 0 ·
jcarnouil avatar image
jcarnouil answered ·

Dear all !
One month later ... and the problem is still present :(
I've used the system without connecting the Pylontech battery's BMS for some time, but it's not a solution as the ESS does not monitor the battery SOC, and the batteries goes in alarm when discharged.
I've made last week a call to my vendor (Myshop-Solaire) but they did not respond at all ! (very bad client service this company :)

Any help is welcome, and if one want to "play" with my system, I can provide him full remote access !
(and will offer a pack of beer if you find the problem ! ;)

I began to desperate .. really !
- Jean-Claude

capture-decran-2022-07-05-a-125039.jpg


Guest VRM access : https://vrm.victronenergy.com/installation/181865/share/b5dfc2b8

PS/ I hope my connections are correct ? (we newer knows !)

pxl-20220629-144117274mp.jpg


pxl-20220629-144619536mp.jpg


pxl-20220629-144146594.jpg


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.