question

shinepuppy avatar image
shinepuppy asked

STS Temperature Sensor Weirdness

Hello all,

It's starting to get cold here in Texas and I noticed some odd behavior this morning related to my low temp cutoff settings on my MPPTs and I'm hoping someone can help me resolve it. I have a venus gx with a temp sensor plugged in to the first port. The correct temperature displays properly in VRM and in the remote console. I purposefully set my MPPTs to cut off at 45 F to ensure temperature sharing worked. This morning the temp sensor read 42.8 F and my MPPTs were charging... yikes!

I noticed the following:

1. When DVCC -> STS -> temperature sensor is set to "automatic", the "Used sensor" displays "---" and my MPPTs charge the batteries despite violating my low temp cutoff setting. Further, when I pull up any of the MPPTs in victron connect, they do not display a temperature in the "Battery" section leading me to believe they are not aware of the current temperature and something has gone awry with STS.

2. When I manually select what I believe is the proper temperature sensor (there are several listed for some reason), all MPPTs incorrectly register the battery temp as 32 F as shown within victron connect and they stop charging my batteries.

Does anyone have any advice that might help me troubleshoot this issue? Desired state is to share the accurate temperature detected by the proper sensor connected to my Venus GX with all MPPTs so I don't kill my lithium batteries when it drops below freezing.

thanks!

Temperature Sensor
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

42.8 F equals 6 C.

Maybe not cold enough to trigger charge cut?

0 Likes 0 ·

Hi there,

I managed to partially resolve the STS problem by plugging a temp sensor into my quattro and sharing that device via the DVCC -> STS configuration. I read on this forum that older versions of the venus firmware did not permit the user to share a temp sensor device that's directly connected to the venus. I believe that's the behavior I was seeing despite running fully patched firmware on all devices and properly matched temp sensors.

Unfortunately sharing the quattro temp sensor device via DVCC -> STS gave rise to another problem; namely my MPPTs now OVERCHARGE my lithium batteries by about .2 volts! I programmed the MPPTs max bulk voltage for 56.72 which worked flawlessly until I dinked with the STS and now the MPPTs charge up to 56.9.

I also noticed when I share the quattro temp sensor device via STS the MPPTs go into "ext. control" mode. Does anyone know where the external control configuration lives?

thanks!

voltagespikes.png

0 Likes 0 ·
voltagespikes.png (183.8 KiB)
1 Answer
shinepuppy avatar image
shinepuppy answered ·

Howdy all,

Update. I wired up a temp sensor to my quattro, selected the new temp sensor in the STS configuration, and it appears the Venus is relaying accurate temperatures to my MPPT. The temp sensor direct attached to the Venus still sends incorrect temp data to the MPPTs.

I have read a few threads relating to Venus firmware version and support for sharing temperature data. I've applied all firmware updates to my Venus and mppts (2.73 and 3.07 respectfully.)

From what I've read in the manual I believe either sensor should work with STS.

Does anyone have any thoughts on the topic?

Thanks again!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.