question

simon-jones avatar image

Can Bus / MCP2515 / Raspberry Pi 4

Hi All,

Apologies if this has been covered but i've not found anything.

I tried with a RP4, v 2.73, and it runs but the Wavestore Hat RS485/CAN doesn't work, I can't get the CAN (MCP2515) to load at all.

I've booted normal Ubuntu and got the CAN interface up, so I know the hardware is ok, it just seems like the overlay or something just won't load.

I've tried loads of different things, like changing overlays, naming, etc, disabled bluetooth, don't seem to be able to get the driver loading.

Anyone got a fix or clue what to look at?

Raspberry PiVE.Can
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

0 Answers