question

abdallah-salamah avatar image

Quattro overload alarm

we have a single phase backup system with two 10 KVA Quattro’s which has been operated since 2015.

Suddenly when the grid shut down and come back the master has the error as shown in the attached video.

Then at the next time when the grid shut down, there is no power from the inverter but when restarting the inverters the system goes fine and so on when the grid come back.

I tried to make it as the slave, but it shows an overload alarm and has no power.

I updated all the units to the latest version, but no change.

The error appear even no load connected.

quattro 10kva
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@Abdallah Salamah

Most times with a master slave config it is a wiring issue, often on the ac side of things, same lengths etc need to be adhered to.

If you have a gx the error code that comes up is helpful in diagnosing the issue.

You may also need to get your units cleaned out. The dust there can also cause issues.

Thank you, i divided the system and make it operate alone and the problem still done.

Unfortunately, there is no gx.

1 Answer
Alexandra avatar image
Alexandra answered ·

@Abdallah Salamah

You will have to take it for repair. There is an internal component damaged, will need to be replaced.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.