sieade245 avatar image
sieade245 asked

Multiplus ESS no longer discharges after firmware update to 482 and v2.66

***UPDATE*** Fixed this by rolling back Ve-Bus firmware from 482 to 433. All settings the same. Worked straight away. Must be something up with the 482 firmware? See reply post for more info. I managed to roll back using the new remote firmware update too which I wasn't sure would work but it did***

Hi guys. Weird one this. Fully working Multiplus 24/3000/70-50 with 1500ah battery bank in AC coupled ESS setup. No issues for the past few years. Grid monitor and AC current sensor for PV inverter. All connected to AC IN. Raspberry PI as the Venus device with a MK3 USB attached

Updated yesterday to 482 using the new remote firmware system. Restarted all my assistants so ESS and AC current monitor. All seemed to go fine. All appears to be working on the portal as before. The AC current sensor didn't work until I restarted the assistance, connected to the temp sense inputs. Multiplus started up in Bulk mode (was about 11am good PV gain). I did notice that it restarted at 100% charge but this didn't affect charging and the voltage and current curves were what I would expect.

However, after the sun went down, it did not switch to ESS discharge. It remained on bulk all night. It did not take power from the grid to continue charging. I checked the settings on ESS. Everything is normal. Min SOC set to 70%. No errors or warnings. Tried switching between keep batteries charged, batterylife and no battery life but doesn't affect it. I tried total power down of whole system, also system redetect and system reset. If I cut the AC to the multiplus, it switches over to inverter and will power a device on the essential AC output fine so happy nothing is broken.

This morning, good PV again, its put some more charge into the batteries but again, I tested it by turning the PV off and it still will not discharge.

I can remote in as normal to the venus device. I can switch the inverter on and off, it sees the battery voltage and current fine so the comms link appears ok. I can't see anything obvious which would prevent discharging. Any ideas? I can roll back to the older firmware just interested to know why it might not be working.

Cheers, Si

MultiPlus Quattro Inverter ChargerESS
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @sieade245

Did you check Q9 of the faq?

you mention an AC current sensor, this might be the problem in combination with grid code settings:

Fourthly, feed-in may be disabled when a grid code (like the German or Australian grid code) uses the aux1 input to disable feed-in, and aux1-in is used by something else (like an AC-sensor or a BMS), this way feed-in can be disabled. Simply un-check the option in the grid-code settings to prevent this.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

sieade245 avatar image sieade245 commented ·

Hi Daniel. I'm not sure I tried disabled this setting. I did try changing some other settings such as LOM type to type B without any effect. My AC sensor is not connected to Aux 1 though, its connected to the temperature sense inputs as my Multiplus does not have the Aux input terminals, its a very old unit. I can try updating again and disabling this option and I'll let you know. Its easy enough to roll back.

0 Likes 0 ·
sieade245 avatar image sieade245 commented ·

Thanks Daniel. This has done the trick! Just be to be 100% sure. I updated the firmware again to 482. Then set it up from scratch so it didn't copy the settings over. I left the Grid Code at UK G98/99 default and left the checkbox ticked to disable feed-in with aux 1. This had the same behaviour as before with no discharge to the grid.

Next I went back in and just changed that one setting, so unchecked the disable feed in box and reflashed. Started working straight away. Great stuff thanks for your reply. What threw me off on this one, was in the VENUS ESS FEED IN page, there is a status display there which says Feed in Limiting Active: NO. It also said NO when I had the box ticked, so I just assumed it wasn't that but I guess this a separate VENUS status to the multiplus feed in setting.


That checkbox you mentioned isn't there in the earlier firmwares. Looks like I didn't try everything after all then! I did try a lot though before coming here. Thanks again

0 Likes 0 ·
55.png (49.1 KiB)
Daniël Boekel (Victron Energy Staff) avatar image Daniël Boekel (Victron Energy Staff) ♦♦ sieade245 commented ·

Hi @sieade245

Thanks for the update.

I know how difficult it can be when updating something causes things to not work, first thing you think of is the update.

Glad you got it sorted, this option in the grid code is needed to comply to the rules, while hardly anyone uses it in practice.

0 Likes 0 ·
palom170 avatar image
palom170 answered ·

Please check the grid reference value(50w), limit current ac-in, ess optimized without battery life, and disable scheduled charge

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

sieade245 avatar image sieade245 commented ·


Grid setpoint-I tried 50W, 150W and 0W, didn't affect fault

Limit Current AC-in. Have to admit I didn't try modifying this value

Ess optimised - I tried all 3, keep batteries charged, with and without battery life

Scheduled charge - This was already disabled. When grid power went negative (I used a plug in heater), the status in VEportal changed from charge to discharge..but the multiplus didn't go into inverter mode, the LEDs remained in charge mode. This was mirrored on the LED status on the VENUS system status display

0 Likes 0 ·
sieade245 avatar image
sieade245 answered ·


I tried everything then decided to roll back the multiplus firmware. I re-updated the Venus Pi to the latest V2.66 firmware, then used the remote firmware update to downgrade the multiplus firmware from 4.82 to 4.33, which is what it was on before. I had to reconfigure the multiplus from scratch as it doesn't take settings with it if you downgrade. All settings and assistants the same as before. Started working straight away without me having to change anything.

On 482, it just will not discharge, the multiplus never goes into inverter mode, and the inverter lights don't come on. The ESS status says self-consumption, and everything must be set up on Venus properly, or it wouldn't work in 433? I didn't change any settings on Venus before or after the multiplus firmware downgrade,

Not sure what the problem is but something in the 4.82 firmware doesn't work with this multiplus 2610. I was thinking it could be grid code/ LOM related possibly. The 433 firmware has the old G83/2 codes and my multiplus is a very old unit. Or maybe an issue with the ESS assistant? I did try completely removing it on VEconfigure and adding it again but this didn't change anything. I could try a later firmware version in between 433 and 482 but its working again so I'm going to leave it alone for now :-) I'm happy to do some further firmware updates and provide logs if the Victron team need them, just let me know.


23.png (132.9 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

netrange avatar image netrange commented ·

Thumbs Up ... My Homework for Tomorrow ... Thanks for the Tryout ... Downgrading in Progress ...

By the Way ... From where can I get the older Firmware ... On Victron Professionell I can only get the 482 ... Thanks ...

0 Likes 0 ·
sieade245 avatar image sieade245 netrange commented ·

You need to make an account on Victron professional website. The old firmware is on there in the 433 and 459 folders. Then on remote update, you click the 3 dots and choose upload file.

This put my multiplus into factory reset mode. I had to set it up from scratch using remote configure - download. Then ve-configure for the settings/ assistants. Then remote configure - upload.

Have to say I really appreciate Victron's work on this first for remote configure and now remote firmware update. The days of being sat in a dark garage on a ladder with a toughbook and ethernet cable are long gone

0 Likes 0 ·
netrange avatar image netrange sieade245 commented ·

Thanks ... I'm digging ... :)

0 Likes 0 ·
Warwick Bruce Chapman avatar image Warwick Bruce Chapman commented ·
0 Likes 0 ·