question

Thomas Rasmussen avatar image

Warning! Voltage cutoff not working on SmartSolar. Many expensive batteries destroyed.

Hi. I have over 100x SmartSolar 75/15 controllers. I have discovered that when used on a 24v system, even though the jumper is on pins 2+3 (Cutoff should be 23.6v). It does in fact not cut at all. On many of my systems there has been voltage drop all the way down to 17v. I have lost $1000s in destroyed batteries.

Is this a known fault? What can I do about warranty?

I bought them from Access Antenna in Perth, Australia. They have provided no support other than directing me to ask my question here.


Thanks,

Thomas

ESSmppt smart solar
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

You have installed over 100 mppt, and now only have a query about their operation?

1 Answer
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @Thomas Rasmussen,

That does not sound good, very sorry to hear it.

I will look into why that dealer thought it was a good idea to refer you here to the community, but this isn't really the best place to resolve an issue like this.

Please fill out this form, and hopefully you can get to a satisfactory resolution;

https://professional.victronenergy.com/support/

For completeness you can read a bit about what this community is about here in the community guidelines.

Again, sorry to hear about the situation, and hope things improve from here.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.