question

xsilvergs avatar image

RPi Venus with Node-Red proxy access problem

New here but I'm used to Node-Red.
Firmware version v2.60~38-large-image-6
Build date/time 20200819194100
Node-Red is running on my RPi 3 B+.

In Settings > Services Node-Red is enabled.

I have a flow with an inject button which is changing the state (1 or 0) of a Relay Control node and I can see the GPIO pin for relay 1 change state. I have also added the node-red-dashboard node and included a button.

From what I understand I should be able to view this remotely.

From https://vrm.victronenergy.com/installation/nnnnn/proxy/
When I click the big Node-Red button under "Proxy Relay" a new tab is opened and I get this message in the browser at https://nnnnn-nodered.proxyrelay1.victronenergy.com

Error: remote installation does not seem to have a running Node Red service.

Hopefully someone may be able to give me a clue as to why I can't view the Node-Red page?

Thanks

Node-RED
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Mark avatar image
Mark answered ·

A few minor firmware updates were necessary to get remote NodeRED access working. If you just upgrade/install the latest non-beta v2.60 extended FW those changes are included and it should work per the online manual.

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Is Firmware version v2.60~38-large-image-6 not the latest? If not do you have a link to a working image pleas?

No its not the latest. A non-beta version of v2.60 extended FW was released in September and is currently the latest.

You can download the appropriate FW from here: https://www.dropbox.com/sh/i8ru22o4ydws1rx/AADpa8lj5s2APZ2JS78OGPjKa?dl=0

Thank you. I'm not sure how you tell easily which are beta but v2.60-large-image-7 works.


many thanks