question

Cory Wikel avatar image

BMV 712 relay not activating when programming matches conditions

I've got a BMV 712 hooked to a Cyrix LI relay but the BMV 712 relay doesn't seem to be following the parameters to open it close the relay as expected.


The only thing that will cause the BMV to change the state of the relay is when I hit the invert relay function. I've tried having the invert relay switch on or off and it never follows the voltage or soc low/high settings configured. The relay stays constantly on or off depending on how I have the invert relay function set... everything else seems to be ignored.


Can anyone shed some light on what I'm missing here? I get absolutely no reaction to any voltage or soc charge low/high events. I've tried different relay modes, disabling the event and enabling it, nothing. Thanks



Set to 24 low and 28 high, charger mode and it looks like it is working because the relay is closed since I'm at 26.9v.

screenshot-20201209-094928.png

screenshot-20201209-094947.png


But then I change the high voltage down to 25v and nothing happens. I would expect it to realize the voltage is high and open but it doesn't seem to care.

screenshot-20201209-095022.png

screenshot-20201209-095036.png


The only time I've been able to change the state is if I turn the invert relay switch on/off... otherwise it never changes state.


BMV Battery Monitor
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

4 Answers
Mark avatar image
Mark answered ·

Your primary issue is that the relay mode must be set to 'Default' for it to respect all the trigger conditions. I still see that you have the relay mode set to 'Charger' in your recent screenshots.

I also just tested it again myself (triggered by low voltage only - per your example) and the relay worked correctly.screenshot-20201225-104848.jpg

screenshot-20201225-104859.jpg


12 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I'll try default when I get back to the rig on Jan 5th.

Same same with mode on default. Set to 27v to flip and let it charge above that and relay is still showing closed.


Below limit it's closed.

screenshot-20210106-102258.png


Current setting should open at 27v

screenshot-20210106-102317.png


After letting it charge up and is above limit, no change... Still closed.

screenshot-20210106-121330.png

I can see that you still have the 'invert relay' option activated - unless you really want that behaviour, turn it off.

Also when testing wait for the voltage to get at least 0.1V above or below the thresholds to confirm you have properly satisfied the conditions.

Also the 'closed' threshold (translated to 'open' as you have the behaviour inverted) is currently set to <24V, but you have not shown any screen images showing this condition was ever satisfied.

Enable (closed) is set to less than 24v and disable (open) is set to 27.0v. V screenshot is showing 27.08v. I'll change it down and send another screenshot.. Wired to invert relay because that's the only way I can get it to flip open/closed at all. It's not the Cyrix that's the problem, I'm not checking to see if it is allowing power because I know it does if it's trigger by the bmv relay open/closed.

You do not need to have the 'invert relay' option active for it to work or change state. With your current voltage threshold settings the first thing you need to do when testing is to bring the battery voltage to <24V, then it will change state and stay in that state until the battery voltage rises >27V.

But when 'testing' you can use other/closer voltages to make it easier.

Ok I'm not understanding why it's not changing state when the upper threshold is met or below that. Invert relay or not, should only reverse it. So if it's closed now, it should open if above the voltage... It's not doing that.


Your statement about it changing state above the upper set limit is not happening regardless of what I seem to set it to. I haven't tested low voltage yet. I've got this to trigger the relay to keep the batteries from the buckboost charging them too much in bulk mode via the Cyrix. The state change is the only thing that's not working right now.


Regardless of the invert function depending on if the v is wired as normally open or normally closed and reversing that, the core problem is it's not changing state based upon the upper limit.


Only way it will change the open/closed state is to flip the invert switch. It's either always open or always closed and seems to ignore any event triggers.


I think @Mark is on the right track.
You can't disable the relay (at 27V) if it wasn't enabled first (at 24V).

Try to set the enable voltage to 26V and switch on some loads to pull down the voltage below 26V than the relay will be activated and should be disabled if the voltage rises over 27V.

Sorry but you still don't seem to understand how the relay 'hysteresis' and operation works.

The relay will not and should not change state (close) when the voltage only goes bellow the upper voltage threshold (when using the low voltage relay condition).

Once again, the voltage must fall below the lower threshold (24V in your case, but try temporarily increase this setting to make testing easier) for it to change state (close).

Then the relay will remain continuously in that state (closed) even if the voltage increases above the lower voltage threshold, until the voltage increases above the upper voltage threshold (at which time the relay will open again).

So to conduct a test you must make the battery voltage fall below the lower voltage threshold - in all your screen images you have never done this.

Ok I got it working the lower limit is when it will turn on and the voltage needs to be below that to trigger it. I just moved it up alot.


I had originally thought it was triggered closed in between the values and off above the top value.


Thanks!

Good to hear that you finally got it sorted / figured out the logic. Thanks for reporting back.

Thanks for the help guys! Feedback is maybe make the app help a bit more clear.


Here's another set with relay disable (open) set to 26.0v and BMV showing battery at 26.5v. Doesn't change state, closed before I changed the setting and closed still after I changed the setting.


Before changing setting current battery voltage and relay state.

screenshot-20210109-070624.png



Changed really setting to 26.0v.

screenshot-20210109-071105.png


Checking again relay state hasn't changed.

screenshot-20210109-070716.png


I also changed the disabled (open) to 24.5v and it doesn't change state. Only way I can get it change is forcing it through the invert relay function.



Cory Wikel avatar image
Cory Wikel answered ·

@Matthias Lange - DE

Any other ideas? I've also unplugged power to the BMV unit to power cycle it.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Cory Wikel avatar image
Cory Wikel answered ·

Here are the sw versions installed if that helps.

screenshot-20201211-064600.png


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

I guess in "charger mode" it still uses the default 90% "clear SOC relay" setting even if the "low SOC relay" is deactivated.
So as long as you SOC is below 90% the relay will remain closed.

cory-wikel-bmv-relay-1.png

cory-wikel-bmv-relay-2.png

Try to use the "default mode".


3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Will do but I've had it on that as well. Will get screenshots again if it's still disfunctional

Same same when set to default or charger mode with the soc at like 93%. Doesn't follow the voltage or soc values to change the state of the relay. The relay works because I can force it changed via the invert relay function and hear the click but seems to ignore all event based thresholds.


screenshot-20201210-135643.png


screenshot-20201210-135330.png