question

karthikn14 avatar image

MPPT 100/20 fuse blows repeatedly

Hi,

I am using MPPT 100/20. Initially i connected with a 12V battery and everything worked fine. Then, i wanted to check the function with a 48V battery [My PV panel capacity - 58V]. But as soon as i connected the 48V battery, a spark came at the battery terminal and the 25A fuse in my MPPT blown off. And the app also stopped functioning. After this i replaced fuse and connected 12V battery again. Surprisingly, the fuse got blown again. When i checked in detail, seems like there is a short circuit between the battery + & - ve terminals of the MPPT (without any wires connected to battery). When the fuse is removed, however, there is no continuity between the MPPT battery + & - terminals.

Someone kindly help to understand this issue and please support to solve this issue. Can someone share the contact details of technical support team of Victron?

Thanks

Karthik

MPPT - Solar Charge Controller
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Daniël Boekel (Victron Energy Staff) avatar image
Daniël Boekel (Victron Energy Staff) answered ·

Hi @Karthikn14

are you sure you have the 100/20 version that supports 48 volt? (older ones don't)

If the fuse blows, this is normally due to an issue in the MPPT, and fuse shouldn't be replaced.

PS. the most common reason for this is wrong polarization of battery connection, this kills the MPPT instantly.

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Daniel,

Thanks for your feedback.

As per the product label, the variant i have supports 48V battery also. Please find below the label photo

20201201-215343.jpg

screenshot-20201201-215320-whatsapp.jpg

And I am sure that we have not connected the battery terminals in reverse, with the MPPT. Is there any other error that is possible for the repeated fuse blowing? Because presently i am not able to connect 12V battery also as the fuse blows immediately after connecting battery.

Kindly suggest how to proceed for resolving this issue. Thanks in advance

Hi @kaarthik

Yes: contact your reseller for this.