question

kellymeer avatar image

No Watts No Amps

I built a solar suitcase with 2x100 Watt Renogy panels. I have double checked every thing, but never gets watts or amps. I am unplugged, and running the inverter, both TVs, all lights and exhaust hood. So there is load.

the voltage on the airstream monitor and with a meter is 12.5 volts. App says battery voltage at 14.6 volts and in absorption. It acts like an open circuit. No change when I plug and unplug.

2019 Airstream 27FB with 2 BattleBorn batteries in parallel.

I am confused. What am I missing?

not charging
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Matthias, thanks. You are 100% correct. It was a blown fuse on the controller. I forgot about that one. I kept measuring the voltage on the controller terminals.

so, like always, check your fuses!

2 Answers
Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

I guess there is a blown fuse/breaker or a open switch between the MPPT and the battery.

The smaller MPPTs also have a fuse itself directly next to the wire connectors.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kellymeer avatar image
kellymeer answered ·

When you mount the controller, it is underneath.


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.