question

howard-massey-hicks avatar image

Victron Energy Smartsolar 150100 Failure/Repair

Unit was installed about 1 month ago.

15 panels, 5 strings of 3 Min Temp 5 degrees C Max 50 degrees C


Freedom Won LiFePO4 10/7 battery CCGX color control to a Victron 5 Kva Multiplus 2


Unit worked perfectly, Now not even one L.E.D. Light is on. It appears to have a dead short on the PV input. If connected no voltage reading if disconnected we have a normal string voltage reading.

All battery terminals are well installed and tightly fitted


Any way of disassembling the unit to inspect?

Any explanation as to what may have caused this failure ?


Picture of installation.

MPPT - Solar Charge Controller
1596447512969.png (1.1 MiB)
1596448554811.png (1.3 MiB)
1596448692282.png (1.0 MiB)
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Do not attempt to disassemble the unit, there is nothing to be gained by trying to open it up. It will only void a likely warranty replacement.

I would open a support ticket - https://professional.victronenergy.com/support/

If the PV is isolated from the MPPT, and only the battery is connected (nothing else), can you open up VictronConnect and see the unit via Bluetooth?

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Guy


Regrettably no... can't connect to Victron Connect either via bluetooth or direct to pc with a VE to usb cable.

Unit is dead.


We have opened a RMA ticket..

Many thanks for your prompt response.

Regards Howard

warwick avatar image warwick howard-massey-hicks ·

Please let us know how it goes.