question

jjahn avatar image

Multigrid + BYD 3 phase: Limited charge power

Hi.

I have a 3-phase Multigrid 48/3000/35 system connected to three 10kWh BYD B-Box. Power is coming from a 7.8kWp SolarEdge inverter. I've had oscillation problems in the past which were fixed with a firmware update (thanks!), but I still have a problem with significant amounts of power from PV not being utilized. That power ends up getting dumped to the grid. Here's a graph that shows this, the data is pulled directly from the Venus D-Bus.


As you can see, the power delivered into the battery never goes above 4kW when there's barely any load from the house and plenty of PV power available. Excess power even gets fed back to the grid too. Here's a zoomed in view of the time around 14:00 which shows some detail:


The temperature in the room at the time was around 22C. For testing I've also done a complete charge of the battery from the grid to see what the maximum charge amp/wattage would be:


As you can see this goes up to around 5kW when charging from the grid, so it's not like the battery charge power limit is the cause here. Is this normal? If so, why is there excess power delivered back to the grid when there's actually plenty of room for putting more amps into the battery?

I see a similar effect when discharging with an even 3-phase load as well, as long as the load is around 6.9kW the system draws power from the grid even when the battery should be able to support this entirely, and I see the same weird wobbly oscillations. Then when I bump this up to 9kW suddenly the power drawn from the battery increases to max while the grid use remains roughly the same, and the oscillations are gone.

Don't get me wrong, the oscillation issues I had last December were completely different and massively bigger in amplitude. However that was a single phase system and I've since upgraded to 3-phase.

I've been talking to my installer and he asked me to also continously monitor the Grid AC In voltages (which I am now doing) but I feel like there might be a simpler solution or config suggestion, so I was hoping you could suggest some things for us to check. I am on the latest firmware (2.20). I also tried disabling my monitoring in case that my requests were causing this, but nothing changed and I was able to measure the same behavior with clamp sensors.

Any suggestions would be greatly appreciated!


ESSBYDmultigrid
capture.png (24.6 KiB)
capture1.png (29.7 KiB)
capture3.png (17.8 KiB)
2 comments
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Excellent presentation, Would it be possible for me to see the data from the VRM Portal?

jjahn avatar image jjahn Guy Stewart (Victron Community Manager) ♦♦ ·

Thanks for the quick response! Absolutely, the date of the data above is the 22nd of October 2018 (between 11:00 and 14:00 CEST), the installation id is 14862. If you send me an email I can give you access to my ELK instance so you can check out the raw data in 5 second intervals.

5 Answers
jjahn avatar image
jjahn answered ·

So after long discussions with my installer, and a firmware update which didn't help, I added the values of the energy meters to my kibana dashboard, and saw that these too oscillate. But no such oscillating load was in the house, which was easily confirmed by switching off the multigrids, which stopped the oscillations immediately.

So my installer suggested that I re-check the phases of the EM as well as the multigrids. And lo and behold, they weren't matching. Or to be more exact, the wiring was 100% correct, but in the bus configuration the multigrids were assigned to the wrong phases. The rotation direction was correct, which was why the system was able to work at all.

So now the energy extracted from PV and put into the battery is significantly higher, since most of the time the system is running in a partial load/production situation.



This looks perfect (some minor upsets after short load spikes are perfectly ok and expected), and compared to similar situations in the past I'm getting over 30% more efficiency.

Bottom line, if your three phase system oscillates, check the EM values if they're oscillating too. Chances are that even though your wiring may be correct, you can have the multigrids assigned to the wrong phase in the bus configuration software.

Also don't forget to reload the ESS assistant into each of them, because changing the phase order in the bus configuration software wipes the assistants.



1552474640278.png (99.3 KiB)
1552474656516.png (48.4 KiB)
Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

I had a look at your system on VRM.

I think I will need to see a wiring diagram of your system to make sense of what I see though.

Do you have one?

It appears you have no loads connected to the Multi's outputs and instead are relying entirely on the 2 x ET340 energy meters to detect the loads, and the solar, and then regulate accordingly. Is that correct?

Also, I would suggest, please update VEConfigure software and ESS Assistants, and Multigrid firmware to the latest versions. Remember to save your settings and reload them as the firmware update will return it to default.

4 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

Correct, each of the Multis feed to a single AC phase, so Multi 1 is connected to L1, Multi 2 is connected to L2, etc. -We do not use the separate AC output because our loads can exceed the power capacity of the Multigrid.

I don't have a wiring diagram unfortunately since this system was upgraded from single phase 10kWh to a three phase 30kWh setup, but your description is accurate.

The beaglebone firmware is the latest, but I'll have to ask my installer to upgrade the software on the Multigrid itself.

Also, we checked multiple times whether maybe the multigrids are connected to the wrong phases in relation to what the energy meter is measuring, but it looks to be correct.


Alright, we've updated the Multigrids to FW Version 455, reloaded the configuration and the latest ESS assistant. Also Venus is updated to the latest v2.23


The behavior is still exactly the same. I've added grid consumption monitoring and I can see the same swings on all three phases on the consumption meter - but the moment I disconnect the multigrids the oscillation stops, so I know it's not some consumer in the house that's doing this.


Help!

can you make a screenshot of the battery bms parameters when this happens? and see if the numbers change there?
and also of the DC voltage / current graphs.

like this:

Hi,

I see no changes on the parameters page. See screenshot below. I've also added a complete breakdown of the AC and DC curves with matching timescales below.

Keep in mind that the AC consumption values are absolutely not correct - there is NO load that shifts between the three phases like this, and the moment I switch off the Multigrids the oscillations just stop. You can also see that there's no correlation with the DC side of things. Using clamp current meter I verified however that each of the three DC lines (the batteries are wired in parallel) have current oscillations corresponding to the power graph, so there's always energy being wasted during these oscillations.


1552313854265.png (503.6 KiB)
1552313875986.png (31.5 KiB)
Boekel avatar image
Boekel answered ·

did you try turning 'phase compensation' on/off?
also look into the parameters sent by the bms, see if that's stable.

3 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I tried phase compensation off but that did not help. I'm also not really seeing any BMS parameter that would suggest a constraint on the battery side, but maybe you could tell me which parameter specifically I could look for?

When looking at the BMS on the remote terminal, under 'parameters' you can see the values the BMS sends to the Venus.

You post a lot of graphs, but not the DC voltage / current. This might be a piece of the puzzle.


If the battery is (almost) fully charged, the BMS might send a lower maximum charge current to the Venus, it takes a couple of seconds for the system to react to this, and this can induce an oscillation. Your system seems to do this but then slower and somehow per phase. that's why I thought it might be a combination of phase compensation and BMS parameters.

Ah those I have in kibana as well actually. There's no correlation. Also note that there can't really be a correlation because the batteries are connected in parallel. There's no way for one battery to somehow cause a single inverter to feed energy into the grid while the others are pulling from the grid, and this behavior to shift around between the three phases. The DC side is a single entity.

jjahn avatar image
jjahn answered ·

I have another datapoint showing a constant three-phase load that starts at around 7kW (combined load 8kW) without any PV production exhibiting the same oscillations.

You can see that as long as the system is under full load everything is stable, actually drawing around 2kW total from the grid + the full power output from the three Multigrid inverters. But just before 21:10 as the load drops to around 5kW (it's a Renault Zoe close to the end of the charge cycle) the oscillations begin. At any given moment, at least one Multigrid is feeding 500W back into the grid.

Expected behavior would be that the grid power would approach zero for all three phases as the inverters fed from the battery are able to produce enough power to satisfy demand.


Any comments or suggestions would be appreciated.




1548102057271.png (180.2 KiB)
Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jjahn avatar image
jjahn answered ·

Just in case it's not easy for you to access, this is what happened on the 22nd in the portal around that time:




And just to illustrate that this behavior completely goes away as soon as the system no longer has to regulate anything, here's me on the 31st of october, switching ESS to "keep batteries charged" at 11:45, notice the sudden stop of oscillation on the three phases:



As soon as I switch back to just having ESS take the PV excess to charge the battery, the wild swings resume:





1541243767408.png (192.3 KiB)
1541243816204.png (135.5 KiB)
1541243942989.png (277.6 KiB)
1541244039814.png (196.0 KiB)
1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

I hope I'm not sounding too impatient, and for sure this time of the year isn't the most productive one anyway, but can you maybe confirm whether this is a software or configuration issue, and if it's a SW problem, whether it'll be worked on?

Right now it's sunny again and the oscillations continue, while the system generates at least a kilowatt of waste heat due to each Multigrid alternating between pulling and pushing power to/from the grid...




1543396791062.png (189.0 KiB)
1543396799135.png (189.0 KiB)
1543396844129.png (85.8 KiB)