question

christofferbengtsson avatar image
christofferbengtsson asked

Access point option missing, Venus OS Raspberry Pi B3+

Hi all,

I hope this post is in the correct space.

I have just finished installing the Venus OS on my raspberry and getting ready to connect it to my off-grid solar installation. Currently I don't have internet available so I would like to access the Raspberry locally. However - when searching for the access point in the WIFI list on Iphone I do not see it. It seems like on the regular GX models that a "Create access point" option available under Settings → Wi-Fi → Create access point. This does not seem to be available on the raspberry pi? Is there a fix for this? Currently I have no way to access the unit unless I bring it to a location with a LAN connection since it won't auto-connect to the hotspot on my phone when available.

Thanks a lot!

Best Regards
Christoffer

Raspberry Pi
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi

The only way to access it, is to plug the lan connection into a WiFi router and access that way.

Regards

Rob D

NZ

0 Likes 0 ·

Hi Christoffer

Did you ever solve your access point monitoring of the Venus OS on the Raspberry pi set-up? If you didn't I have come up with a cheap ESP8266 workaround to create a local network without LAN connection or additional router. Let me know if you are interested. Regards



0 Likes 0 ·
5 Answers
kradenko avatar image
kradenko answered ·

Hi,

I am sitting with exactly the same problem. Have you found a way to make it work?

Kind Regards,

Davin Hansen

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The simple solution i found is to use a old spare WiFi router and plug the raspi Ethernet port into it and use the WiFi side to receive the data anywhere on a phone tablet etc.

Regards

Rob D

NZ

0 Likes 0 ·
jwfrary avatar image
jwfrary answered ·

@Kradenko @ChristofferBengtsson Did you find a way to get this to work? _ I was hoping to do the same!

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

kradenko avatar image
kradenko answered ·

Hi jwfrary,


I got my answer on the github page. Even though the you can simultaneously create a hotspot and have it as a client the Victron team don't allow it for some reason.

I have attached their response below. Let me know if you have success with making it work.

https://github.com/victronenergy/venus/issues/713

Regards,

Davin

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

pagedo avatar image
pagedo answered ·

Just bought a Victron 712 Battery Monitor 5 weeks ago and was plesently surprised that there was a connection with the Raspberry Pi. I have been working with Raspberry Pi devices configured as various servers for the last 7 years - mainly with the Debian images and Ethernet connections to a Home router, not the Busybox image with WiFi.


The first thing I wanted when I got the Venus Pi up and running was it to be configured as an Access Point for when I am outback and I want to check the state of my battery and what has happened to it over the last 24, 48 hours etc.


I found quickly that if you installed hostapd, the Access Point option is visible and available - it just doesn't work. After a lot of messing around with wlan0 configurations, hostapd cofigs, dnsmasq configs and uhcpd configs a couple of times I actually got the PI up as an Access Point just for it all to stop as soon as I rebooted. After many fresh starts with the Venus Pi V2.60 image I started to hone in on what was included in Busybox and I came across connman.

Things really started to change when I issued the command:


$> connmanctl enable wifi


After a bit more investigation I came across:


$> connmanctl tether wifi on <SSID> <passphrase>


and that is all you really need.


The downside is that I have yet to find a way to specify with connman the Access Point's address, netmask, network and the IP range you want to set. It has defaults of 192.168.1.1, 255.255.255.0, 192.168.1.0 and I guess a range of 192.168.1.2 to 192.168.1.254


There are a couple of other configs you should do as well to ensure teathering is persistent across reboots.


This is what I have done to a brand new install of the

venus-image-raspberrypi2-20210215153610-v2.63.rootfs.rpi-sdimg.zip


From the Web browser from the clean install:

===============================

Settings > General > Access Level >

Superuser

Settings > General > Set root password >

1234567

Settings > General > SSH on LAN >

<ENABLED>

Settings > Firmware > Online updates > Check for Updates >

<PRESS TO CHECK>

Settings > Date & Time > Time Zone >

<COUNTRY> >

<TZONE_REGION>

Settings > General > Reboot? >

<PRESS TO REBOOT>


From a Terminal session accessed via SSH:

============================

$> connmanctl technologies

$> connmanctl enable wifi

$> connmanctl tether wifi on VENUSAP 1234567

$> connmanctl technologies


$> nano /etc/connman/main.conf


TetheringTechnologies = wifi

PersistentTetheringMode = true

AddressConflictDetection = true



2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

gazza avatar image
gazza answered ·

Hi Christoffer

Did you ever solve your access point monitoring of the Venus OS on the Raspberry pi set-up? If you didn't I have come up with a cheap ESP8266 workaround to create a local network without LAN connection or additional router. Let me know if you are interested. Regards


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.