question

solarsean avatar image

BMV-712 SOC not Accurate with Drop In Lithium (built in BMS)

After extensive testing, we found that the SOC is not accurate with Battleborn drop-in lithium batteries. We believe this is due to the fact the Battleborn's internal BMS is not allowing the BMV to take accurate readings.

For example, on a 100Ah battery - When the battery has half of it's capacity drained with 50Ah consumed, the SOC reads 0%. It will remain at 0% as more Amp hours are consumed and pulled from the battery. The SOC will register 1% when it is charged back to only 50Ah consumed, and will increase to 100% once it reaches 0Ah consumed.

Of course it should be a direct relationship for this example - Every Ah consumed should equal 1% in the SOC.

Is the lack of an accurate SOC a limitation of the BMV-712, since it was designed to work with Victron batteries that don't have an internal BMS?

BMV Battery Monitor
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
lehrling avatar image
lehrling answered ·

Curious why discharge floor setting is not shown...?

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Ron Alexander avatar image
Ron Alexander answered ·

You have many errors in your BMV settings. RTFM.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

klim8skeptic avatar image
klim8skeptic answered ·

Change the Peukert exponent to 1.05. See if that helps tomorrow.

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

We have indeed changed the Peukert to 1.05, but this didn't change the readings. Testing has been performed on 3 different Battleborn batteries as well, all with the same results.

Have you contacted Battle Born to question this behavior?