question

MichelBeausejour avatar image

BMV Current vs Smart Solar MPPT

The BMV shows a negative current while the MPPT shows a charge current. There is no load. It looks like the BMV shows negative values while it should display positive values. What is wrong?

BMV Battery Monitor
bmv.jpg (208.1 KiB)
controller.jpg (196.3 KiB)
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
spirou avatar image
spirou answered ·

One is showing the mppt output to the battery, the other the battery total in/output. There's no reason why they should match even if you connected your BMV wrong.

In my van there's a 0.15-0.2A drain even with van electrical system (CBE) turned off at the main panel. This includes whatever the mppt and bmv use for themselves and any other standby load that I haven't identified yet. So in my case I might have 1A output from the mppt, but only 0.8A going into the battery.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Justin Cook - Bay Marine Supply USA avatar image
Justin Cook - Bay Marine Supply USA answered ·

@MichelBeausejour, the most likely condition is that your BMV shunt is connected in reverse; the PCB on the side of the shunt bears small print that defines the correct connection points. The only cable connected to your battery NEG should go to the side of the shunt labeled "battery", and all other system NEGs including all loads, chassis grounds, and charge sources (including the NEG from your MPPT) must be connected to the side labeled "loads and chargers".

See the full user manual here: https://www.victronenergy.com/upload/documents/Manual-BMV-700-700H-702-712-EN-NL-FR-DE-ES-SE-PT-IT.pdf

Please check that your shunt is connected correctly and report back if that doesn't solve the problem!

2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I see that the negative from the charger is connected to the battery negative with the shunt negative. Could this be the problem?

Yes, the charger NEG can't be directly on the battery, it needs to be on the "loads and chargers" side of the shunt.

That being said, it doesn't necessarily explain the readings you're getting... but the incorrect connection there indicates that there's a decent chance the shunt itself is also incorrectly connected.