question

kvanstee avatar image

Using MPPT 100/15; 12V 8A appliance not working

Hi, when I plug this appliance in it doesn't work. A soft clicking noise is heard (from the plug) even with no load on the charger. Interestingly when there is another appliance in a second socket (in parallel to first) it's power led goes on/off with a period of about 1 second in time with the soft clicking.


The battery charger worked in a vehicle 12V socket.

What do you think?


MPPT - Solar Charge Controller
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Matthias Lange - Service Team Döbeln DE avatar image

Not sure what you are trying to do!? Please give us some more informations, pictures and/or a simple wiring diagram.

Do you connect the eBike charger on the "load" at the MPPT? If so the inrush current of the charger maybe is to high so the MPPT thinks there is a short circuit and deaktivates the load output.

4 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Yes this is most likely what happens. I get a temporary load disconnect when I connect my 12v compressor fridge or laptop charger to the load output on my 100/20, although both then work fine after a couple of seconds recovery.

In cases like that it's maybe better to use the load output to switch on/off a relay and take the power for the loads directly from the battery.

kvanstee avatar image kvanstee Matthias Lange - Service Team Döbeln DE ·

Can you suggest a suitable relay?

I don't know the correct english name in german I call it "KfZ-Relais".

Something like "GoodSky GRL-S-112DF".

kvanstee avatar image

I am trying to get the battery charger to work on my home 12V solar system.


Yes I plug the charger into a socket connected to "load" at the MPPT. How do I test your hypothesis? And if you're right what is a solution? The clicking seemed to be coming from the plug in the photo, not the regulator. Is that possible?

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.