question

bennettmvc avatar image

VE Direct Connection between CCGX and MPPT

My CCGX is not seeing my MPPT 100/50 when connected via a VE Direct cable

MPPT - Solar Charge Controller
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
bennettmvc avatar image
Hi Justin Cook,
Weirdly after your note arrived when I checked the CCGX Overview page first thing this morning it briefly showed the BlueSolar as connected and on Bulk (it was a yellow box in the bottom right hand side of the Overview graphic with a sun symbol and showed a flow to the batteries), but then,equally mysteriously, it disappeared after a few minutes and has not reappeared.
1/So I checked the MPPT firmware via Victron Connect using the Bluetooth Victron dongle, and it was a bit out of date: now it is v1.43, formerly v1.39.

But still no recognition of the MPPT by the CCGX.

2/ So I checked the firmware of the CCGX and that is the latest version.

3/I have eliminated a kinked cable (it is brand new and has a smooth route), pins into both the CCGX and MPPT appear ok because they are working on the bluetooth dongle and the BMV.

4/ Swapped the BVM cable from VE Direct port 1 to port 2 on the CCGX and put the VE Direct cable from the MPPT into port 1.


5/Rebooting it seems to make no difference. It sees the Multiplus 24/3000/70 and the BMV 700 but not the BlueSolar 100/50.


I’m stumped!





1 comment Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

The only one missing combinations I can see is possibly a bad cable, it reads like you swapped the ve.direct ports with BMV at the CCGX end, but not necessarily swapped the cable itself at both ends?

That would explain the bluetooth dongle working.

Given all those isolations the next thing I would try is another MPPT, and/or your MPPT on another CCGX. Your dealer should be able to help with that further test if you don't have those available.

Justin Cook - Bay Marine Supply USA avatar image

@bennettmvc, there are several conditions which can cause this; the immediate one which I'd check first is: is the cable in good condition? Check for any nicks in the insulation, hard bends that may have broken the wires inside, etc. Then check both end of the connection, make sure that the pins on the MPPT and CCGX are oriented properly (the pins can often become a little bent, which may prevent the cable from inserting fully) and that the ends of the cable are in good condition and securely inserted into the VE.Direct ports. You may also try moving the cable from the MPPT to a different VE.Direct port on the back of the CCGX.

I'd then check that the firmware on both the MPPT and the CCGX is fully up-to-date, and then, finally, after all the above has been checked and found to be good, restart the CCGX (Menu > Settings > General > Reboot?) and see if the MPPT comes back online.

If it's still not showing up after all that, it may be time to contact the distributor from whom you purchased the equipment; it's rare, but it does happen on occasion that one of the VE.Direct ports goes out on the CCGX.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.