Stephen avatar image
Stephen asked

After battery reconnect Smartsolar 75/15 shows volts but no amps

We have two caravans set up identically with a single 150w solar panel connected via a Smartsolar 75\15 controller to a single 150ah AGM battery. Both worked flawlessly since being installed a few months ago. Reciently both batteries were disconnected at the battery when some gas work was being done.

Now one caravan shows voltage at the panel and into the battery, but zero W solar and no amps at panel or into battery, and no charge having gone to the battery since it was reconnected. I tried disconnecting the solar panel and battery and reconnecting them in the correct order but made no difference.

The second caravan shows the same, while the history indicates it has been charging since it was reconnected, and unlike the first caravan after a load has been applied it operates normally in bulk, but then the serious appear as it switches to float. I did not try disconnecting solar ect. as I did above.

Neither caravan has ever spent any time in absorption, but we haven't had any real drain on the battery as they're just being finished so I'm putting it down to that.

I'm stuck.... What can I do?

smart solar set-up help
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Matthias Lange - DE avatar image
Matthias Lange - DE answered ·

Have you checked the fuse at the MPPT?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Stephen avatar image Stephen commented ·

I have not, but once I locate the fuse I'll be checking it and will report back here...

0 Likes 0 ·
Stephen avatar image Stephen commented ·

Checked the fuse and its fine. I managed to pull a small black plastic tab out at the same time... Not sure how to put that back...??

0 Likes 0 ·

Related Resources

Additional resources still need to be added for this topic