igee7 avatar image
igee7 asked

ESS + DC coupled PV not feeding in / MPPT not increasing charge voltage after update to Venus 3.14

The situation
3x Multiplus-II 48/3000/35-32 Version 508
Cerbo GX Version 3.14
2x MPPT 150/35 Version 1.61 on VE.Direct
1x MPPT 150/70 Version 3.13 on CAN-Bus
ESS configuration with latest version of ESS Assistant
BYD LVS 16.0 Battery on CAN-Bus
DVCC is forced on.
DVCC override charge voltage set to 54.6V
All other settings as described in

ESS mode optimized without battery life

EM24 ethernet grid meter

DC-coupled PV enabled

1708882881162.pngImage Caption

DVCC charge voltage overriding BMS CVL

1708882949603.pngImage Caption

The problem
DC coupled PV excess not working any more after updating GX device to 3.14. Before the GX update I used Venus 2.73 and MP-2 Firmware 487 and DC-coupled
PV excess worked fine: MPPT-voltage was raised by 0.4V and the surplus was fed into the grid.

First of all I upgraded only the GX device because i needed to control charge voltage via Modbus TCP, and Venus 2.73 unfortunately had a known bug in the corresponding register.

As far as I understood the setting "feed in DC coupled PV" increases the charge voltage of the MPPT controller by 0.4V while the MPs are instructed to feed the surplus back to the grid.
Before the upgrade this could exactly be observed by checking the charge voltage of the MPPTs (-> networked operation): charge voltage was set to 55.0V, while CVL is 54.6V)
After the upgrade the MPPTs are not increasing their voltage. The charge voltage is always set to the

same value as reported by the the BMS oder the override-value set in DVCC-> "limit charge voltage"

1708883094327.pngImage Caption

There are many posts in this community reporting similar problems, but none of the seem to exactly match to my specific problem: MPPT is not increasing the voltage.

Any ideas what I'm doing wrong? Or is this a new bug introduced in Venus OS 3.x ??

Regards and many thanks in advance

ESSVenus OSfeed-inmppt overvoltage
1708882881162.png (28.2 KiB)
1708882949603.png (38.8 KiB)
1708883094327.png (36.7 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @igee7,

Venus 3.21 is the current latest release, the first thing I would suggest is to update to that and see if the issue is resolved.

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

igee7 avatar image igee7 commented ·
Hi Guy Stewart,

thanks for your reply. I will check this out by the end of this week and then come back with the result.

0 Likes 0 ·
igee7 avatar image
igee7 answered ·


last days I finally managed to make some tests to reproduce and isolate the issue. First of all I have to to mention that there is also a AC-coupled inverter on AC IN, in parallel to the grid. Its a 3phase-SMA-Inverter without any communication to the GX-Device.


1) The issue, as described in my initial post happens even with the latest release 3.22. Version 2.73 I used for more than 2 years worked perfectly. After the first upgrade to 3.13 I noticed this issue for the first time. Then I also upgraded the Multis to 508, the ESS assistant and the MPPTs to the latest release. I even flashed the cerbo with a clean image from the download page. I reconfigured everything from scratch. Unfortunately no change at all. All components are now running the latest release.

2) Its difficult to get a full charge in march in Germany, so I simulated a full battery by reducing charge voltage step by step until the Multis and the MPPTs switched to absorption mode (MPPT mode 1).
If I now turn on "DC-coupled PV - feed in excess" the MPPTs should switch back to mode 2 (as seen in modbus register 226.791 and 223.791) and increase their charge voltage by 0.4V while the Multis should feed-n the overvoltage back into the grid. Unfortunately this does not happen any more (as it did with venus 2.73).

I noticed, that this behaviour is somehow related to the AC-coupled PV-inverter: I tested this by turning off the AC-inverter and immediately the MPPTs behave like they should: they increase their voltage and the multis start feeding the overvoltage into the grid.
So this appears to be a change in the ESS-control loop: I suppose this happens due to the negative readings of the grid meter (EM24; the readings are negative as the AC-Inverter already feeds power into the grid) even without any feed-in activity of the multis.

If I turn off the AC-inverter the EM24 readings are positive and feed in of DC-PV is working as it should.

By the way: It makes no difference if I turn on "AC-coupled PV - feed in excess" or not. As found in the documentation this feature is only working with modbus-connected Fronius-Inverters.

Best regards

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

igee7 avatar image
igee7 answered ·

Today we had a sunny day and the battery gets fully charged to the absorption voltage (manually set to 54.6V) .... The MPPTs still totally shuts down to 0W while DC feed-in excess is enabled:

The feed-in of 1304W comes from the AC-coupled PV inverter.


The MPPTs stay at their voltage of 54.6 V, without increasing anything:


Nobody there with an idea whats wrong here?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Related Resources