alaskannoob avatar image
alaskannoob asked

Pylontech US5000 stopped communicating through BMS.CAN

Off grid with 8 x Pylontech US5000 batteries connected to our Cerbo GX through the BMS.CAN. Haven't had any issues in the months since we set it up until today.

Today a couple of strange things happened. Battery temps were between 40-50F or so. Light loads. While monitoring the Victron MPPT charging the bank, when the bank got up to about 96% SOC it disappeared from the Venus.local display. But then it came back soon after and had jumped to 98% SOC. No errors. In the logs, I see:


It shows a blank line at 16:05:16 where it seems the battery stopped communicating with the Victron system.

But then it came back and showed it was charged to 100% and I stopped watching the console at that point.

But maybe ten or fifteen minutes later, the power went out in on our cabin. So we tromped through the snow the 700 feet or so to the solar shed where the equipment resides. The batteries all looked normal, no flashing error lights, but the Cerbo was beeping and the Quattro had a red light showing for "low battery." Which was odd given the batteries were fully charged.

So I turned the Quattro off and back on, and all the power came back on and it was inverting and supplying power again. But the Pylontech batteries were no longer detected in the system and the MPPT also threw an error 67 for "No BMS Detected" which makes sense since it appears the Pylontech batteries are no longer communicating through the BMS.CAN for whatever reason. They're now supplying power to the Quattro and we have power, but we can't monitor them. I haven't messed with any cables and I'm not sure why this happened. I tried unplugging the BMS.CAN cable from the Cerbo to the batteries and plugging it back in but that didn't fix anything. I turned the batteries off and turned them back on, still they no longer communicate with the Victron system.

Logs show that right around 17:03 the batteries stopped communicating and no battery info was logged after that.


Before this occurred, battery SOC and health was 100%.

No idea what happened. For now I have the MPPT off and we're basically just running power with dumb batteries. In the morning if the batteries are still unreachable through the BMS.CAN I might try swapping master batteries (changing which battery connects to the Cerbo through the BMS.CAN) to see if that does anything. If it doesn't, I guess I"ll shut our system down and contact Pylontech to figure out what we need to do. I can't charge the batteries if they don't communicate to the system because that would risk over voltage or over current.

Any ideas what might have occurred or how to fix this?

first-weird.png (272.8 KiB)
errors.png (461.8 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
nickdb avatar image
nickdb answered ·

If the battery has disappeared from the Cerbo, clearly some form of fault interrupting comms.

You have covered the bases. Testing with a new master is a good idea, it eliminates that module.

Cables easy to replace. What about terminators?

After that the Cerbo will need a test.

You can also try to use the ve.can bus on the cerbo as a plan B, just change the profile to 500kb and remove any actual ve.can devices.

Strange one. Any chance moisture got in somewhere?

Let us know how it goes.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

nickdb avatar image nickdb ♦♦ commented ·

Just to add, the timeout and power down is normal when comms is lost. You get a short grace period (allows for firmware updates, reboots etc) but ultimately once it knows it is a managed system, it will power down to protect the environment once that timeout is exceeded. So making the the system unmanaged is a good emergency step, just be sure all your individual settings on chargers are good, possibly a little more conservative to avoid any issues while this is resolved.

1 Like 1 ·
alaskannoob avatar image alaskannoob nickdb ♦♦ commented ·

Good to know. I have the MPPT powered off just to be double sure it doesn't try to charge the batteries. And I have no other charging sources. It's just discharge limits that I have to keep an eye on (especially with our cold temps) but we're in a bit of a warm spell right now and our loads are minimal. We're about to go to bed anyway, and get up in the morning to tackle this issue.

0 Likes 0 ·
alaskannoob avatar image alaskannoob commented ·

That's a good plan of action. I'll do that tomorrow.

No moisture fortunately. Metal roof and new construction. Batteries covered in insulation.

I'll update tomorrow with results.

0 Likes 0 ·
alaskannoob avatar image
alaskannoob answered ·

I swapped out the terminator on the Cerbo GX. The terminator wasn't the issue.

I then swapped master batteries. I took the BMS.CAN cable out of the Pylontech master battery and put in a different battery and re-wired the comms appropriately. Turned off the batteries and turned them back on and that worked. All eight batteries are now showing. Flipped on the MPPT and it began charging them with over 5KW of PV coming in.

Conclusion: the previous master Pylontech battery "A/CAN" port appears to no longer work.

I'm not sure why this is, but the battery dealer told me that perhaps the BMS CAN comm cable was touching one of the battery power cables and that might cause an issue. He suggested shielding. I do think the cable was touching one of the battery power cables in its spaghetti mess.

Batteries were at 85% and we're getting good power so they'll be 100% again shortly, so I guess we'll see if this happens to us again...

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alex Pescaru avatar image Alex Pescaru commented ·

It's DC current through battery power cables, not AC.

And it's 48V, not high voltage...

That shielding suggestion is odd, to not say otherwise, in my opinion...

0 Likes 0 ·