Elimac avatar image
Elimac asked

Battery current - triggered even when is charging

I was hoping to make my system trigger to AC in / powerassist when the current draw from the battery exceeds a certain amount. But system is switching even when no current is being drawn!

It switches to AC in with these generator start-stop conditions:

And when system is charging like this:

So, if the Venus knows that I am not asking 6A from battery - and on the contrary, I am charging with 50A - why is the start/ stop condition still activating generator/AC in ?

PS: tested with a lot of other different settings too.

1563959465386.png (63.3 KiB)
1563959554071.png (38.8 KiB)
1563959696240.png (63.0 KiB)
1563959720457.png (63.5 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Mark avatar image Mark ♦♦ commented ·

Out of curiosity, have you tried to specify negative (-) currents as the trigger thresholds?

I'm not saying that this will fix your issue / I have not tried it myself, but current draw from the battery is indicated as a negative (-) current.

This might already be assumed with this input so may not be required, but it's worth a try.

0 Likes 0 ·
Elimac avatar image Elimac Mark ♦♦ commented ·

Thanks Mark for the idea. I don't think is possible to set negative values... at least I couldn't do it.

0 Likes 0 ·
2 Answers
Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

The generator tools of the CCGX switch the non-voltage contact relay on the back of the CCGX, and are intended to close a two wire system for an autostart module triggering a generator's motor to start.

It is not intended to open or close the AC input relay on the MultiPlus.

This is possible, but not in the way you are doing it.

There are several ways, you could use the latest version of VictronConnect, AC input control feature:

Or you could use the Ignore AC with Virtual Switch feature of VEConfigure:

This is considered an advanced feature, so please heed the warnings on these tools, and do not attempt this if it is outside your training, experience or skill level.

You may wish to contact your Victron Dealer instead:

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Elimac avatar image Elimac commented ·

I have to say that I got pretty annoyed with this answer. I can understand better to have no answer at all than one like this, sorry.

- There is judgement on the customer knowledge

- It is stated something is wrong, but not clearly what it is (assuming it could be related, which I don't believe it is)

- And most of all, the main issue is completely dodged.

As a matter of fact, the way the non-voltage contact relay on the back of the CCGX is wired is completely irrelevant for the problem. I just left it now OPEN and, of course, the problem persists: the relay is switched when it should not.

The problem is the way Venus determines when or not to switch the relay based on "Battery Current" condition. Is is apparently using "Input current into Multiplus (DC.Bus current)" and not the output current coming from battery (System Current as seen on VRM).

0 Likes 0 ·
Pedro Lima avatar image Pedro Lima commented ·

Dear Guy,

Im Elimac's dealer. He wants to control a relay based on the battery current (Inverter load minus MPPT charge), not based on the inverter current alone, that's why he is using the Venus relay, and not the VE.Configure.

Problem is, that the Venus is not controlling the relay as it should (inverter-mppt amps), it seems to be controlling the relay using the inverter amps only. Should be a firmware bug, as the battery amps are correctly displayed on the main page.

0 Likes 0 ·
Elimac avatar image Elimac commented ·


Here's an example of the above:

VRM seems to have all that's needed. The last picture on the right is apparently battery current. It takes into account the MMPT current and shows if there was battery current being drawn.

On this occasion, upon high loads, there was current being drawn before 12h (just ~20A), but not on the afternoon. However, the condition "Battery current" with, say ~60A, being set was triggered in every event. It seems Venus is using the VE.Bus (middle picture) values...

0 Likes 0 ·
1564064597533.png (99.5 KiB)
Elimac avatar image
Elimac answered ·


I am using the assistants to ignore ACin and I have followed Victron manual to do it:

Venus is connected to AUX of Multiplus. It is not this part that is broken. This is working very well with AC Power limit, Voltage limit, even SOC.

I have pretty much tested all conditions, and they all work EXCEPT for the current limit:

So, the focus is not on the setup as I have 4 out of 5 conditions working ok. I can even ignore AC in manually on Venus front page by clicking "start generator".

The Battery current condition is not working and from my tests it indicates that Venus is using "VE.Bus" value instead of "System" value. That is, in effect seems the same as the AC load condition.

Guy, would it make a difference how I have it wired for the subsequent action?! If the Venus wrongly triggers the action of Battery current being drawn out when in effect is charging with positive current, we would have the same problem regardless.

This is the issue...

1563962108589.png (27.8 KiB)
1563962234051.png (47.3 KiB)
1563962312671.png (19.6 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.