marcles avatar image
marcles asked

BMV-700 wrong display

Hi, for 4 years my BMV-700 setup worked perfectly, but this winter the display went blank and I couldn't do anything to bring it back to life. I brought the display unit inside the house, then spring arrives so I plug it back and the display now shows something, however the only data that is valid is the voltage. All other displays are wrong :
- Amp reading is fixed at 795A and never changes no matter what load I put on the system

- Watt reading shows 9.6kW without load, then 9.3kW under a 700W load, then shows 11.4kW when charging the batteries

- Ah usage is always to zero, capacity is always 100% and capacity in hours is always infinite

My campervan always spent winter outside for 4 years and everything always worked without problems. I have a 12V - 440Ah battery setup that works fine, charger works, inverter with a load as well as 12V appliances work fine, etc, but the BMW-700 unit fails to show the right data. There isn't much to check on the shunt unit, I made sure nothing was loose. I've reset to factory default many times, checked the config values which seem alright. Any idea what to look for? What to do to get the correct readings?

Thanks for the help!

BMV Battery Monitor
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
boekel avatar image
boekel answered ·

Always check wiring first.
And at the shunt check for water damage / etc (depending on where it is mounted it might get wet)

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

marcles avatar image marcles commented ·

Hi Boekel,

I already checked the wiring, as well as the shunt assembly : everything is secure, no wire seems affected in any way, no scratches, etc. No water or humidity near the shunt or the wiring or the display and the location is not prone to water anyway. Nothing loose in the shunt area either, that could have caused some weird contacts.

It seems to me the shunt electronics is not able to capture/send the right data - is there a way to validate that, or reset the shunt electronics beside doing the factory defaults reset using the setup+select buttons on the display?

Thanks for your help!

0 Likes 0 ·
boekel avatar image boekel ♦ marcles commented ·

easiest is when you have another unit somewhere, then you can test your unit on other cable / shunt, etc. swap out things until you know what is the cause.

0 Likes 0 ·