question

Noisy Boysie avatar image

ESS - Multiplus2 - not discharging battery

Hi All,

This system has been running for just under 1year and has been working just fine.

I have multpilus2 3000/35 grid tied(UK) + ET112 (grid meter) + Cerbo GX(got one of the first one :) ) + self built Batrium BMS Lithium (8KWH) Battery Storage via CAN-BUS + 4kw PV AC on AC1 in (growatt) so no connection to GX

During winter I've left it on Battery optimised with battery life so the battery didnt cycle much if at all, mostly it stayed at 80% SOC

I decided to add the AC Current sensor - single phase - max 40A - CSE000100000 on the AC in side to data log the Solar in VRM portal as I have always missed having this extra data

The Multiplus2 is on FW 470

Cerbo was on 2.58 but decided to upgrade to 2.60 recently - not sure if this impacted the issue i will detailed below

ESS assistant is installed and was the only assistant installed.

Node RED is connected to the GX but isnt used currently and is shut down but works

So to add the AC current sensor I researched as always the correct method and set the DipSwitches all correctly and wired it into Aux 1, I used VRM portal to download and add the assistant via VEConfig3. I got the message that ESS assistant was not upto date and this is where things might have gone weird. I didnt realise that i should right click the assistant and upgrade, instead i removed the assistant and re added it using the same setting, making sure before i removed it to review and note down the settings used. Adding now both the new ESS and AC current sensor setting and exit and saving the file.

Uploading it through the VRM process is proceed to flash it to the Multiplu2. it ended with an error which i didnt note down but it was along the line of error writing assistant config (sorry cant remember it excatly)

I checked everything and saw I now had the PV Inverter box on the GX console but it was on AC out, so I downloaded the config again and swapped in the assistant to AC in and re uploaded it this time no issues or errors.

The PV inverter now correctly showing on AC in, I left it to do its thing for 24h and saw it was then during the night showing 0W on the PV inverter

As I have now recently upgrade to the Agile Tariff on Octopus energy I wanted to ready the setup to be able to charge the batter during the night and discharge during the peak times of 4-7:30 PM (this has always been the big plan but you know covid and all that....

So now I set about ESS and and moving from the option Optimised (with battery life) to optimised (with out battery life)

But no discharging of the battery is happening and im not sure why.

What I have tried so far.

using VRM i downloaded the config of the multiplus2 and removed all assistants and re uploading, then download again and re add the assistants - no change

using mk3-usb connect VEConfig3 to connect and remove all assistants and send data, i got a msg asking as ther eare no assistants to remove the config stored on the multiplus2 I said yes. I then re added the assistants and send the config. no errors or issues. - still no change though no batter discharge.

using the GX console - redetect the multiplus and reset - no change still no discharge

I have removed the AC current assistant - no change still no discharging

I have noticed that the GX device is keeping the ESS settings so I can see its keeps the config some how and knows the battery life state it was previously using.

I’ve tried rolling back to GX ver 2.58 but this didnt help - no change still no discharging.

I've tried fully charging the battery with keep battery charged and switching back to optimised with and with out battery life and can see its dropped the min soc to 75% - no change still no discharging.

screenshot-2021-01-23-102655.png


typically the sun has come out now and i've got a full battery and no where to store it :) so I know it wont discharge now as its exporting.....but trust me it doesnt and i will later upload a new pic showing it importing with out using the battery to invert back to Ac in 1

If I set the switch position to inverting only it inverts to the critical loads with out issue. this does seem to surgest it wont invert to Ac in anymore...not sure if this is key...I rember previously this setting still inverted to AC in 1 but it was a while ago i tried this setting as its not often used if at all in this setup.

no Schedule charging is set enabled

ESS config is as below:

pic1.png


pic2.png

Grid feed in is below

pic3.png

If I set with battery life i show the follwoing:

pic4.png

If I disconnect the GX from the MultiPlus2 even at night it wants to charge the battery, not sure i remember it doing this previously.

So somthing is up and im not sure how to fix this one.

Thanks in advance and sorry for the long read :)

Boysie.


added:

Turning the oven on shows it doesnt want to invert back to Ac in 1

pic5.png

Multiplus-IIESS
pic1.png (32.2 KiB)
pic2.png (28.4 KiB)
pic3.png (24.8 KiB)
pic4.png (32.0 KiB)
pic5.png (34.1 KiB)
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
Noisy Boysie avatar image
Noisy Boysie answered ·

think I have found my issue:

pic6.png


I connected my AC current sensor to Aux 1 DOH!

I'll move it to aux 2 but i expect this is whats causing export eg inverting on Ac in 1 to not fuction,

Boysie


pic6.png (28.2 KiB)
3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

just turn the switch off unless you want to use it, Could be a nice option

i cant you need the grid password for that and i dont have that. so moving it to aux 2 is really my only option...its easy enough.

all working again now after chaning it to aux 2

pic7.png

just gotta wait the 24h for the ac current sensor to calibrate :)

pic7.png (34.9 KiB)
Paul B avatar image
Paul B answered ·

try setting your grid setpoint to negative value this will export the battery power untill it gets to your min SOC.


well thats my understanding ( I have not used it like this myself)


then use scheduled charging to fill it during the day at certain times and to different SOC levels

2 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Tried -500 and still no discharging....:(

Just tried mine

NO export

changed the below MAX feed-in from 0 to 3100


then it feed in upto the grid set points negative setting

1611402829573.png

1611402829573.png (22.4 KiB)
seb71 avatar image
seb71 answered ·

Your only DC source is the battery (no DC solar charger).

Why would you even want to invert to AC In?

3 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

by having the gid set point to 0 or close to it you can use the storeged battery Wh to feed the house while ther eis no PV AC preventing importing from the grid...eg use the free stored energy first

seb71 avatar image seb71 Noisy Boysie ·

Your battery can only be charged by your Multiplus, with power from AC In.

So when it has AC In power, it will charge the battery.

While charging the battery, it can't invert at the same time.

Others may use it to charge during off peak and then to export when there buy tarriff is at the highest level.