peter-vddriessche avatar image
peter-vddriessche asked

Trouble with Mode 2 connection to the "settings" service, cannot write to register 2700

I want to do time shifting using Mode 2.

But I'm having trouble connecting with Mode 2.

My Modbus TCP connection works. I can write for example register 22 which sits on the Unit-ID 246 (com.victronenergy.vebus). I an also read registers. So my modbus connection works .

But I cannot write register 2700 which sits on the Unit-ID 100 (com.victronenergy.settings).

When I look at my system on the VRM Portal, I see under Modbus TCP Services, the following list, where 'com.victronenergy.settings' is missing. Could this be the reason I cannot write 2700?

Any suggestions to solve this?

Best regards








2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
peter-vddriessche avatar image
peter-vddriessche answered ·

Problem solved. it was a program issue. Nothing to do with the Victron services.


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thanks for reporting back, I don't fully understand the issue or solution, but is there anything you could explain further if someone else comes across the same problem to help them?

0 Likes 0 ·
peter-vddriessche avatar image peter-vddriessche Guy Stewart (Victron Community Manager) ♦♦ commented ·

Hello Guy,

I am programming a battery steering algorithm in VBA excel. I had followed a very interesting online course on Udemy for this

Reading several registers in one go (ie using one 'handle' for a series of addresses) worked fine. The error I made was that I tried to write also several registers in one go. That did not work. When I changed this and wrote one one register per handle, it worked.

Best regards

0 Likes 0 ·