davo00 avatar image
davo00 asked

IP22 charger going straight to Absorption

I have a Victron BSC IP22 12/30 charger and a 120AH Lithium battery When I connect to 240v power, the charger immediately shows a voltage of 14.2v goes straight to Absorption, irrespective of the actual voltage. The charger is set to the Li-ion profile. Below are screenshots from both the IP22 and Smartshunt.

Can anybody suggest how I can get it to Bulk charge before going to Absorption?

ip22.png (217.0 KiB)
smartshunt.png (281.9 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

11 Answers
Thierry Cortassa (Victron Energy Staff) avatar image
Thierry Cortassa (Victron Energy Staff) answered ·

it's like your charger is in power suply mode !

check your wiring and fuse may be somethink in this way !

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

davo00 avatar image
davo00 answered ·

The charger is definitely not in power supply mode. I have stripped the system down to simply the charger and battery with nothing else connected. I have now inspected the history and see that the charger performed as expected the first seven times a cycle was commenced. Since that time, whenever power is turned on, the history shows bulk charge for 4-6 seconds and then Absorption immediately after that. The absorption cycle lasts exactly 2 hours and then it goes into storage.

Screenshots below.

Has this behavior been seen before? Perhaps my charger is defective and needs to be replaced.

charger.png (216.6 KiB)
charger-history.png (119.7 KiB)
smartshunt.png (276.8 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Did you check the wiring and fuses voltages between the chargers terminals and the battery terminals with a multimeter?

If there is a break, or bad connection, the charger voltage will rise because it doesn't have the battery to pull it down.

If you are reading a voltage of 13.4 Volts with on a multimeter with the probes connected to the output terminals of the charger, while the charger is reading 14.2 V then there is a problem with the charger.

If you are reading 14.2 volts on a multimeter with the probes connected to the output terminals of the charger, and only 13.4 volts on the battery terminals, then there is a problem with the wiring, connections or fuses between the charger and the battery.

0 Likes 0 ·
jfackrell avatar image
jfackrell answered ·

I recently purchased the IP22 on Amazon and mine is doing the same thing. I am sending it back for a replacement. I hope the new one isn't defective. How do I know it's defective and not related to how I have it connected or a problem with my batteries? While troubleshooting the issue, I had a feeling the charger was somehow thinking it was connected to 14.2 volts and moving to ABS due to some fault within the charger. To test this theory, I disconnected my battery as well as the cables connected to the charger. I plugged it back in and logged into the App. With nothing connected, it was showing it was in ABS at 14.2 volts. This appeared to validate my theory, but I wanted to be sure so I went into the settings and switched to power supply mode then back to charger mode. I quickly clicked on the status tab and watched as the voltage quickly climbed up to 14.2 volts and into ABS. Something inside the device is faulty or there is something wrong with the latest firmware. Either way, the problem was isolated down to the device itself. I suggest others having this problem do the same test I did. If others doing this test have the same results, it will provide further proof of an issue with the device and hopefully provide Victron with what it needs to diagnose and correct the problem going forward.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

duane avatar image
duane answered ·

In this situation you could try to create a VE Smart network with the smart shunt then join the IP22 to the same network

The IP22 will then use the voltage from the smart shunt and all may work as expected

My suspicion is that your wiring is too light or long this issue should be resolved but the network will help with the diagnosis

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

stockie avatar image
stockie answered ·

Mine is doing exactly the same I need to test as yet with multi meter but would concur that this coincided with the firm ware update I did a couple of weeks ago

is there anyone directly at victron that has read this if so can they please confirm this is the case please?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

stockie avatar image
stockie answered ·

I’ve had a play with a multi meter and the my battery reads 13…… my smart shunt reads 13….. when on positive of battery and the 2 negs on the smart shunt

but then on the terminal on the charger reads 14.2 when attached to battery and 14.2 with the negative detached but still power going to it

if that is of any significance

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

sandmac avatar image
sandmac answered ·

I have found that my charger has the same issue.

It seems to only have started after the latest firmware update.

Also the unit gets really hot and the fan is only working for a couple of seconds before it stops. This repeats every couple minutes.

Do you guys know if it is possible to use an older version of the firmware to check if the issue is related?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

eric-edwards avatar image
eric-edwards answered ·

I am now having this issue too, exactly as described above and immediately after a firmware update. I have contacted the vendor as the product is still in warranty but it is frustrating that I cannot contact Victron direct. It is clear to me that the firmware update has caused a problem, I have used the charger many times without any issue, the problem only started after the firmware update which was, of course, sent to the unit automatically by Victron.

Come on Victron, sort this out!

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Eric Edwards , and others answering on this (rather old) thread that worry if they have a bug in firmware:

Ofcourse, if there is indeed a problem in the firmware, we'll for sure sort it out. Similarly, broken chargers we'll replace. Do note that the issue that started this thread was no broken charger. It was a connection/wiring-issue between charger and the battery.

But before I have some questions, please allow me to explain this:

Until now, every time such report came up, it was in the end determined to be an issue due to a faulty connection between battery and charger. For example a blown fuse, or some other system issue. Not in the charger, and for sure no firmware bug.

We test the firmware extensively before release. In our labs, and in a field test group. And also have not pushed out any firmware updates recently, and keep in mind that there are several hundred thousands of chargers out there in the field, if not even more.

The last firmware update released was on 2021-10-07, in VictronConnect v5.48. And then specifically it was version v3.42 for the IP22 rev2 chargers, (serial no HQ2024nnnnn and later); as an optional update. Not mandatory.


Troubleshooting an IP 22 charger

Now, to your issue, first of all know that when there is no battery connected, for example due a blown fuse, it is normal for the charger to jump to absorption after 4 seconds.

Similarly, in case the fuse (which is in the charger, and replaceable) is blown, the charger will also go to 14.2V and absorption phase.

Can you describe your system? Ie is there more than just the IP22 charger? Is it in a VE.Smart network?

Next, take out the fuse and measure that with a multimeter for continuity.

And in case that's fine, then use a multi meter to measure the voltage at both the charger- and the battery terminals.

Possible results:

1) In case both battery- and charger terminals read 14.2V, then the battery is already fully charged - no problem with the charger or its connections. Its then normal for the charger to show 14.2V and be in Absorption. Or, in case both read 14.2V and its a lithium battery, it might be that the battery is disconnected itself internally, also no issue with the charger.

2) In case the charger terminals and VictronConnect read the same voltage, also no issue with the charger. Even if the battery at the same time reads a lower voltage. If there is a difference, check the wiring and fuse between charger and battery.

3) In case there is a difference between what is measured with the multimeter at the terminals of the charger and the reading in VictronConnect, then check the fuse. In case fuse is absolutely fine, then send the charger in for repair.

Hope above helps! Welcome to share more details and results of checking with a multi meter.

0 Likes 0 ·
eric-edwards avatar image
eric-edwards answered ·

I don't possess a multimeter. I do know, however, that my batteries needed charge and that the charger went direct to absorption. The first battery was a lead/acid battery which had drained completely due to a switch being left on. The charger went straight to absorption as soon as I switched it on (after connecting the battery). Today I went to charge one of my lithium batteries which I had used for several days and again the charger went to absorption immediately. I have three lithium batteries, it went straight to absorption with two of them but actually did bulk charge with the third.They are Poweroad batteries which I can read through bluetooth, here is the display on one of the batteries and on the IP22 charger at the same time during charging.



I have checked the fuse in the charger, it is intact.

I have used this charger many times since I purchased it in May of last year and always without issue, it is only since the firmware updated (three days ago) that this has happened.

1641483374068.jpeg (312.3 KiB)
1641483393928.jpeg (330.6 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@Eric Edwards

I've a couple of IP22 for testing and none of them showing this behaviour. They all on latest firmware v3.42. Also notice the higher voltage on the charger output 13.81V vs battery terminal voltage 13.61V as a result of cable losses. I think I'm using only 4mm2 wire and quite long. If I extend the length, it would be even more drastic. Not only that the wire will get hot but the voltage at the output will also increase...within seconds...and as soon as the charger measures 14.20V it goes into absorption.


As Matthijs I also suggest doing some voltage measurements at the IP22 output terminals during charging and at the battery terminals. The high voltage at the output can be the result of a faulty cable or connection between the terminals and the battery which causes a high resistance.

If you don't have a digital multimeter I suggest you hire a professional installer to check your system.

What is your installed firmware? What are the charger settings? Please post screenshots of all settings including those hiding behind Advanced Settings, then Advanced battery settings and finally Expert Mode. And please also post images of your IP22 installation.

0 Likes 0 ·
img-4952.png (368.3 KiB)
img-4954.png (387.0 KiB)

Hi Eric,

Thank you for the details. I checked them, and really expect the issue to be a wiring issue. Too much resistance between the charger- and battery terminals, causing the voltage drop.

To make sure, you'll have to use a multi meter, or contact your Victron dealer, and send the charger in for checking it or perhaps they have another good advice.

Also I have here attached the previous firmware version, v3.25. Just in case you want to try those. Instructions for how to install those are here:

Note that you will be able to login and monitor the charger while that version is installed, but will not be able to change any settings. To change settings, you'll first have to update it again.

Best regards, Matthijs

Blue Smart IP22 Charger 12-30 (3) - v3.25_A331 and

0 Likes 0 ·

That's helpful mvader, thank you. I have tested the fuse, it's good. I've taken your point about losses and have shortened my cables. I've drained down a battery and put it on charge and it appears to be working. The voltage at the charger is now 13.76v and the voltage at the battery is 13.62v, are these acceptable?

What I cannot understand is why the problem appeared immediately after the firmware update, I have had no problem before this, the update MUST have made a change.

0 Likes 0 ·
Hi Eric, the acceptable voltage drop depends on the amps flowing at that moment. 0.15V is not much, especially not when there was 10 or 20A flowing at that time.

Firmware updates can't cause voltage drop, I'm sorry.

0 Likes 0 ·
mvader (Victron Energy) avatar image mvader (Victron Energy) ♦♦ mvader (Victron Energy) ♦♦ ·

ps. I think there is just some coincidence going on here. Or something else, difficult to figure out. What matters is if it works well, and seems to work well. Also what matters for your system is that you limit the voltage drop, which you did now.

I'm not worried, and don't think you need to be worried either. Have a good weekend!

0 Likes 0 ·
bagarn86 avatar image
bagarn86 answered ·

Having the exact same issue as many other here. Worked fine until a firmware update. My charger is hooked up to 2x lifepo4 without BMS in my boat and jumps straight to absorbtion after 4s of bulk. Using the boats OE wires which is 10mm2 if I remember correct and they are about 3m of length. Since it worked fine previously and nothing else has changed, I’m not expecting it to be an issue with the connection. The fuse at the charger terminals is not blown, is there another internal one too?

My Victron battery monitor which is connected to the batteries via the shunt reports a different voltage at the batteries while the IP22 reports 14.2V when in the absorption phase.

Any one has any news in this matter or a way to resolve it? I temporarly increased the absorption time to 8h so the charger will charge the batteries to 100%, but it’s not as effective when it’s skipping the bulk stage and limiting the amount of amps

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Please read the same thread above for an answer:

0 Likes 0 ·
bagarn86 avatar image bagarn86 Stefanie ♦♦ ·
In my case that would mean to send the charger back, but as several other have pointed out the replacement charger does exactly the same so it seems pointless? The problem must be something else?
0 Likes 0 ·

Yes of course. The cause could also lie in the installation itself and that's where I would look first. The troubleshooting is also explained in detail in the other post. Why would you send it back if you haven't troubleshooted your setup yet?

FWIW, I charged my lithium batteries with two IP22 chargers yesterday. There were no problems. The bulk phase lasts until the absorption voltage is reached. That was about 3 hours of bulk. I'm happy to take screenshots of it.

0 Likes 0 ·
el-fred-el avatar image
el-fred-el answered ·

my charger hase exactly the same issue.

if i connect the ip 22 the VStart in the hystory windows shows from beginning 14.20V on the battery before connecting i measured 13.30V

checked my wiring

checked the fuse

all fine

Also the fan is only working for a couple of seconds before it stops. This repeats every couple minutes.

it seems that this thing happens only to a few -monday models-? but as bagarn86 says its still possible to charge the battery but its not the idea to increase the absorbtion time...

as many others i am also wondering and waiting for a clear solution of the situation ...

saludos de chile

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

As suggested above, have you checked the output voltage at the charger with a meter?
0 Likes 0 ·
el-fred-el avatar image el-fred-el kevgermany ♦♦ ·
yess output of the ip22 is 14.2v ... full voltage to charge the battery... battery is less then 80% charged so ip22 should charge on bulk which it doesnt... ip22 jumps directly on absorb ... the app shows battery startV 14.2v ...which is wrong

thanks anyway for your answer -question ...

0 Likes 0 ·