question

giampaolo avatar image

Battery Balancers behaviour. Should there be an alarm?

Hi

I have a question concerning the behavior of three battery balancers I have connected to my batteries like in the enclosed picture.

I have seen that the green light turns on on all the balancers , then with a deviation of more than 50 mV the orange led of the balancer in the middle turns on while the others are off.

I also noticed that with a deviation of more than 500 mV there is no alarm on the balancers. Is this behavior normal or maybe there is something wrong with the balancers or connections?

Regards.

Battery Balancer
balancer.png (102.4 KiB)
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

@Giampaolo

There is a also a voltage trigger level. So it will only balance once your batteries have hit that level. Is the 500mv happening out of the trigger range? Check the datasheet.

https://www.victronenergy.com/batteries/battery-balancer

Also a little demo page to show you how it works.

1 Answer
giampaolo avatar image
giampaolo answered ·

Now the balancer seems to be working properly. With a deviation of more than 500 mV there is an alarm and it also starts balancing the batteries after a deviation of 200 mv. Probably now I understand that only the balancer in the middle works because the imbalance is between the second and third battery in the bench.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.