Christian Dorst avatar image
Christian Dorst asked

Multiplus II ESS Mode 1 latency and limits

Hi folks,

I just installed a 3-phase ESS Mode 1 with 3 multiplus II 5000-70-50. Since there is a lot of PV installed yet, I decided to connect the PV on AC-Input, and installed an EM24. The installed battery is a pylontech US3000 rack with 2 stacks of 6 battery piles.

I got some error messages about high voltage, but found the information in the tutorial for pylontech batteries about 52V..

The reason I'm writing is the discharge behavior of the multiplus. The latency ist very high (serveral seconds for a load of about 2000W). I searched for a reason, and found a 400W per second limit referenced to the grid codes. Is there any posibility to adjust this value?

The software is up to date (2623474 on the multiplus und 2.54 on the venusGX).

Best regards


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Alexandra avatar image Alexandra ♦ commented ·

@Christian Dorst

What component is generating the high voltage alarm?

0 Likes 0 ·
Christian Dorst avatar image Christian Dorst Alexandra ♦ commented ·

The alarm comes from the pylontech BMS, but as I mentioned above, I don't see this as a large problem, more like a little bit annoying.. I found comments for this here:

and here:

0 Likes 0 ·
3 Answers
Christian Dorst avatar image
Christian Dorst answered ·

the problem I have is mentioned here for Mode 2 & 3:

"5. Response times and ramp speed

There are multiple factors that determine the response time to a (digital-) command to feed in:

  1. Latency and communication speed of all components in the communication chain: ModbusTCP or MQTT, GX Device, MK3 microprocessor, ESS Assistant, internal communication in the Multi itself.
  2. Rate limiting imposed by the used Country Grid code. Code “Other” has no rate limiting, Code “Europe” allows installer configurable rate limiting, many other codes have fixed a powerup ramp up.
  3. Hard coded rate limiting in the inverter/charger firmware: as per ESS version 162 it is set to 400W per second. The reason for this rate limiter is that without that there are regulation problems (overloads and such) when the mains is weak (long cables and such resulting in a relatively high impedance). More information on that here, as well as in the main ESS manual."

I got these 400W/sec in Mode 1 which is way to slow IMHO.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

rainerb avatar image rainerb commented ·

There seems to be other (known?) issues for the slow response speed in an ESS system with several grid meters. See this discussion:



0 Likes 0 ·
Christian Dorst avatar image Christian Dorst rainerb commented ·

Thanks Rainer, that's excactly what I see here too.

Sunny greetings


0 Likes 0 ·
jacola avatar image jacola Christian Dorst commented ·

Hi guys, i have exactly the same problems. very high latency, and 52V pylontech high voltage alarms.

In my case i have rapidly changing loads - big irrigation pumps, which, once connected, draw 11kwh distributed over all phases.
obviously i want to cover those peaks with my ESS. The absolute worst is that those pumps go on and off (whenever set pressure is reached they go off, then on again).
a 400W/s slow rate makes the system pretty much unusable .. if the pumps come up for 10 seconds, then off 10 seconds, about 3.6kw per phase, i need 9 seconds after they switch on until i have the power covered, for 1 second, then i overproduce 9 seconds .. completely useless.
Other than setting the ESS to constantly produce 10kw while the pumps run (and give the idle times for free to the grid) .. anyone has an idea ?


0 Likes 0 ·
Christian Dorst avatar image Christian Dorst jacola commented ·

I do not have any solution for the slow response problem. As Rainer mentioned, there is a thread about this topic with a answer by a Victron staff, that says it is a known issue that's being worked on.,

My high voltage alarms disappears after a couple of charge-cycle, and now the battery seamed to be balanced correct. Have you made all these settings describted in this article:


best regards


0 Likes 0 ·
gnagflow avatar image gnagflow jacola commented ·

Hi Johannes,

did you already find a solution for a work around of the 400W/s limit?

thank you!

0 Likes 0 ·
jacola avatar image jacola gnagflow commented ·

Hi, there seem to be no way around this. the inverters had a software bug also resulting in crazy behavior, that was solved 1/2 years later.
I decided to switch the system to 'pass through' and be off grid as much as possible. the 400w/s do not apply then.
I am now plagued by false loss of mains (LOMS) detection and my inverters usually fault when going on-grid, which is super annoying, but victron went dark on this. i understand they have a conceptual or firmware issue in the loss of mains detection which makes the devices pretty much unusable without external an external solution .. but seems they prefer to not answer any more and wait to see what happens.


0 Likes 0 ·
mucwendel avatar image
mucwendel answered ·

Any news about the slow battery charge/discharge response?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

baxter avatar image
baxter answered ·

Hi, any news on that? Our mains in Austria is not weak so more than 400W/sec would be fine to avoid any unnecessary grid consumption and feed in because of slow responses on load changes

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.