question

jeanmc avatar image
jeanmc asked

ESS system Pylontech battery Alarm – High voltage Alarm

Hello,

I keep getting an alarm/warning every 14 minutes via the CCGX for the following:

Pylontech battery Alarm – High voltage warnings – Voltage reading attached to each warning varies between 51.56V through 51.77V

This alarm pops up during the absorption phase. I.e. absorption light is lit on the Multiplus ii 5000 and a status of absorption charge is indicated on the SmartSolar Charger MPPT 250/100.

As per previous reply from Guy on a “DVCC and Pylontech Battery” community post, I understand that a Pylontech managed lithium battery does not have a bulk, absorption and float stage like a lead acid battery. However, during the bulk phase, the 4 US3000 Pylontech batteries charged up to 80% without any alarm. Charging has now slowed to almost nothing. Current SOC is 81%

All the Victron components run the latest available firmware as detected via the CCGX and VictronConnect App. The current firmware versions are as follows:

CCGX – v2.53

Multiplus ii 5000 – v471

Charge controller – v1.46

I have loaded and configured the ESS assistant and configured all settings as per these two documents:

https://www.victronenergy.com/live/battery_compatibility:pylontech_phantom

https://www.victronenergy.com/live/ess:design-installation-manual

I have made sure that the Multiplus II Charger Tab settings for Float voltage is set to 51V and that Absorption is set to 52V after completing the ESS assistant as per documentation. After I started receiving the high voltage warnings, I have also tried setting Absorption on this tab down to 51V. This makes no difference.

I understand that the charge controller settings are ignored and controlled by the CCGX via DVCC

DVCC is ON, Shared Voltage Sense is OFF, Shared Temperature Sense is OFF.

Any assistance to resolve this problem would be appreciated.

Thank you,

Jean

@Guy Stewart (Victron Community Manager)

battery chargingPylontechwarnings
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
Murray van Graan avatar image
Murray van Graan answered ·

Hi @JeanMc. In this case, charging is controlled by the Pylontech, which tells the system via the color control which charge voltages, and charge currents it wants. If charging drops, it is most likely because the pylontech has asked for a lower charge current. With what you are describing, the issue is with one of the pylontech batteries themselves. Most likely there could be an individual cell that generates that error, so the overall battery voltage will still be within limits. I have solved this error before by setting the system to keep batteries charged, and limiting the charge current in DVCC to 10A per battery, and leave it for 8 hours odd. This gives the battery balancer inside the pylontech time to properly balance all the cells. If this does not fix it, one of the modules would most likely be faulty and need to be sent to the supplier

6 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jeanmc avatar image jeanmc commented ·

Hi Murray,

Thank you for your reply. I will try your suggestion. I can confirm that the Pylontech BMS has reduced the charge current requirement. In CCGX, under Pylontech parameters the charge current limit (CCL) was reduced to 15A. I believe this happens when the batteries reaches 80% SOC. I have loaded the system this morning and the CCL is now at 148A at 76% SOC. Maybe these new batteries need to work a bit before I contact the supplier.

0 Likes 0 ·
Matthias Lange - DE avatar image Matthias Lange - DE ♦ jeanmc commented ·

As @Murray van Graan suggested you should make a first 100% charge with a small current to give the balancer time to do it's job.
After this first slow charge the batteries should be able to handle the full charge/discharge current from 10-95% SOC.

0 Likes 0 ·
jeanmc avatar image jeanmc Matthias Lange - DE ♦ commented ·

Hi Matthias,

Thank you for your reply. I agree with you. Prior to posting this question to the community, my objective was to allow the system to charge the batteries to 100%. I switched the Multiplus to charger only mode and the intention was to get the batteries to 100% SOC using the system defaults prior to using the inverter. The High Voltage battery alarm unfortunately occurred and hence the post.

I also implemented the 10A DVCC current limitation today along with the “keep batteries charged” setting.

The High Voltage battery alarm still occured every 13 to 15 minutes. The charge current being sent to the batteries is almost negligible (0.2A) therefore I assume this setting has no effect.

I have identified the problem unit. I have reconfigured the system using only two out of the four batteries and I am no longer getting the alarm.

However, the two batteries’ SOC remains at 80%. The charge current being sent to the battery is still hovering around 0.1 to 0.4A. The Pylontech battery parameters at this point are as follows:

Charge Voltage Limit – 53.2V

Charge Current Limit – 7.4A

Discharge Current Limit – 74A

The DCL is correct because we have two US3000 modules currently hooked up. 2 x 37A = 74A

It is important to note that when the battery reaches 80% the charge indicators on the charge controller and Multiplus changes from bulk to absorption. This is when charging stops. Although I no longer get the alarm, the batteries do not charge higher than 80%. This is with ESS mode set to “keep batteries charged” active. There is something going on when the Multiplus and charge controller switches from bulk to absorption. While in bulk mode, the batteries charges and there is no alarm. The moment the system switches to absorption the charging stops/slows to almost nothing.

Can someone please explain what exactly should happen when the system switches the multi and charge controller from bulk to absorption? I assume the Pylontech BMS communicates the SOC back to the CCGX via CAN bus. The CCGX then tells the Multi and charge controller to switch from bulk to absorption. What should happen to the charge current and voltage?

0 Likes 0 ·
Murray van Graan avatar image Murray van Graan jeanmc commented ·

Hi @JeanMc. I still think you have some unbalanced cells, and the only way to rectify this is to keep ESS mode to “keep batteries charged” for a period of time. The reason I say this is, I have several of these system running with Pylontech and normally it only starts reducing the charge current limit somewhere between 93% and 96% SOC. Anything over 98% SOC is considered fully charged, and you should also see it go there. The low current you see at this point might be the BMS doing a “rest” after a fast charge, before balancing begins. Of course this won’t or shouldn’t take hours. To answer your question, bulk charge happens when the battery voltage is below the absorption level (52V). It will switch to absorption as soon as this voltage is reached, and then current into the battery will gradually reduce whilst maintaining the absorption voltage. This stage will continue until the battery reaches 100% SOC unless the BMS interrupts this process - which I think is what you’re seeing at this stage

0 Likes 0 ·
jeanmc avatar image jeanmc Murray van Graan commented ·

Latest update:

All four batteries were reconfigured and added back to the system. ESS mode set to “keep batteries charged”. Left the system for several hours and the batteries unfortunately refuse to increase charge. The high battery voltage alarm events increased in frequency. I did notice that during the absorption phase, which kicks in at about +/- 81% SOC that the system gradually increases the voltage while restricting the current. The ESS system uses its default 52V voltage to do this. I assume this is where DVCC comes in. When DVCC is on, the system ignores the absorption charge configuration on the VE. Bus (Multi) configured via the VE config charge tab. It looks like the charge algorithm tries to condition (maybe the better term is balance?) the batteries using small charge and discharge cycles. The result is unfortunately not what we hope for.

I identified and removed the problem Pylontech module. The three “healthy” modules were added back to the system and the settings were reconfigured to match the altered capacity. ESS mode was left to “keep batteries charged”. Within half a day the system reached full capacity. The CCGX console reflected a battery SOC of 100%. The status alters between 99% and 100%. Not a single high battery voltage alarm event was raised.

I’m busy taking a closer look at the problematic module. I have removed the healthy modules and added only the problem module to the system. It obviously flooded the CCGX with high voltage battery alarms during the absorption phase. I have loaded the system slightly using the system defaults by altering the ESS mode and minimum SOC config. I have managed to get the charge up to 86%. It is a tedious process. I’m not sure whether it will go higher than this. I have not had an alarm in the past hour. Battery voltage is 51.9V. Multi is currently indicating Absorption. The current to the battery ranges between 0.2A – 0.7A with bursts up to 2A. The system also triggers small discharges using the same current values.

Here’s hoping I can recover this battery.

0 Likes 0 ·
jeanmc avatar image jeanmc commented ·

Hi Murray, "Keep batteries charged" is currently the selected ESS mode. I think what I should do is leave the mode like this, reconnect the other two batteries, configure the system battery capacity back to what it was for the 4 batteries, turn off the audible alarm beep on the CCGX and leave the system to see if it sorts itself out.

Thank you very much for your assistance.

0 Likes 0 ·

Related Resources

Victron Pylontech battery compatibility guide

VictronConnect VE.Bus charging manual  

Additional resources still need to be added for this topic