question

davidtm274 avatar image

BMV712 shows minus current when charging

Hello brains trust,

I have a BMV712 for a dual battery system in my car and I’m using an enerdrive 40amp dc2dc charging unit.
I have connected all cables, one coming off the neg of the 2nd battery to the battery side of the shunt and then on the load side I have a cable going to a bus bar and a cable going to the neg of the charger.
Could anyone help with why the BMV would be showing a minus amps (-2.3amps for example) when the charger is charging?
I have no loads connected to the bus bar and the battery is at 100%. The 2 other cables coming off the neg post are a temp sensor for the charger and a earth to the chassis.

TIA,

David

AGM Batterydischarge level
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I see a negative bus with nothing connected to it....

1 Answer
tonyjobson avatar image
tonyjobson answered ·

can you clarify what you have connected to the negative terminals of the battery bank?

There should be no cable from chassis ground to the battery. the only thing connected to the battery -ve terminal should be the shunt.

Did you calibrate the shunt at 0 amps (by pulling all your fuses and making sure there is no load / charge or discharge ?

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.