Mark avatar image
Mark asked

VenusGX + Node-RED - Modbus TCP Communication Issues


I have installed the recent VenusGX v2.42 FW build with integrated Node-RED from

I am trying to communicate with an external device via Modbus TCP (a My PV AC Thor - which is a modulated AC heater power control unit) and control it via logic developed within Node-RED.

I have successfully installed the additional contrib node 'node-red-contrib-modbustcp' and am able to communicate with the unit.

However I'm unable to setup a flow to BOTH write to the unit (with a power request) at regular intervals AND read from any registers (such as temperature) at regular intervals.

For example;

Write only - connects/works fine

Write & Read - no connection

Write & Read after a few minutes - write connects/works but read doesn't

Read only (write node deleted) - connects/works fine

I do know that a Modbus TCP read and write event can't occur exactly simultaneously (and it doesn't need to), but I'm not sure how to sequence the read/write requests or what I can change to get this working with the Modbus TCP node-set that I'm currently using...

My next step was to attempt installing a different / mode advanced Modbus contrib node 'node-red-contrib-modbus' (I have seen examples of write and read nodes successfully coexisting with this node-set) but unfortunately I get a bunch of installation errors - see below;

I have also tried to install manually via Putty using the npm install command (including the suggested variations) but still get the similar errors.

My programming/Linux skills are very limited, so troubleshooting this myself is a bit beyond me.

If anyone is able to offer some advice on how I can possibly get write and read communication working with the current Modbus node-set I'm using ( or how to get the more advanced Modbus node-set ( successfully installed on the VenusGX it would be greatly appreciated.

PS. I do know that my other option is to run node-red externally to the VenusGX unit (such as on a RPi), but I want to leave this as a last option for now.

Thanks in advance, Mark.

Venus OSVenus GX - VGXNode-REDModbus TCP
1578918593750.png (7.5 KiB)
1578918652151.png (10.9 KiB)
1578918680367.png (11.2 KiB)
1578918689863.png (11.2 KiB)
1578918744113.png (10.4 KiB)
1578919398600.png (66.5 KiB)
1578919714781.png (9.3 KiB)
1578920937522.png (17.6 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

1 Answer
gawan avatar image
gawan answered ·

Hi Mark,

were you able to fix your issues ?

I am still struggeling to connect the Modbus Node to my Venus Device ... the connection is up and running, but reading is always throwing errors . Could you give me a hint what I am doing wrong ?



1597167231114.png (8.5 KiB)
1597167241572.png (14.3 KiB)
1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

shaun avatar image shaun commented ·

Hi Gawan,

i have node red installt on a raspberry pi and running fine.

i don't know exactly what is causing the error, because i mostly copy and paste from examples and i'm happy if it works.
But you can take a look at the pictures and my test flow.
maybe you will find the problem on your system.

This is my test flow.

this is the test flow for importing

test flow.txt

the following pictures show my settings

I hope this helps you.

best regards


0 Likes 0 ·
modbus-node-red.png (40.7 KiB)
write.png (13.3 KiB)
server.png (14.4 KiB)
palette.png (29.8 KiB)
test-flow.txt (5.9 KiB)