question

cliffRaccani avatar image

Venus GX will not detect ET112 energy meter.

What am I doing wrong here?

I have been trying to get the system to recognise the ET112 energy meter but no can do.

I have a Venus GX device (Firmware v2.33) connected to a Victron USB RS485 cable which is connected to 10m of Cat6 FTP solid core cable which is connected to the ET112 energy meter in my consumer unit.

Venus GX --> USB to RS485 cable --> 10m Cat6 cable --> ET112 energy meter.


Please see pictures below for actual wiring connections.


Upon connecting to Venus device I see multiple flashes of the red led only on the Victron USB to RS485 cable.

I know its trying to tell me something about the connection but I have no documentation explaining the meaning of the flashing sequence. All I can guess is that its telling me the connection is at fault somewhere.

I then found Carlo Gavazzi UCS (Universal configuration software) which runs on Windows 10 and is designed to talk to the ET112 energy meter and configure it and just check that it is working.


I then unplugged the USB to RS485 cable from the Venus GX and into my laptop running this software.

You guessed it, It came alive.

The UCS software immediately connected to the ET112 via the same wiring and I could see that it was working!

It would seem that the wiring from my consumer unit to the USB RS485 cable is correct for the Laptop but for some reason is not acceptable to the Victron Venus device.

So if anyone out there can look at my setup and hopefully spot what I am doing wrong I would be most grateful.

I have some further pictures showing the UCS software settings.


Cat6 cable on the left to Consumer Unit and USB to RS485 cable on the right. I have double up the GND connection.


Software and version.


Software has connected to meter and is showing data.

The next few pictures show the settings for the meter.






ESSVenus GX - VGX
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
cliffRaccani avatar image
cliffRaccani answered ·

Problem solved, was a defective ET112 meter.

Thank you @ejrossouw and @WKirby.

Really appreciate your input.

Incidentally, I did not end up using any termination just worked without.

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

WKirby avatar image
WKirby answered ·

That cable run is getting long enough that you'll need terminators on each end of the cable.
There is a 120Ω resistor inside the USB converter, it is available on wired 1 and 2 (brown and red). Connect brown and red wires to orange and yellow.
On the ET112, I can't remember if there is a terminator resistor somewhere on the terminals or its a configuration parameter. Otherwise connect a 120Ω resistor on this end too (pins 4 and 5).

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

ejrossouw avatar image
ejrossouw answered ·

Hi @Cliff Raccani

May I strongly recommend you follow proper the wiring instructions below. That is if I interpret your wiring correctly from the image.

https://www.victronenergy.com/live/energy-meters:et112

The Neutral should NOT connect/feed through the ET112, but ONLY has a connection with a 0.375A fuse to the neutral bussbar. Only the Live feeds are connected.

Once that is done, see how it goes.


2 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @ejrossouw

Thanks for your reply, but that did not solve it.

Still no energy meter detected.

Since the UCS software is able to detect the energy meter could this be a configuration setting.

I notice that the Modbus Id is 1 in the USC software but the Venus OS starts Modbus Id from 30.

Does the Venus software reconfigure this and all settings for the grid meter?

Do you know what the flashing red led sequence means on the USB to RS485 cable?

Any help much appreciated.

Hi. The flashing lights on the USB connector are rx and tx indicators. There should be no reason to modify anything on the ET112 if there is only one. Indeed my suggestion was more from a "get the basics right first then work from there.

The specs of the usb device can be found https://www.ftdichip.com/Support/Documents/DataSheets/Cables/DS_USB_RS485_CABLES.pdf

Make sure you use a twisted pair as well as look into wkirby's suggestions. When I connect or disconnect my 485 cable, it shows up only after min or so . Another aspect could the the driver on the Venus. Reboot the GX if not already done and try a different usb port.

Q: Do you need such a long cable or will the 5m version work?