question

snaptec avatar image

Multiplus II GX enable ESS Mode 3

Hello everybody,

I'm trying to enable ESS Mode 3 with a Multiplus II GX.

In Ve Configure I set the GridCode and configured Inverter/Charger and added the Assistant "ESS".

I've send the settings to the Multiplus.

On the web interface of the CCGX unter Settings -> ESS is just shown "No ESS Assistant found".

Tried reboots and made a fw update to 2.33.

What did I wrong or what did I missed?


Final goal:

Have a "dump" bidirectional inverter for charging / discharging over Modbus like here:

https://www.victronenergy.com/live/ess:ess_mode_2_and_3

in Mode 3.

Multiplus-IIESS
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Zak avatar image

In "System setup"<"system name", do you have the ESS checked ?

Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

snaptec avatar image

omg, thanks Zak.

Shame on me, that was on Auto.

Now ESS is available.

Where is that documented?

I thought that this is just a name for the Display.


I think that "external control" is the right config in ESS for using mode 3 and controlling via modbus?

Anything else I should know or configurate?


The battery connected will be liion, with its own balancers and bms.

High/Low Voltages are configured.

7 comments Share
10 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @snaptec

System name has nothing to do with functionality.

ESS assistant not being available: was the Multi connected and on? if not it is not available.

snaptec avatar image snaptec Daniël Boekel (Victron Energy Staff) ♦♦ ·

its a multiplus II GX.

When its off the gx part is also off!?

snaptec avatar image snaptec Daniël Boekel (Victron Energy Staff) ♦♦ ·

Could be possible that the switch has been on "Charger only" and not on fully on. Remote Switch is not used. But I'm not sure.



Could you please confirm this?

I think that "external control" is the right config in ESS for using mode 3 and controlling via modbus?

It's hard to find the right document for configuring this scenario.

https://www.victronenergy.com/live/ess:start


https://www.victronenergy.com/live/ess:ess_mode_2_and_3

AFAIK:

generally: mode3 = external control,

mode2 = optimized, and you set the grid-setpoint and charge / discharge enable.

snaptec avatar image snaptec Daniël Boekel (Victron Energy Staff) ♦♦ ·

Thanks for your help, I think I'm on the right way.

When "No Battery Monitor" is enabled and ESS in "optimized" I can set the grid point with register 2700 on ID 100.

The Multiplus still shows Bulk/Absorption, is this normal even in Lithium Mode?


When setting ess to "external control" the Multiplus goes into ESS passthru.

On top of that ID 242 / 246 is not readable (registers 37/38/39).

They are also not readable in optimized mode.

I can write to them, but nothing happens. Maybe the last faulty bit?

Show more comments