rolfniem avatar image
rolfniem asked

SmartSolar MPPT VE.Can 150/70 Stops Charging

The setup is as follows:

  • Inverter: Victron MultiPlus-II 48/5000/70-48
  • Battery: Hubble AM2 / Freedom Won eTower
  • PV
  • Charge Controller: SmartSolar MPPT VE.Can 150/70 rev2
  • Cerbo GX
  • Cloudlink Device (with Hubble Battery)
  • PV Array 4 x 550Wp Canadian Solar. 2 strings of series panels.

The Multiplus has been configured as an ESS system to prioritise PV yield consumption.

The problem is illustrated in images below. The system works perfectly. The battery is held at the defined minimum SOC (50%) overnight. As the sun comes up charging commences through the MPPT charge controller. The system works perfectly and then, for no apparent reason, the charge controller drops to zero. The voltage is still high enough, sun is shining and battery is not at 100% SOC.

What I have tried:

  1. I have replaced the MPPT and the problem persists.
  2. I have swapped the batteries (Hubble AM2 and Freedom Won eTower) and the problem persists
  3. Checked all connections on the PV Array and all good.
  4. Power down the MPPT (PV Off/Battery Off) and restart and it will not charge. It only starts uo again the next morning.

Other observations:

  1. No error messages.
  2. I noted the Charge Controller Sate is External Control not ESS as per the Victron ESS reference document.

IMAGE 1: 31/07/2023: Around 13:26 the MPPT drops to Zero. The battery was at 100% SoC and start discharging. The PV Voltage is at around 90V which is expected yet no yield.

IMAGE 2: 30/07/2023: System performed 100% as expected.

IMAGE 3: 29/07/2023: Again, the system is performing as expected and suddenly the MPPT stops charging.

IMAGE 4: 26/07/2023: Added this to show that it does happen when the battery SoC is not 100%. Stopped charging around 11:00 when battery SoC was only approx. 68%.

ESSMPPT SmartSolar
1691344132779.png (43.1 KiB)
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

2 Answers
Lars Filusch avatar image
Lars Filusch answered ·

i have more or less the same problem, two 150/70 CAN stopp charging for no reason, SOC is farr below 100%. Multiplus is charging perfectly. Battery 2x Pylontech US3000.


sometime both at the same time sometimes the second one stops a few hours later. Then the producing only a few Watts, 5 or 10W. The system consumption is 80W minimum but no more charging. Next morning, same same but a little different. bildschirmfoto-2023-08-17-um-095537.png

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

beat avatar image
beat answered ·

Here also same issue with a MPPT 100/20 this morning, see below, mode was external control, and in VenusOS, the mode was 2 (MPPT), and plenty of sunshine on it. See attachment. If you need support access to check logs, just ask, it's my installation "test".

It stayed low at 2W instead of 500+W during minutes. I went with Victron Connect over bluetooth and tried to turn output on and off, and suddenly the load went up without apparent reboot. Below graph and state during low output.

whole morning:


in detail:


During the "off state":


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.