question

real-ark-ministries avatar image
real-ark-ministries asked

GlobalLInk 520 will not connect in Central Oklahoma USA, even with external antenna.

I have two smartsolar 50/100 that my customer wants to monitor through the VRM Portal. The blue light is blinking then turning to red, then this same cycle repeats itself. The light is never turning green and connecting. I have mounted an external antenna and it is on the roof of the house affixed to the gutter outside and it still will not connect. The zip code in the US where the install is is 73010. Would appreciate some help. Thank you.

globallink
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

3 Answers
jolir avatar image
jolir answered ·

Have you switched the GlobalLink 520 to external antenna (tiny switch by external antenna port)?

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

real-ark-ministries avatar image real-ark-ministries commented ·
Yes I did I tried it without the external antenna then ordered the external antenna and installed it this weekend and switched the selector to the external antenna. it still will not connect and I am not sure why.
0 Likes 0 ·
jolir avatar image
jolir answered ·

I can only surmise you have a faulty unit. My GL520 connected almost immediately, even without an external antenna. With the external antenna, the received power increased from around -97dBm to around -65dBm, and thus has a faster data rate.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

jolir avatar image
jolir answered ·

……or, there is no LTE-M 4G provider in your area?

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.