question

wjf avatar image
wjf asked

Global link 520 and MPPT not connecting

We have a global link 520 connected to a Bluesolar 100/50 controller via the VE Direct cable. When go onto VRM to find the device, there is no device available. Even though the lights are blinking green and yellow which indicates that 1x device is connected. Anybody have thouights on why the MPPT can't be found?

We have tried to power off and on, and also tried a different ve direct cable.....

Solar charger is working fine.

globallink
2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @WJF

What is the serial number of the global link?

Kind regards,

Thiemo van Engelen

0 Likes 0 ·
wjf avatar image wjf Thiemo van Engelen (Victron Energy staff) commented ·
0 Likes 0 ·
6 Answers
wjf avatar image
wjf answered ·

Can anyone kindly reply?? Even if you don't have the answer but may have a way to get to the solution??

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Lasse avatar image Lasse ♦♦ commented ·
Hi, @WJF I have sent you an email.
1 Like 1 ·
Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi,

Can you connect to the globallink using VictronConnect on a phone or tablet?

Kind regards,

Thiemo van Engelen

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wjf avatar image
wjf answered ·

Thanks @Thiemo van Engelen (Victron Energy staff) for the reply. We can connect to the Global link, but cannot find the MPPT in device list. The Global link has the lights blinking to say that there is one device connected to it....


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wjf avatar image
wjf answered ·

Any thoughts @Guy Stewart (Victron Community Manager) You are the wizz around here!!


2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

hub avatar image
hub answered ·

Hello, I'm new to forums, and have a similar question. In my case the GL520 shows no devices in VRM, although the local Blue Tooth network onboard already includes SmartSolar 75/15, Orion Smart, BSC IIP22 12/30 shore charger and BMV702. These all appear as local devices along with the GL520 on the Victron connect app on iPhone etc. I can find no way to "add" devices to the VRM portal. Logging into VRM via the web I see just the default voltage readout from the GL520 itself, no data from other devices. I feel I have missed a setup step, but the manual is no help on this point. Ideas? TIA

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @hub

What is the serial of the GlobalLink?

Kind regards,

Thiemo van Engelen

0 Likes 0 ·
Lasse avatar image Lasse ♦♦ commented ·
Hi @hub , if you want to use bluetooth to connect the smart devices to the GlobalLink you need to first connect to all of the devices via VictronConnect and then go to the settings of the GlobalLink via VictronConnect and enable all the devices to connect to the GL520.


If you are using VE.Direct the devices should automatically appear in VRM. If not you can try to power cycle the GL520 as it sends some data every 24 hours and at first boot and other data every 15 minutes.

0 Likes 0 ·
Lasse avatar image
Lasse answered ·

Fixed with a change required on Victron's end, thanks for reporting @WJF

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

wjf avatar image wjf commented ·
Thanks a lot for sorting that @Lasse
1 Like 1 ·