question

teloth avatar image

" Mandatory " Smartsolar update v1.56 killed VEDirect to VEDirect cable communication?

Early this morning I was presented with V1.56 " Mandatory " update on 150/60 Smartsolar that connects to my Multiplus II via VE direct port.


Immediately after the update finished , the controller vanished from VRM.


I have two other SmartSolar 150/35 , both of these are connected via VE.Direct to USB , that goes on a USB hub , that connects on the USB port on the MultiPlus II.


I have also updated both of these 150/35 to same V1.56 and both of them still reporting to VRM.


I swapped cables over , and 150/60 does indeed work on the VE.DIrect to USB.


Also tried the VE.Direct to VE.Direct cable on both of the 150/35 controllers , no joy, no connection.


So, this update definitely must have done somerhing that effects VE-Direct to VE.Direct link communication.


mppt smart solar
1 comment
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

I have upgraded both the camper and the show trailer to latest SmartSolar firmware 1.56. Connected to PI via USB to ve.direct without any issues so far

3 Answers
teloth avatar image
teloth answered ·

Hi Matthijs

You should be a magician !

You made my SmartSolar appear again on Ve.Direct to VE.Direct cable :-)

Came home , had a nice ice cold beer to calm my general firmware update fears , done the V2.66 update on the GX and all is good now.

Many Thanks again


2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Guy Stewart (Victron Community Manager) avatar image
Guy Stewart (Victron Community Manager) answered ·

Hi @Teloth

Is this an official Victron cable with the Victron insignia, or a self-made cable?

If you are certain it is a genuine cable, please get in touch with your supplier about a replacement to see if that resolves the issue.

8 comments
2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi Guy and others for feedback.


Yes, the cable is a genuine Victron Ve.Direct to VE.Direct cable that has been in use for months and not has been touched.


Just to re-iterate couple of points, the VE.Direct to USB cable still works.

VE.Direct to VE.Direct cable does not.


Also , as I said , the moment the update is done , the Smartsolar 150/60 controller ( that was connected via VE.Direct to VE.Direct , on the single VE.Direct port that is on the Multiplus II ) , immediately disappeared from VRM and not obviously reporting solar yield which throws off Battery percentage values etc , even though charager still charges the battery.


I know it is weird but this is how it is.

The cable has not been touched whatsoever, it would be a trillion in 1 coincidence that it happened split second after update finished on the SmartSolar , cable not touched and this happened surely.

Can some more people see if after updating Smartsolar to V1.56 and see if VE.Direct to VE.Direct communication transmission still working and report please?

Thanks

Morning! Sorry for the troubles!

I (a) tested several test systems like yours in our lab, ie. MP-II GX + MPPT with a VE.Direct connected MPPT, all work well.


and then (b) looked your system up in VRM. Where I noticed that your GX firmware is not the latest fw, its on v2.57. Could you update that?


v2.66 is the latest version iirc.


if that doesn’t work; I’ll make a support case and have someone help you with this in more detail (by logging into your system remotely, preferably).


we’ll get this sorted one way or another.

Matthijs


ps. for any one else reading this: there are already 100s of not 1000s of MPPTs running on v1.56. All OK, so I am not worried about a large systemic issue

teloth avatar image teloth mvader (Victron Energy) ♦♦ ·

Hi Matthijs

Thanks for the reply.

Could you please confirm you are indeed using VE.Direct to VE.Direct cable ( and not the VE.Direct to USB ) in your tests. Between SmartSolar and Multiplus II GX ?

Sorry , asking this as you just said VE.Direct cable.

The firmware , yes, have not updated since purchase about a year ago , as everything worked beautifully as it should , and I did not want to jeopardise anything by doing an update , just for the sake of it. I am a bit paranoid like that :-p

I am using a Multiplus II GX 48/3000 right now and I have a Multiplus II GX 48/5000 on order and due in a week or two.

My intention is to keep the 3000 as a spare backup unit.

I suppose I will see what happens on the 5000 , when it is installed.

In the meantime , I ordered another VE.Direct to USB cable until new Multiplus comes , as I know those are still working, confirmed by swapping cables around.

Hi, yes, ve.direct to ve.direct cables.

For us to look into it any further, you’ll have to do the firmware update of the GX Card. Remote Console -> Settings -> Firmware update.

I can understand that you could be a bit wary of that now; but I really recommend it. Matthijs

teloth avatar image teloth mvader (Victron Energy) ♦♦ ·

Hi Matthijs

Sorry , I thought you meant the main inverter firmware. Which I never updated since day one. ( for which , I do not have the cable for anyway ) As I understand this can only be done by MK3-USB Only , is that right?

Yes, I did update GX couple of times previously , which I can do that.

But I still prefer to wait when the new one , 5000 arrives , prior to installation to test.

Just in case ...

Thanks

Hi Again,

No problem, I'll get an email once you're ready and have posted the result here.

Yes I don't mean the Inverter firmware. Which you can update now by the way, even without MK3-USB, see here:

https://www.victronenergy.com/live/venus-os:remote_ve.bus_firmware_updates

That's a new feature, quite recently introduced.


Matthijs.


teloth avatar image teloth mvader (Victron Energy) ♦♦ ·

Hi Matthijs

Many thanks for taking time with replies and help.

Have been very helpful.

If you were in the area , I would make you a nice cup of freshly ground coffee and serve it to you with a nice cookie, to show you my appreciation ;:-) , socially distanced of course !

That is a nice feature that you guys introduced , regarding firmware update , without the need of MK3. I am still scared to do the main inverter firmware though , as it works all OK.

Would you have the time to take a look at the other thread I posted few days back , but not had any official replies / feedback on?


Titled " Last 24h stats disappeared from VRM , web and also from the app "

Many thanks

I thought you meant the main inverter firmware. Which I never updated since day one. ( for which , I do not have the cable for anyway ) As I understand this can only be done by MK3-USB Only , is that right?

Since GX firmware 2.65 you can update the VE.Bus inverter firmware via VRM (without using a MK3-USB interface).


I ordered another VE.Direct to USB cable until new Multiplus comes , as I know those are still working, confirmed by swapping cables around.

You could also order a VE.Direct cable, just to rule that out. It is cheaper than a VE.Direct to USB cable.

seb71 avatar image
seb71 answered ·

Mine still work with VE.Direct cables after update to v1.56, but the difference is that I have a Cerbo GX, not a Multiplus II GX.


It would be a bizarre coincidence, but maybe check the VE.Direct cable you have.

2 |3000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.