question

asbjoern85 avatar image
asbjoern85 asked

Smart Solar MPPT 100/20-48 disables load output about once a day

Hi,

My Smart Solar MPPT 100/20-48 disables load output for a few seconds about once a day. I'm running the latest firmware. It get's really annoying as I have a gass alarm that beeps LOUDLY 5 times when it's gets power back, really fun when it happens while were sleeping.


Any idea what's causing this? Is there an event log I can review somewhere?

MPPT Controllers
9 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi @Asbjoern85

What firmware version is running on the MPPT?

Kind regards,

Thiemo van Engelen

0 Likes 0 ·
asbjoern85 avatar image asbjoern85 Thiemo van Engelen (Victron Energy staff) ·

It's at the cabin, so I can't check. It was the latest firmware available when I checked the 17th of January.

0 Likes 0 ·

Do you perhaps know which VictronConnect version you had / have installed? You can find this under Settings.

Kind regards,

Thiemo van Engelen

0 Likes 0 ·

And did you also go into the settings menu to check if it was the latest firmware version or not? I ask this, because in the past, VictronConnect would update to every new firmware version at the moment that you connect. Currently, VictronConnect does not always force a firmware update. It does require this (most of the time) when you go into the settings menu and want to change a setting.

I mention this all because the problem you describe looks like a problem that is solved in Firmware version 1.54, which is included in VictronConnect 5.35. It is however not mandatory to update to this firmware version if the MPPT has version 1.50 or newer. IT only needs to be updated to 1.54 when you want to change a setting. And I believe the Product Info page also shows whether the latest firmware is installed or not.

Kind regards,

Thiemo van Engelen

0 Likes 0 ·
asbjoern85 avatar image asbjoern85 Thiemo van Engelen (Victron Energy staff) ·

I used Victron connect v5.35.


Yes, I went in and check, it said it was the latest version on the SmartSolar.


I can verify if it is in fact running v1.54 next time I'm at the cabin, but that could take weeks. It's promising that the bug sounds familiar to you.

0 Likes 0 ·

The bug sounds familiar, but as said, it was solved in firmware version 1.54, so it should be solved in your MPPT. Next time that you are there, can you please make a service report and store a settings file and post them here? This might help us to analyse and reproduce the problem.

Kind regards,

Thiemo van Engelen

0 Likes 0 ·
asbjoern85 avatar image asbjoern85 Thiemo van Engelen (Victron Energy staff) ·

I hope I have an earlier firmware then. I'll make the service report and export the settings file for you next time. Thanks for the help so far.

0 Likes 0 ·
asbjoern85 avatar image asbjoern85 Thiemo van Engelen (Victron Energy staff) ·

Hi again @Thiemo van Engelen (Victron Energy staff)

I was at the cabin this weekend and saved the report and settings file for you. I was running version 1.54, but I still have this issue.

Here is the report, the forum wouldn't allow me to upload the settings file, do you have an email I can send it to?

VictronConnect_report.log


I noticed another bug in the MPPT, the "Low temperature cut-off" can be set as low as -10°C, but when I click ok, it saves it as 0°C. This setting is important to me and I would appreciate if you could look into it.

0 Likes 0 ·

Hi,

Do you have a jumper on the VE.Direct port of the MPPT and if so, at which position?

Kind regards,

Thiemo van Engelen

0 Likes 0 ·
4 Answers
asbjoern85 avatar image
asbjoern85 answered ·

I can add to the story that the 100/20-48 is new and has done this from the beginning. The Smart Solar MPPT 75/15 it replaced worked perfectly.

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi,

The load output of the MPPT is also disabled for 1.5 seconds when an overload situation is detected on the load output. This would mean a load current >20 Amps, even for a very short spike. Could this be the case in your situation? Were there any other changes in the DC system when it was switched to the 100/20-48V?

Kind regards,

Thiemo van Engelen

2 comments
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi,

I doubt very much there was an overload event, it happened during the night in most cases with a more or less constant load of ~6W. If I switch on all DC devices at the same time, the load is still less than 20A.

The other change to the DC system was going from 12V to 24V and the addition of Orion 24-12 DC-DC convertes.

0 Likes 0 ·

I can add that I'm not sure if the MPPT disables the output momentarily, or if it crashes and reboots with the same result.

0 Likes 0 ·
Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi @Asbjoern85

I was wondering whether you were already able to test if the problem also occurs when the load output setting is not set to "Battery Life"?

Kind regards,

Thiemo van Engelen

1 comment
2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.

Hi, i did change the setting from "Battery life" to one of the other options, it still happened twice this weekend.

0 Likes 0 ·
Thiemo van Engelen (Victron Energy staff) avatar image
Thiemo van Engelen (Victron Energy staff) answered ·

Hi,

This problem should be solved with MPPT firmware version 1.56, included in VictronConnect version v5.40. Can you please test and confirm that it is now indeed solved?

Kind regards,

Thiemo van Engelen

2 |3000

Up to 8 attachments (including images) can be used with a maximum of 190.8 MiB each and 286.6 MiB total.