veflash Image

veflash

MK1 Multi 48/3000 "Bootloader" LED indication

Mulitplus Indicating Bootloader LED error. Victron toolkit app states to recover firmware on the chip using VE.Flash. Is this even possible or is the chip stuffed?

I tried to proceed with the process of VE.Flash but it wouldn't connect to chip.

BarendVDevill asked
Daniël Boekel (Victron Energy Staff) answered ·

1 Answer

Quattro 3k firmware update failure

Hello,


I tried to update my Quattro but the process failed. I have tried several options and no success so far and need to help to get back on track.


The equipment:

- Quattro 12|3000|120, PCB version 010021-4, original FW 1931119

- UTP cable of 1 meter

- UTP cable of 2 meter

- MK2 (I don’t have an MK3)

- Windows 10 DELL notebook with latest VE toolset

- Windows 7 desktop with latest VE toolset


What I did:

1) I downloaded the firmware from the professional Victron site. I have now two files: 1931159.vff and 1931209.vff

2) I stated VE-Firmware on my notebook and followed the instructions. I selected the 1931159 firmware without the assistant support.

3) I made sure that the dip switches were set ok (DS1-off, DS2-on)

4) At first the boot-loader was updated. This went apparently well, as subsequently the firmware was updated.

5) The update failed during the postprocessing phase (a windows pops up labeled: updating / post processing and shows a progress bar. The progress bar stops at about 80%.

6) A “General Failure” is reported and I can only click “OK”, after which the application is terminated.

7) I repeated the process, with hopes that a second time the update would be successful. The bootloader was not updated this time. The general failure appeared at the same moment.


I have recorded the process, see movie at: https://www.dropbox.com/s/92r7y4s6qw53ew9/Quattro_FW_Update_failure.MOV?dl=0


8) For a second try I used a desktop with Windows 7. I also downloaded the firmware again from the professional Victron site. The process of updating and failing is identical to the notebook process.

9) I now tried it again with the 1931209 (with assistant support) version of the firmware. Same result.

10) Next, used a longer cable, no result again.


I now have an unusable Quattro with 8 flashing LEDs. My questions:

a) What to do? How can I make the update work?

b) What happens at about 80% of the postprocessing phase? Is this a CRC check for example?

c) What is exactly going on? A “General Error” is not providing my any guideline to resolve the situation. Is there a log file, or can I enable generating one?


Thanks in advance for your help.

Bertus

Bertus asked
WKirby answered ·

2 Answers

Has anyone tried using VEFlash via Wine?

I don't have a Windows laptop currently, and would like to keep it that way, so I have been running VEConfigure via Wine on Linux which seems to work perfectly well. I would like to be able to do the same with VEFlash, but I know the consequences of something going wrong there are potentially significant. I'm quite familiar with embedded Linux, and am used to flashing things via serial or JTAG from the command line, so if there is a way to achieve this for Victron products too I'd love to hear it.


Otherwise, has anyone here tried flashing a Victron device using VEFlash on Wine?

aeneby asked
aeneby commented ·

5 Answers

3 Posts
9 Users
0 Followers

Topic Experts

There are no topic experts for this topic. Participate in the posts in this topic to earn reputation and become an expert.

Related Topics