ios app Image

ios app

This topic was meged into VictronConnect

Victron Connect constantly reconnects to SmartSolar MPPT 100/50

I am using the latest Android app (June 19th) and firmware (1.50). When the app is connected on the "home screen", it will reconnect constantly, every 15-20 seconds, and it *always* reconnects if the app was in the background, or the screen locks - which is super annoying.

kev_rm asked
Matthias Lange - DE answered ·

1 Answer

Smartsolar/victron connect reporting - Can the date and time be changed?

I'm connecting to my 75/15 and 100/20 controllers via the victron connect app.

When connecting to the 75/15, there seems to be a problem in that the reported yield for the day is split over multiple days. Almost as if it is working based on a different time-zone or something.

For example. I cleared all the history a midnight. This morning the yield has been 130w so far, yet when checking via the app (in all it's forms) It is showing a yield of 90w as yesterday and 40w as today.

The reporting on the other controller, is working fine, it's just the 75/15 that seems off.

I've not seen anywhere in the settings where I can tell it what the current date and time is in order to get accurate reports.

mikedefieslife asked
TurboJens answered ·

9 Answers

Will smart solar ve.can be configurable in victron bluetooth app?

Hello,

Happy user here. We just got a new MPPT 150/100 Smart solar VE.CAN

and a tad disappointed to see that ve.can can not be configured remotely via the VRM and Victron app like the other ve.direct gear.

Might that be added in a future update I wonder?

It is a really great feature for our other Victron gear and really useful for our remote off-grid installation..

Many thanks for listening.

houser asked
houser edited ·

2 Answers

No remote Console in Victron Connect

With a Cerbo GX firmware 2.54 and new Iphone SE OS 13.4.1 and on a macbook pro with OS Seirra, the Rremote Console is NOT available. The Cerbo gets seen, connected via bluetooth, but there is no option to get to the remote console, the only way to control the Cerbo, is via VRM and that is painstakingly slow. Has anybody seen this ? the fact that it seems to happen on several devices makes me believe this could be a bug. All devices are also on the same wifi network and trying the venus.local/app/ wont work (ip address subsitute also will not resolve anything)

pyemarine asked
Daniël Boekel (Victron Energy Staff) commented ·

3 Answers

2 devices (MPPT 100/30 + Multiplus 800) via one VE.connect dongle: is this possible?

Hello,

I bought a ship on which an Multiplus 800 with a Digital Multi Control panel is installed and also a MPPT 100/30 with a VE.Direct Bluetooth dongle. With the app I'm able to monitor the solarpanels/MPPT but I really would like to monitor the Multiplus 800 also via the app via the same bluetooth dongle (otherwise I have to buy a second dongle and switch between bluetooth-instances?).


Is there a possiblity?


Kind regards,


Pim

Pim asked
Matthias Lange - DE commented ·

2 Answers

Victron Connect (Mac OS) and Smart Batteries

I have 4 x 12,8/200 Smart batteries, a charger and smart battery protect. I can connect via bluetooth to all the devices from my iPhone, however from my Mac I can only connect to the charger and smart battery protect, when IU try and connect to the batteries, it sits at 20% connected.


Anyone have any ideas.

Bathnm asked

0 Answers

VictronConnect-Remote (New Feature) not Connecting

Hi. I have a RPi running Venus OS temporarily since I can't get get Cerbo GX in stock just yet and would like to demo the system before I go to far. I cannot get the Victron Connect App to connect to the new VictronConnect-Configure feature they recentely released to fully control the devices remotely. It fails at 40% with error "MQTT-RPC Unable to connect to the RPC broker. Configuring the device is not possible. Error Code: 8"

-Venus/RPi connected to VRM and logging data every 15 min as expected

- Remote console is working as I can change *some* settings via the online portal

- VRM portal shows connection to Venus "Online" with green check mark

- Venus OS v2.54, 2-way VRM connection is enabled

- Using MPPT-->VE-direct cable --> USB converter --> RPi. Not 100% clear if this is supported


One of the big reasons I purchased this system is to remotely control a fridge connected to load of MPPT. I really need to know if this will work with Cerbo GX or if I'm dealing with some network issue which I am not sure how to debug

pyro asked
pyro answered ·

2 Answers

VE Direct to USB data to VRM Portal Advanced Tab

I have 3 VE Direct cables to my Cerbo (from 3 MPPT controllers) and 1 VE Direct to USB cable (from a MPPT 100/20) all to my Cerbo GX. I receive detailed data on the VRM Portal for the 3 MPPTs connected by the VE Direct cables, but I do not receive any of the detailed information on the Advanced Tab on the VRM Portal for the MPPT that is connected to the Cerbo GX by the VE Direct to USB cable. How can I add that detailed info to the VRM Portal from the VE Direct to USB cable and MPPT? Thank you.

gscriba asked
gscriba commented ·

1 Answer

Victron connect roadmap, grid code ?

Is there a public roadmap for features in victronconnect?

I see the statement that it is to be a replacment for veconfigure. Also it say grid code not yet supported. When will it be supported so I can use it to configure the grid code in a multiplus 24/800 (small form factor) via bluetooth (using the appropriate dongle)?

By the way, I am a bit confused by the demo library, which have support for multiplus 24/800 but not with a picture of the small form factor variant. Both variants share the same name as far as I can tell. Are both variants supported?

Rikard asked

0 Answers

Conection to Multiplus with MK3-USB not possibile

Hey Guys,


I can´t connect to my Multiplus 12/1200/50 I followed the instruction of the victron videoI found here, https://www.youtube.com/watch?v=6lH3mF2cVaY&t=6s I tried using both a mac and a win 10 laptop, both with the same result, that the Victron connect or VEConfig app won´t go beyond the point “fetching data from VE-Bus” and then times out. I double checked the drivers in windows and COM port 7 uses FTDI driveres I also tried the VE Config app with “auto detect port” and manualy selected both com3 and COM7” with the same result that it can´t connect. If I go to force connect it times out as well.

If I use a Color Control on the VE-Bus port the Multiplus is recognized but I can´t really change any setting or setup an ECC.


From the Color Control I see the following firmware details of the Multiplus.


Productcode:2662

Fimrware 416

Device Instanz: 257

VE.BUS Version: 2662416

MK2 Device MK3

MK2 version 1170207


Any help on how to properly connect would be very much appreciated!

Thanks for your support.

rene_klose asked
Jordi.Fax commented ·

1 Answer

Does the mppt (75/15) also get energy from the battery?

I have a victron 215WP solar panel connected to my MPPT 75/15 controller which is connected to my leisure AGM battery.

When there is no solar power, I can't seem to connect my phone to the MPPT. Is this normal? or does the MPPT normally takes power from the battery?

+ can you in some way check with the victron connect app the charge status of the battery?

thanks!

yarrut asked
dazey77 answered ·

1 Answer

Is this thing actually working?

BMV 712 Smart, house battery is a Battleborn LiFePO4 100 Ah which is charged through a Redarc BCDC (no solar yet) - settings are

Batt. Cap. 100 Ah, Charged Voltage 13.9, Discharge Floor 20%, Tail Current 4.00%, Puekert Exp. 1.05, Eff. Factor 99%.

Relay: Low SOC 20% (all alarms by default set to Disabled).

Display: all set to on except Mid-voltage display.

Misc: Shunt current 500A, Shunt voltage 50mV, Aux input Starter battery.

Since initially setting these settings there has been no difference to the display, or percentages.

I'd like to be able to see the current state of charge for both the house (aux. LiFePO4) and the vehicle start battery: how and what do I need to do differently to see the actual state of charge of both?

Thank you.

Mike Smalley asked
irwinr answered ·

1 Answer

Victron Connect has stopped working

I have an Asus pc which is connected all-time in my Victron mppt's

i recently made a format and reeinstalled windows 7 ultimate genuine software

everything in the pc is working flawless, but

when i installed the victronconnect and run it

i get a message " the program has stopped working" and "close the programm"

i cannot run it and get a blank window with this message.

i tried to run it as administrator but, same thing

i saw in properties that victronconnect is running compatible to windows xp sp2

i even changed this to run it in compatibility with windows 7, but same thing.

i even tried to download v4.3 which i had before and was working with no problem but, victron is giving me only v5.19

i even ran a winfix utility for everything in the system but, no glitches no corrupted or missing files and no problems.

i've spended 5 days trying to make it run.....no results

please advise


( i'm having bbq fish to ease my sorrow )

christos asked
Jaco Reinecke answered ·

1 Answer

Victron 100/30 battery Voltage inaccuracy

My Victron charge controller seems to think my battery voltage is higher than it actually is according to my BMS 712. This seems to cause the charger to go into float mode too early and not fully charge my battery. Only seems to charge to a little over 80%. You can see from the screenshot below that my charge controller thinks my battery voltage is 14.2 but it is actually only 13.47. FYI: I am running 200 amp hours of battle born lithium batteries. Any way to remedy this?

[image]

Michael49 asked
klim8skeptic answered ·

4 Answers

VictronConnect 5.26 update - disabling eq with lithium batteries meh

So the new 5.26 update “Disable equalization voltage setting when lithium preset is selected”...


This is really annoying. I understand why it’s been done - presumably to stop people inadvertently cooking their nice expensive batteries, but I’ve happily been using this to charge my batteries up to 14.4v every 10 days as my absorption voltage setpoint is lower. It’s been really nice to have that happen without having to do it manually or worry...

I assume I can probably get around it by changing to a different preset and setting everything up manually again but it seems like a backward step - would be nice if the option was still available even if locked away in the expert settings...


or maybe you could implement a feature whereby we can do a slightly higher voltage charge periodically and call it something else so there’s no confusion??

adev asked

0 Answers

Cannot find Multiplus Compact in VictronConnect

Using VictronConnect through the MK2 USB interface, I am not able to find my Multiplus Compact.

Is the MK3 USB adapter required for this to work, or am I doing something wrong?

Posse asked
Matthias Lange - DE answered ·

1 Answer

Documentation for Victron Connect

@Guy Stewart (Victron Community Manager)

Hi Guy, Suggest at Paragraph 3.1 of the Victron Connect manual that you add the limitation for the VEBus BMS assistant... correction to my last version.

This edit update - the later info clearly identifies the VEBus BMS assistant under the lithium battery 'wizard' - as a limitation; note however I did not want the wizard as I knew what parameters I wanted.

Is this limitation for ALL assistants?

Cheers Mike

Michael Riley asked
Michael Riley edited ·

0 Answers

How good is the remote feature of Victron Connect!!!

I need to get this of my chest :-)

I'm working with a lot of tech of different sort. But Victron gear is just a highlight for me. I run 30 sites now and the ability to remote control MPPTs and BMVs leaves me ecstatic.


Big ups you guys!

MarioWagner asked
MarioWagner answered ·

2 Answers

Powershell Script to join CSV and add Date to CSV Export from VictronConnect

I have written a Powershell Script which will join the CSV Export Files from Victron and add the Date to a column. I will provide this as is and cannot guarantee that it works for all and with all future exports. But maybe it helps...

Copy the code into eg. Merge_Files.ps1 and load eg. in Powershell ISE

Please edit the variables at the top of the file.

I will not do any kind of support for the script! Its community based!

I am not at all affiliated with Victron and dont get paid or whatever for this.

<#
Version: 1.0
Created on: 08.06.2020
Author: Thorsten Lambrecht
Notes: 
IMPORTANT: Names of the CSV have to be: YYYY-MM-DD_AnyName.csv
Date in the Name has to be date of the export, as this is the calculation base!
The output file will by default be saved in the Script Directory
Version:
1.0 Start Version
#>

$CSVFilesPath="c:\temp\VictronExports\*.csv"
$OutFilePath=$PSScriptRoot

#Get the List of all CSV Files
$CSVFiles=Get-ChildItem -path $CSVFilesPath
#Work on the CSV File by File
$AllValues=foreach ($CSV in $CSVFiles) {
    #Import the Export-Date from the Filename of the file
    $DatumStr=($CSV.Name -split "_")[0]
    #Convert the Date to a PS Datetime
    $Datum=$DatumStr -as [datetime]

    #Import the current CSV and skip first element, as it is usually Day "0" and we dont know, 
    #if day 0 is the complete value, unless values were exported at the end of the day in the dark
    #if you dont want to skip line "0" comment "-Skip 1" Line with a #
    #Values will be converted to appropriate types, as the general import would put them to NoteProperty.
    #Dont know if the errors are really int values, as I never had errors!
    $CurrentFileImport=Import-Csv  -Path $CSV.FullName -Delimiter "," | `
        select-object `
        -Skip 1 `
        @{Name="Date";Expression={$Datum.AddDays(-($_.'Days ago'))}},`
        @{Name="Date exported";Expression={$Datum}},`
        @{Name="Days ago";Expression={[int32]$_.'Days ago'}},`
        @{Name="Yield(Wh)";Expression={[int32]$_.'Yield(Wh)'}},`
        @{Name="Consumption(Wh)";Expression={[int32]$_.'Consumption(Wh)'}},`
        @{Name="Max. PV power(W)";Expression={[int32]$_.'Max. PV power(W)'}},`
        @{Name="Max. PV voltage(V)";Expression={[Single]$_.'Max. PV voltage(V)'}},`
        @{Name="Min. battery voltage(V)";Expression={[Single]$_.'Min. battery voltage(V)'}},`
        @{Name="Max. battery voltage(V)";Expression={[Single]$_.'Max. battery voltage(V)'}},`
        @{Name="Time in bulk(m)";Expression={[int32]$_.'Time in bulk(m)'}},`
        @{Name="Time in absorption(m)";Expression={[int32]$_.'Time in absorption(m)'}},`
        @{Name="Time in Single(m)";Expression={[int32]$_.'Time in Single(m)'}},`
        @{Name="Last error";Expression={[int32]$_.'Last error'}},`
        @{Name="2nd last error";Expression={[int32]$_.'2nd last error'}},`
        @{Name="3rd last error";Expression={[int32]$_.'3rd last error'}},`
        @{Name="4th last error";Expression={[int32]$_.'4th last error'}}
        
    $CurrentFileImport
}

#Now Group the values by Date, so that we see, which dates are overlapping
$Grouped=$AllValues | group-object -Property Date

#Now make a clean list, which will take only the Date-Line with the highest Yield, as this seems the full value
$CleanedList=foreach ($Group in $Grouped) {
    ($Group.Group | sort-object -Property 'Yield(Wh)' -Descending)[0]
}

#Export both lists to files. "AllValues.csv" is more as a reference to see, which lines have been doubled
#Output will be sorted Ascending, if you want Descending, add "-Descending" 
$AllValues | Sort-Object -Property Date | Export-Csv $OutFilePath\AllValues.csv -NoTypeInformation -Force
$CleanedList | Sort-Object -Property Date | Export-Csv $OutFilePath\CleanedList.csv -NoTypeInformation -Force


Mr-Fly asked
Mr-Fly answered ·

1 Answer

Victron Connect History showing actual days, not active solar days as expected

I have a SmartSolar 100/30 MPPT which is connected to my RV - so it sees intermittent use - around 50 days per year. I happy with the performance of the unit - and the charts and graphs really helped me understand and track our electricity usage. However during one of the constant updates, the behavior of the History feature changed - happening maybe the last quarter of 2019? Previously, each day in the history was triggered by a charge cycle - the solar panel seeing sunlight and charging the battery. Times / days when the panel was disconnected from the system were ignored. And my panel is disconnected / dark when the RV is not being used. This app behavior was exactly what I wanted to see.

Subsequent to this fateful update, the History chart is now determined by calendar days - apparently by the clock in in the smartphone. Now all the days in between my RV trips are filled in with blanks - making the History function mostly useless for me. How can I get back the previous functionality? For stationary application - where the solar system is used every day, this change doesn't make any difference. But for me - where I use the solar system intermittently - this change crippled one of the most useful tracking features in the software.

JeffB asked

0 Answers

MPPT Solar Charger - showing only charged volume? How to see total potential solar if battery is full?

Hi guys,


I'm using a SmartSolar 75/15 with a 180W solar panel for some weeks now and I noticed the following:

the VictronConnect app does not show me the effective power the solar panel COULD produce but only the one it used to charge the battery. So when the battery is full then I have just a few watts produced during a nice sunny day.

But I want to know what the solar panel would be capable to produce to check how much of the theoretically 180W it would give out in certain conditions.

Is that possible with VictronConnect or what have I got to do to get these values?


Thank you very much


Andreas

lemon asked
spirou commented ·

2 Answers

What is a VictronConnect Service Report? How can I read it?

Can anyone tell me how to create a service report that's legible? The ones I get, are unreadable bunch of characters....


surgicalpro asked
Guy Stewart (Victron Community Manager) answered ·

3 Answers

Using Excess Solar Power? USB to SmartSolar Charge Controller

Is it possible to connect a USB socket directly to a charge controller to get USB power during the day time? Possible use is where I don't have a battery bank in place yet want to charge mobile phones and iPad.

SteveCounsell asked
MaxxManic edited ·

1 Answer

VictronConnect feedback - Why force firmware update for MultiPlus?

Hi,

I had a call out tonight to check the programming of a Multi and brought the (Linux) laptop with VictronConnect. Many thanks btw for making that available: we're on our way to one less requirement to keep Windows :-)

I could however not use it as VictronConnect wanted to upgrade the firmware of the Multi before it would do anything else. That was a bit inconvenient and also seems to contradict the advise not to upgrade firmware unless you have an issue, want a new feature or need support.

The firmware of this particular Multi was upgraded only last week after installing a new battery bank.

Upgrading would have taken me too long this time of the day, especially since VictronConnect cannot retain all the settings, thus requiring the use of a Windows PC with VE.Configure to retrieve those settings first.

Is there a reason why I can't simply tell VictronConnect to ignore the firmware upgrade (for now)?

thanks,
Jan


jbakuwel asked
Guy Stewart (Victron Community Manager) commented ·

2 Answers

Blue Smart Charger advanced settings

Hi,
in the demo library of the current VictronConnect version you have the possibility of advanced settings in the Blue Smart Chargers(at the bottom after changing from "normal" to any other preset).
In this advanced settings you have a lot of settings to change.
But with a real charger this option is not available.
Will this be a future feature or is it a bug in the app. If it is a future feature when will it be available?

Greetings from Germany

Matthias Lange - DE asked
bjornb commented ·

3 Answers

Running old versions of VictronConnect on Legacy iOS devices

Hi

It would be a good situation if old iPads could be used as monitors for Victron systems. Can you continue to support old devices with Victronconnect, eg iOS 9.

Dunk O asked
Matthias Rethage commented ·

2 Answers

Victron 75 /15 status Batterie aus
  1. Seit letzter Update ladet victron 75 /15 erst ab 18uhr vorher steht Zustand aus WIESO KANN MIR VIELLEICHT JEMAND HELFEN

[image]

aus

[image]

Dia asked
Dia answered ·

3 Answers

Can VictronConnect Export file include the date?

Please add the date to the export. Right now Export only contains days back, so basically I have to fill that in By myself.
if I archive these Csv, I have to also remark the date when it was exported otherwise the file will get useless.

Mr-Fly asked
Mr-Fly answered ·

5 Answers

VictronConnect Demo Library anomalies


This is more an observation than a question…


I find the Demo Library in VC a very useful tool for selecting the right product for a project and understanding the capabilities and limitations that are not always so evident from reading the manuals or datasheets. It provides a virtual ‘test drive’ of the product before committing to purchase it. Sometimes I even pre-configure a device in the demo library, save the file and just load it when I install the device. But mostly I use it to check or cross-check product features. For example, I want to use a programmable relay in an MPPT to do some switching based on certain conditions and need to understand what options I have. Doing a 'test drive' helps confirm I can do what's intended.

That’s when I noticed some oddness in the Demo Library…


In the Solar Chargers section there are quite a lot of duplications and a couple of errors. Perhaps the duplications stem from the two versions (Tr and MC4) but they functionally identical as far as configuration is concerned and shouldn't be there.


In sequential order, the problems I noticed are:


· BlueSolar MPPT100/30 – listed twice


· BlueSolar MPPT100/50 – ditto


· BlueSolar MPPT150/35 – ditto


· SmartSolar MPPT150/100 – listed 3 times and last one incorrect*


· SmartSolar MPPT150/45 – listed twice and both incorrect*


· SmartSolar MPPT150/60 – ditto*


· SmartSolar MPPT150/70 – ditto*


· SmartSolar MPPT150/85 – listed 3 times and last one incorrect*


· SmartSolar MPPT250/100 – listed twice


· SmartSolar MPPT250/60 – ditto


· SmartSolar MPPT250/70 – ditto


· SmartSolar MPPT250/85 – ditto


· SmartSolar MPPT VE.Can 150/100 – ditto


· SmartSolar MPPT VE.Can 150/70 – ditto


· SmartSolar MPPT VE.Can 150/85 – ditto


· SmartSolar MPPT VE.Can 250/100 – ditto


· SmartSolar MPPT VE.Can 250/70 – ditto


*These devices don’t list the Relay in the Settings menu. I’m pretty sure they have the same relay as the 85A and 100A versions – unless the manuals and datasheets are wrong. (I've only used the 150/100 so not 100% positive about the /45, /60 and /70 models).


And in the Inverter/Charger (VE.Bus) section..


· MultiGrid 48/3000/35-50 – listed twice


· And the MultiPlus-II 24V version is not there (yet?)


There may be others but these are the ones I noticed.


I know it would be a big job keeping everything up to date but I think this tool should be treated as a 'source of truth' - ie accurate information - about product capabilities.


Cheers

Phil

dunnp asked
Guy Stewart (Victron Community Manager) answered ·

1 Answer

Connect Dashboard

I have a BVM712 & Smart Solar MPPT100/30 I connect via Bluetooth on my iPhone and its great. But finding it a bit of a pain having to keep switching between devices. It would be great if the iPhone had a dash board section that you could add information from both devices too, so on one screen I could see all the things I keep checking.

I saw someone did build one but it was with a website, and more hardware then I have.

Did I miss something in the docs or is this even possiable?

TimDoring asked
TimDoring answered ·

3 Answers

Followers

271 Posts
6 Users
2 Followers

Topic Experts

There are no topic experts for this topic. Participate in the posts in this topic to earn reputation and become an expert.