dbus Image


This topic was meged into Venus OS

Relays and Battery Data on Venus GX Disappeared

My Venus GX has been installed for 4 months and working perfectly - using both relays to switch generator and a pump. Until today...

First Issue: Now, for no reason, the relay setting has disappeared from the settings menu. And I have no access to see or control the 2 relays. Why would the settings for relays disappear from menu? Normally, even with nothing connected to the relay inputs, they showed up as a menu item.


Second issue: The main screen no longer shows data for battery levels, PV levels, DC current etc (but they do still show up correctly and update correctly in the device list page so it is receiving all battery and MPPT data as per normal). This happened at same moment that relays disappeared.


And Last issue: the VRM Portal is not updating data. The Venus GX is online, and connecting every 30 mins - so I can see it - but the last data is from 5 hours ago (when relays were lost)

So what has happened ? Is it software or hardware of the Venus GX device?

Basically only half of the system is now working and they are not related (ie. relays going missing are not related to the main screen missing the battery voltage)... So it seems like a a software failure?

Using latest firmware on all connected devices. Tried rebooting, unplugging power etc multiple times.

Any advice appreciated

Thomas G asked
Thomas G commented ·

2 Answers

Which Shunt do I need (dummies guide)

hello all,

Spent a lot of time trying to find the answer to what might be a simple question. A buying guide would help iron this out.

I have two engines, one engine goes to an isolator which charges the following

two x XV31MF (aft) for the bow thruster (Total 220ah)
three x XV31MF (stern) for entertainment and engine start.(Total 330ah)

Reading the posts a 500am might be ok? My concern is the engines which are large volvo Penta start from battery bank 2. The batteries are say 1000 cold crank amps that’s 3000 CCA the shunts go up to 2000 amps.

So I am confused what amps I look at for the shunt

CCA is a lot higher than the amps

the above two groups are in parallel

Brand Numax
Range Numax XV
Voltage 12 Volts
Technology Wet
Capacity (C20) 105 Ah
MCA 925 A
CCA (EN) 740 A

Rsmith9848 asked

0 Answers

capacitance tank monitor

Been looking forever for a way to monitor my captivate tank sensors with Venus but only thing I have found is restive.

Short of anything thing from Victron when SiMarine adds NMEA2000 to PICO and their tank senders do you think I will be able to interface. NMEA2000 is a standard protocol right?

philcollins asked
lshantz commented ·

3 Answers

PV Inverter on AC-Out, connected but not showing up/no AC Load total shown

Solar Edge PV inverter connected to the AC-Output side of my split-phase+parallel Multiplus installation. Monitoring is working, you can see the device pushing updates every couple seconds:



But the AC Loads totals are obviously incorrect, and the inverter is nowhere to be found... There is about 2000W draw on the Loads side:


I've tried rebooting my PV inverter, and VenusGX several times, tried to rediscover the inverter but couldn't really find a way to remove it - or my old inverter. Is it time to reset the VenusGX and start fresh or something like that?


PV Inverter is the newest "CPU" version, 4 that is controlled via SetApp on smartphone, and has no LCD screen or buttons whatsoever.


ee21 asked
ee21 answered ·

2 Answers

Has DC System - Incorrect Consumption in VRM when Phoenix Inverter is run on DC

Hey everyone,

I am running an off-grid system with a GX Device and an MPPT, BMV and Phoenix Inverter 12/800. I also have DC loads connected to the system. As long as the inverter is not running, the consumption values in VRM are perfectly valid, but as the inverter runs, the values measured are off, as the inverter power is just added ON TOP of the DC Load Power which already includes all the current drawn by the inverter.

Is there a way to configure the GX Device to ignore the AC Power measurements, as they are already included in the DC Load? If not: it'd be great to have an option in the menu that states that the inverter is run on the DC system. Otherwise I am unable to reliably log the system consumption...



steffend asked
steffend edited ·

0 Answers

2 MPPT controllers with venus on Pi

I have 2 MPPT controllers 1 connected to a Pi using the Victron usb cable. Do I need another USB cable connected to the second MPPT to report the state of charge for that unit or will the VE smart Network synchronise the charge across the 2 units and report the overall state of the system?

Dilbert asked
WKirby answered ·

1 Answer

Venus GX not sending data to VRM

My Venus GX has been unable to communicate with the VRM portal for

about a month now, as in no data is uploaded, device list says "Last

seen a month ago", etc. On the GX remote console, "Last contact" always

shows "---" and "No error".

My installation ID is 9884e3b3e091.

- Network is fine, the GX has an IP address, DNS servers, etc. I have run through the steps at https://www.victronenergy.com/live/ccgx:start#trouble_shooting_data_logging.

- I am able to curl ccgxlogging.victronenergy.com from the commandline

on the GX (gives 403 Forbidden but shows that I can reach the server)

- If I disable VRM logging on the GX, tail /var/log/vrmlogger/current,

then re-enable VRM logging, I get the following output:

@400000005edad70d1684946c MainThread-vrmlogger: Starting to log, logmode == LogToVRM, url == http://ccgxlogging.victronenergy.com/log/log.php
@400000005edad70d1c6aa2a4 MainThread-http_endpoint: Internal backlog buffer initialised. Count = 9
@400000005edad70d1d89e5b4 MainThread-http_endpoint: Found '/run/media/sda1' as remembered external path
@400000005edad70d1db03a34 MainThread-http_endpoint: Checking '/run/media/sda1' for suitability for external storage
@400000005edad70d1e93899c MainThread-http_endpoint: Found /run/media/sda1 as external storage dir
@400000005edad70d20618724 MainThread-http_endpoint: Extra SQLite DB made at /run/media/sda1/vrmlogger-backlog.sqlite3
@400000005edad70d20730f6c MainThread-http_endpoint: Made /run/media/sda1/vrmlogger-backlog.sqlite3 the active buffer
@400000005edad70d20eb641c MainThread-http_endpoint: Starting sender thread
@400000005edad70d21eb019c MainThread-http_endpoint: Reading from {0} resulted in an error. Doing nothing.
@400000005edad70d22064de4 MainThread-http_endpoint: Started sender thread
@400000005edad70d2219a704 MainThread-http_endpoint: HttpEndpoint initialised, http worker thread running
@400000005edad71022645c04 HTTPThread-vrmhttp: Using existing VRM auth code

It doesn't seem to progress beyond this point. Am running v2.54. Could there be some problem at the VRM end?

aeneby asked
Jaco Reinecke answered ·

1 Answer

USB GPS Module has Speed recorded on Venus OS When Vehicle is Stationary ??

Help please ?

Set-Up is Raspberry Pi 3 with Venus OS publishing to vrm site and there is a USB GPS plugged into the Raspberry Pi 3.

This is in a stationary vehicle. Why do I see a Speed published on the VRM portal ?


Thanks in Advance

grunkern asked
LKLMEnterprises answered ·

4 Answers

Mobile studio rig, 120v to 230v

I own a Mercedes Sprinter with a Volta Power Systems 13.5kWh rig. It's being used for mobile sound recording. Wanna put a small 6000btu Mitsubishi MUZ-FH06NA in it, powered off the 120v supplied by the Volta batteries. Can I use the Victron autotransformer 120/240 32a? If not, what would be the best way to accomplish this?

dylanwest99 asked

0 Answers

Feature Request/Bug Report: Venus GUI Diagram incorrect topology

Hi, I am now using Venus to monitor my system. However, I was surprised to see that the diagram of connected devices is incorrect. I am guessing it was done to try and oversimplify things for beginners?

This is how my system looks right now:


Firstly, this diagram has inconsistently applied design principles. The AC inverter load is not connected to the battery, but rather to a central "busbar", so by that formalism, the DC load also should be.

Secondly, this diagram prevents the system from being accurately represented, for example in the case where the solar system is producing enough power to simultaneously charge both the battery and power the DC load. In that case, this diagram depicts the power going through the battery first, and then to the DC load, which physically wouldn't happen - electrons being moved from the solar charger would literally never pass though the battery.

Would it be possible to correct this diagram? I am being driven mad by this nonphysical depiction. This is how I believe it should look:


vulture asked

0 Answers

VRM portal MultiPlus 12/3000/120 16 AC/OUT

My installation is on a boat:

2x 110AMP batteries as "house bank" (bank 1)
2x 110AMP batteries as "Starter battery and bow thruster" (bank 2)
The batteries are: Lucas LX31 110ah Leisure Battery
The two banks are connected via a Cyrix-ct 12/24V-120A (CYR010120011).

Connected to bank 1 are the following:
One BMV-702 (BAM010702000R) with 3x 160Watt solar panels
One SmartSolar MPPT 100/50 (SCC110050210)
One MultiPlus 12/3000/120-16 (PMP123020001)
One Venus GX (BPP900400100) (https://vrm.victronenergy.com/installation/36369/share/820f64ab)

Connected to the Venus GX are the following:
BMV-702 (BAM010702000R)
SmartSolar MPPT 100/50 (SCC110050210)
MultiPlus 12/3000/120-16 (PMP123020001)

My question:
On the VRM portal and Venux GX I only can see the "AC Loads".
But the MulitiPlus has two AC OUT. And I have both AC OUT in use.
Is it somehow possible to see the use on AC OUT 1 and AC OUT 2 instead of only "AC Loads"?

Sebastian W. asked
Michael Riley answered ·

2 Answers

BMV 712 always shows 19 amps

I just installed a new BMW 712, it updated the firmware twice 2.XX something then to upgraded to 4.XX version so far so good. But it always shows about 19 Amps no - or + just 19 amps. So I started to look for the drain but there isn't any. I turned everything on and the amps never change. Volts do drop with the load but the amps are steady at 19 ish... So then I plugged in the charger ... guess what still says 19 amps. Being in the 5th wheel I just disconnect the - side and inserted in the shunt.

White bottom is going to the 5th wheel and Black is going to the negative side of the battery. On the battery there is nothing but the black cable.

I did connect both voltage red wires to the shunt but I haven't hooked up a second battery yet, doubt that matters

As I recall the charger was unplugged as well I never recall ever seeing a - sign for current.



imjustdave asked
imjustdave answered ·

1 Answer

Looking for input - 4 to 20mA and 0 to 10V senders

Hello Community!

We’re considering to add a USB accessory to our GX product range, to add 0 to 10V, as well 4 to 20mA inputs.

But since all of us have very limited experience with 4 to 20mA tank senders, we're looking for some input:

  1. Is it always 4mA = tank empty, and 20mA is tank is full? Or do the empty and full levels need to be configurable in a software setting on the GX Device?
  2. And how important is it that the transducer can be powered by our device?
  3. Anything else we should keep in mind when designing a 4 to 20mA input? Good features you have seen else where?

Also, if you are using 4 to 20 mA senders, please post a link to a datasheet or specs below. And if you have an opinion on the sender, what you like/don't like, welcome to add that.

Lastly, most questions above are for 4 to 20mA, not for 0 to 10V - but if you have special comments about 0 to 10V, welcome as well - obviously. The product we have in mind will have inputs that can be used for both types.

Note, that this is quite early in the product development, I can’t say anything for now with regards to availability dates.

All the best and thank you! Matthijs

ps. just to prevent any question about this: we'll soon launch a new Venus OS version that can work with irregular tank shapes, as well as naming tanks and some more features: all those features will also available for the 0 to 10V and 4 to 20mA inputs. Details here.

mvader (Victron Energy) asked
RayMiller commented ·

9 Answers

How to get USB Venus-data tar file to unpack

I asked this in the modifications space earlier this week I wonder if it can be answered.

Referring to implementation notes it says:

Also if venus-data.{tar.gz,tgz,zip} is found on removable storage (usb stick, sd-card) when booting, it will be unpacked into /data. Implementation details in this commit. Added per Venus v2.30~28.

However this is not working for me in Venus os 2.53.

I have traced through the init.d logic.

Execution of either of the scripts:

  1. /etc/rc5.d/S30update-data.sh
  1. or /etc/init.d/update-data.sh 

Works fine and reports: "Updating /data with /media/sda1/venus-data.tar.gz"

And the contents are correctly installed on /data

But this is not happening when rebooting.

What am I doing wrong?

More diagnostic information is in my post in the modification space.

LaurenceH asked
LaurenceH answered ·

1 Answer

Venus GX NMEA2000 MPPT

Hello, Can you give some info on MPPT solar data being transmitted to NMEA2000 through the Venus GX? Does it output the data or when will this be available if not?

Also keen on tank level and temperature output to NMEA2000 through the Venus GX.


Navin Devkurran

Garmin EMPIRBUS Product Support Specialist

GarminNZ asked
mvader (Victron Energy) answered ·

1 Answer

How to use Ve.Bus Diagnostics to troubleshoot issues?

I have been experiencing a recurring error 17 problem with a parallel 3 phase
system of 6 X Multiplus ii 5000.

The Ve Bus diagnostics look useful for diagnosing comms problems and I have been trying to use them to check the Ve Bus
communication health and it gives the result in the attached photo.

There should be 6 inverters present, and there are only 5..... L2 Slave is missing. The numbers are also high.

How do I interpret this data?

I assumed from the data that L2 slave was perhaps not communicating reliably, so I exchanged that inverter for another, but there was no change in the data.

I note that there have been previous posts also asking for this information.

Any help would be appreciated. ( Even if it is to know that this data is as yet unreliable but watch this space!)


Ian Straker


Ian Straker asked

0 Answers

Multiplus and his function states

Hi all,

I would like to know behavior of Multiplus unit 24/1600-40, when I'm going to change Multi's state by SW & Modbus ("On", "Inverter only" / "Charger only".

Presumption: There is another, smaller one, inverter connected to Multi's AC input, they both use the same battery. No grid code entered to Multi, UPS function of Multi is off, Venus GX or similar.

1. What is power consumption of Multi, when the Multi is switched by SW to "Charger only" state (power limit of Ac input is set to 0A = Multi works as pass-through device = no charging of battery, AC input feeds load)

2. Can I use Power Assist function for this setup (state "On")? Could it be harmful for smaller inverter when Multi will stop assistance due to small load? P.S.: I know about “Minimum shore current limit” of above mentioned Multi.

3. Is there any output power interrupt, when I'll do SW change of Multi's state in any possible way (Inverter only > Charger only, Charger only > Inverter only, On > Charger only, On > Inverter only, ...)

4. Is there necessary to set something else?

Thanks in advance for valuable feedback J


JiT asked
Daniël Boekel (Victron Energy Staff) commented ·

1 Answer

Venus OS - iPhone USB modem not recognized as GSM modem

I am trying to use an iPhone as an USB modem/gps on pi 3+ with Venus os 2.42. iPhone USB modem is recognized and is working when connected to pc or Mac. When connected to pi iPhone charges via usb but is not recognized as gsm modem nor as gps device.

hanschristian asked
ejrossouw answered ·

4 Answers

Venus GX 2.42 CAN Bus Connection - What can we see?

Hi, today I connected my Venus GX V2.42 to my NMEA2000 network by terminating an n2k cable to the CAN2 screw terminals and into the network backbone. I now have three devices vsible on the network from N2K Analyzer and also my Simrad MFD's.

Device 1 is Quattro - Shorepower data displaying AC Voltage, Freq, Current and Power etc
Device 2 is Quattro - Inverter data displaying AC Voltage, Freq, Current, Power & Battery V and I
Device 3 is the Venus GX - Displaying product data but not much else

I was hoping that I would also be able to access the following;

BVM7XX Battery Voltage, Current, SOC, Temp, Aux Voltage for each BVM on the system (I will have 2 or more)

Tank data / Digital Inputs

MPPT Controller Data (I have 2 on my system)

Lastly, my Quattro unit is Version 1.0 - does this need an update? I have experienced problems lately where the inverter output drops off for a period of time before coming back on. When disconnected from the Venus the unit seems to be stable.

Thanks for any assistance / advice you can provide.


Greg Ireland asked
Kevin Windrem commented ·

5 Answers

Venus GX -> NMEA2000 / Signal K

I have an EasySolar 24/1600 that I'm looking to tie into my vessels sensor / monitoring network.

From reading this article it looks like the recommended approach has been to bridge both the VE.Bus connection from the internal MultiPlus and VE.Direct from the MPPT direct to N2K. In the comments section though there was talk of a CCGX -> NMEA integration. Is this still something on the horizon?

I'm assuming it will apply to the Venus GX too? If so, that would be a much neater integration (VE.Bus and VE.Direct -> Venus GX -> NMEA) as well as providing a couple of additional sensor inputs.

On a slightly related note, has there been any consideration for providing a direct Signal K interface from the Venus / CCGX?

kim asked
mvader (Victron Energy) answered ·

6 Answers

Venus OS driver for Fronius Smart Meter

Updated with latest results on 17-Apr-2020


At home, I have three roofs (east, south and west) with 9.9 kWp PV feeding into a Fronius Symo 8.2-3-M. The setup has Fronius Smart Meter 63A-3.
In a few days I am adding a Multiplus-II 48/5000/70-50 and 2x Pylontech US2000 (4.4 kWh net) LiFePO battery.


I am running Venus OS on a Raspberry 3B+. It nicely shows the power fed in by the Symo, with all details.

Venus is not showing any data from the Fronius Smart Meter.


I would like to have the data from the Fronius Smart Meter available on the Venus.

My idea is that I need a driver for Venus OS, which gets the data from the Smart Meter via the http API that Fronius provides and passes that information onto dbus - where hopefully Venus treats the data as if it came from a meter that it knows.

Steps Forward

I searched for a solution to my problem on the internet.I thought that I can not be the first to have this issue. But I found no direct solution.

There are several projects that might be a good start for getting to a solution:

  • dbusdummyservice.py from velib_python
    A simple service on the dbus.
  • dbus-cgwacs
    Reads energy measuremens from Carlo Gavazzi Wired AC Sensors (hence cgwacs), and puts it on the D-Bus.

Both projects look like a good start for programming my own solution.

Python script emulating the Victron Grid meter

Using dbusdummyservice.py from velib_python as a basis, I wrote this script:

#!/usr/bin/env python

Used https://github.com/victronenergy/velib_python/blob/master/dbusdummyservice.py as basis for this service.
Reading information from the Fronius Smart Meter via http REST API and puts the info on dbus.
import gobject
import platform
#import argparse
import logging
import sys
import os
import requests # for http GET

# our own packages
sys.path.insert(1, os.path.join(os.path.dirname(__file__), '../ext/velib_python'))
from vedbus import VeDbusService

class DbusDummyService:
  def __init__(self, servicename, deviceinstance, paths, productname='Fronius Smart Meter', connection='Fronius SM service'):
    self._dbusservice = VeDbusService(servicename)
    self._paths = paths

    logging.debug("%s /DeviceInstance = %d" % (servicename, deviceinstance))

    # Create the management objects, as specified in the ccgx dbus-api document
    self._dbusservice.add_path('/Mgmt/ProcessName', __file__)
    self._dbusservice.add_path('/Mgmt/ProcessVersion', 'Unkown version, and running on Python ' + platform.python_version())
    self._dbusservice.add_path('/Mgmt/Connection', connection)

    # Create the mandatory objects
    self._dbusservice.add_path('/DeviceInstance', deviceinstance)
    self._dbusservice.add_path('/ProductId', 16) # value used in ac_sensor_bridge.cpp of dbus-cgwacs
    self._dbusservice.add_path('/ProductName', productname)
    self._dbusservice.add_path('/FirmwareVersion', 0.1)
    self._dbusservice.add_path('/HardwareVersion', 0)
    self._dbusservice.add_path('/Connected', 1)

    for path, settings in self._paths.iteritems():
        path, settings['initial'], writeable=True, onchangecallback=self._handlechangedvalue)

    gobject.timeout_add(200, self._update) # pause 200ms before the next request

  def _update(self):
    URL = ""
    meter_r = requests.get(url = URL)
    meter_data = meter_r.json() 
    MeterConsumption = meter_data['Body']['Data']['PowerReal_P_Sum']
    self._dbusservice['/Ac/Power'] = MeterConsumption # positive: consumption, negative: feed into grid
    self._dbusservice['/Ac/L1/Voltage'] = meter_data['Body']['Data']['Voltage_AC_Phase_1']
    self._dbusservice['/Ac/L2/Voltage'] = meter_data['Body']['Data']['Voltage_AC_Phase_2']
    self._dbusservice['/Ac/L3/Voltage'] = meter_data['Body']['Data']['Voltage_AC_Phase_3']
    self._dbusservice['/Ac/L1/Current'] = meter_data['Body']['Data']['Current_AC_Phase_1']
    self._dbusservice['/Ac/L2/Current'] = meter_data['Body']['Data']['Current_AC_Phase_2']
    self._dbusservice['/Ac/L3/Current'] = meter_data['Body']['Data']['Current_AC_Phase_3']
    self._dbusservice['/Ac/L1/Power'] = meter_data['Body']['Data']['PowerReal_P_Phase_1']
    self._dbusservice['/Ac/L2/Power'] = meter_data['Body']['Data']['PowerReal_P_Phase_2']
    self._dbusservice['/Ac/L3/Power'] = meter_data['Body']['Data']['PowerReal_P_Phase_3']
    self._dbusservice['/Ac/Energy/Forward'] = meter_data['Body']['Data']['EnergyReal_WAC_Sum_Consumed']
    self._dbusservice['/Ac/Energy/Reverse'] = meter_data['Body']['Data']['EnergyReal_WAC_Sum_Produced']
    logging.info("House Consumption: %s" % (MeterConsumption))
    return True

  def _handlechangedvalue(self, path, value):
    logging.debug("someone else updated %s to %s" % (path, value))
    return True # accept the change

def main():

  from dbus.mainloop.glib import DBusGMainLoop
  # Have a mainloop, so we can send/receive asynchronous calls to and from dbus

  pvac_output = DbusDummyService(
      '/Ac/Power': {'initial': 0},
      '/Ac/L1/Voltage': {'initial': 0},
      '/Ac/L2/Voltage': {'initial': 0},
      '/Ac/L3/Voltage': {'initial': 0},
      '/Ac/L1/Current': {'initial': 0},
      '/Ac/L2/Current': {'initial': 0},
      '/Ac/L3/Current': {'initial': 0},
      '/Ac/L1/Power': {'initial': 0},
      '/Ac/L2/Power': {'initial': 0},
      '/Ac/L3/Power': {'initial': 0},
      '/Ac/Energy/Forward': {'initial': 0}, # energy bought from the grid
      '/Ac/Energy/Reverse': {'initial': 0}, # energy sold to the grid

  logging.info('Connected to dbus, and switching over to gobject.MainLoop() (= event based)')
  mainloop = gobject.MainLoop()

if __name__ == "__main__":

The script registers itself on dbus as "com.victronenergy.grid" and publishes values as defined on Venus wiki - dbus - Grid meter .

Before I run the script, I have the following situation on the remote console, feeding 3.9 kW to the grid:


When I run the script, I see the following situation on the remote console, as if the AC Loads would consume 3.9 kW:


So, clearly, my script does something. But not what I wanted.

As the next step, I added three paths to the script: "/Ac/L1/Power", "/Ac/L2/Power" and "/Ac/L3/Power" and then it worked. So, the "/Ac/Power" was not enough for Venus to accept the data as valid- it needed power for all three phases separately.

Now the remote console shows:


Final thoughts

So, it is possible to use a Fronius Smart Meter and make Venus see it correctly.

I think this could be useful for other users as well, therefore it now can be found together with some documentation on GitHub: venus.dbus-fronius-smartmeter

RalfZ asked
RalfZ edited ·

2 Answers

BYD LVL 15.4 - High Battery Voltage Warning


since 2 days i've connected new BYD LVL 15.4 (two units) to a single MP-II 48/5000 together with 2 MPPTs chargers. Installation and configuration went smootly, following the Victron provided docs. All components running the lastest SW and no connection problems exists. Since the initial full charge i saw Voltage Warnings from the BMU (and on the CCGX following) - the Battery voltage is displayed at 55.3V and thus slightly above the documented limit. I though that CCGX (venus) is dynamically controlling the DC voltage receiving the changing limits from the BMU ? Any other option to correct in order to avoid these warnings ?

best regards,


martghh asked
Guy Stewart (Victron Community Manager) commented ·

1 Answer

vecan dBus services disappear if GUI isn't running

I noticed that vecan dBus services (using dbus-spy) disappear if I kill the GUI process. These services return once the GUI has restarted.

Specifically in my case:



I'm currently running Venus version 2.52

Is this normal/expected or a bug?

Kevin Windrem asked
Kevin Windrem answered ·

2 Answers

Clear list of detected PV inverters in Venus OS, stop automatic scanning?

I had some issues setting up my PV inverter when my system was first installed, getting it to stay assigned to a static IP address. As such my Venus GX still remembers each IP address it was found on in the list of "Detected IP Addresses" under the PV Inverter tab. Is it possible to clear this list entirely and start from scratch?


Secondly, my Venus GX seems to like automatically scanning for PV inverters periodically, several times a day, every day it would seem. During this time, the PV inverter that was already added becomes unavailable, and the data stops being sent to the console. Is there a way to disable automatic scanning?


ee21 asked
mvader (Victron Energy) commented ·

1 Answer

Tank setup error on venus firmware 2.40


Firmware 2.40 makes it impossible to change tank capacity. When change from the default value 200l, it jums back to 200l instead of the value have set.

Rune Eilertsen asked
mvader (Victron Energy) answered ·

2 Answers

Alternator w/ WS500 and Victron Venus or Cerbo

I love the Victron Venus system and would love to upgrade to the Cerbo (if i can every get my hands on one). I'm currently in the process of upgrading our alternator on our yacht. For this we will use a WS500 regulator which has the ability to get data from the victron BMV shunt in order to control voltage and Amperage coming from the alternator.

My question: is there anyway to see only alternator output through a venus or cerbo device? I know that the WS500 has a CAN bus but i would be unsure how these two devices would communicate or if there would be any way to display that information. It would be very helpful to understand what all the charging systems are doing (solar, wind, alternators, etc) on a single screen.

I do believe the answer is, no, there is no way to do this but i figure i would ask before i close the door to the idea.

polarseal asked
Paul B answered ·

1 Answer

Set AC-In to "Phoenix" or "Inverter" in Venus OS


normally my loads are small so I chose a medium size Multiplus due to the lower standby consumption. This is also the reason I don't want to use a bigger unit or parallel setup because this would give me a much more higher daily consumption.

Anyway there are a few high loads I hardly use. For these loads I want to put a Phoenix 3000 at the AC-in of the Multi so I can run the small unit 24/7 and the bigger one only when I need it. Doing this I still can use the same circuits.

Technically this is not a problem, I think. But what about the Venus device. I can only set "grid" or "generator" as far as I know but not "inverter". This would give me a muddled VRM as the energy comes from the battery. Can this probably somehow be added in future versions of the OS? Or isn't it possible at all.

Can both, a Phoenix AND a Multiplus even have a VE.Bus connetion to a Venus or is this only possible with VE.Can?



Porcini asked
Porcini edited ·

1 Answer

Multiplus 12/3000/120 no Connection to Venus and VictronConnect


My Multiplus loose the Connection to the Venus and now its not more posible to find it in the Victron Connect App.
I have an 12/3000/120 and I use an RPI with Venus Image and it still works fine, till last Week.
It was not posible to see him on the Venus and I tried to connect him with my PC and Samsung Tablet to the Connect APP.
Normaly it works fine with the MK3 but now it do not work.
With VEConfigure3 it still works fine.
Can somebody help me please?
Sorry for my bad English.

Rene asked
Rene commented ·

1 Answer

Color Control GX: How to find old versions of Venus OS firmware

Can anyone share the download link for Venus OS 2.18 firmware? I need to downgrade from 2.33, but it cannot be done from CCGX as I dont have any backup firmware in storage on the device.

djgagy asked
Guy Stewart (Victron Community Manager) answered ·

1 Answer


346 Posts
2 Users
1 Follower

Topic Experts

There are no topic experts for this topic. Participate in the posts in this topic to earn reputation and become an expert.

Related Topics