reboot Image


start automatique Flow node red after reboot venus os ?


is it possible to start node red flow after reboot raspberry pi venus os large ?

thank you

ro2kpdp asked

0 Answers

MP2 Update failed - cannot find VE.BUS

After installed the whole ESS System I wanted to update my MP2 48/5000/70 to the newest Firmware. It startet fine but lost connection. Tried IT again and said "no VE. DIRECT" device found and made a warning Light "Boot-loader" :-/ error Code 745 "cannot find VE.Bus System"

I updated it via Cerbo GX, no BMS, no Inverter or other things connected. Cerbo got voltage from 48v battery Pack. I dont have MK3-usb.

Do you have any idea how to Set it back to dealer config... Is there a way to update without ve.bus

Othet LAN cables tested

Thanks & bes regards


rene-89 asked
rene-89 answered ·

2 Answers

Multiplus II GX regularly rebooting and causing MPPT RS to go offline


My Multiplus II GX keeps on rebooting itself multiple times a day and sometimes it loses connection to the MPPT RS on reboot. When this happens, I have to do a manual reboot for the MPPT RS to be found again.


I have a Multiplus II GX connected via VE.Direct to an MPPT RS, and via BMS-CAN to a BYD BMU. I have v500 firmware and v2.92 Large installed on the MPII GX. The MPPT RS has v1.10. The BMU contains the latest firmware from BYD. The MPII GX has an ethernet connection and comms testing has confirmed that this is a reliable connection

The system has been very stable for 18 months until October when it failed twice. This month it is failing every day (only during daylight hours) and, I suspect, when a state transition is happening (e.g. below Active SoC to above Active SoC).

I initally thought that it might be an intermittent cable issue however both cables have been removed and replaced and the system has immediately recovered. The connections are sound and no comms errors have been reported.

I have done some initial diagnosis and have captured the relevant /data/log/messages.


The symptoms are as follows:

  1. Rebooted on 16 December at 11:44, 11:48, 11:52, 11:57, 12:00, 12:06.
  2. Each time, the VE.Bus state changed from Ext Control to Bulk (although this may be a symptom rather than the cause). At the 12:00 reboot, the MMPT RS went offline and didn't come back. This meant the batteries stopped being charged as the MPPT RS had no data from the BYD BMU.
  3. I noticed the MPPT RS was offline at 13:09 and manually rebooted the MultiPlus II GX. It reported that the connection to the BMS was lost but this is an artefact of the main problem.
  4. The MultiPlus II GX then rebooted itself at 13:44, 13:48, 13:51 and 13:58. This time the MPPT didn't go offline. However, notice the times - exactly two hours after the previous reboots. I suspect a firmware issue.

Looking at the messages logs it seems that every time the MPII GX rebooted, there was a period of time (1-2 minutes) where nothing was added to the logs. So nothing obvious although the preceeding messages contain a lot of ipv6 related details.

I have logs that I can provide to Victron support and am more than willing to open up the remote access.

paulcooper asked
paulcooper edited ·

2 Answers

Venus - reboot when no contact with ethernet?

The "Reboot device when no contact", in the Venus device, under "Settings" / "VRM online portal", is useful with an unreliable wifi connection.

Do you still need this if you use an ethernet cable to the venus device, to a router that is not always on? The scenario here is a Venus GX that is connected to a Thales satellite router that is not always on. The router will be switched two or three times a day, and we need the Venus to then upload the locally stored records when the router becomes available.

Or, maybe a different question - is it harmful for the Venus to reboot all the time ;-)

Albert de Jongh asked
kevgermany answered ·

1 Answer

0 Answers

Cerbo GX sensitive to low voltage transients.

I have the Cerbo supplied on a 12v DC system running other equipment that can produce very very small low voltage spikes that I measured on my scope. However, it was enough to cause the Cerbo Gx to reboot. Has anybody come across this issue? I fixed it with a capacitor on the power supply cable of the Cerbo although the manual does not call for this.

nathanielnzl asked

0 Answers

is there a regular reboot option

hi everyone,

I have a simple (but excellent) shunt/mppt/GX system that recharges the Li batteries of our domestic circuit on our boat which lost the wifi creds to connect to the router, a reboot fixed it immediately.

Is there a way to schedule a regular reboot of the system other so I don't have to do it manually?

many thanks


it344x asked
it344x commented ·

2 Answers

Multiplus 12v/3k restarts every 30 secs with VE.Bus BT dongle plugged in
I have a new one I haven't ran into before. A Victron Multiplus 3k in inverter mode with a smart VE.bus BT dongle plugged in causes the inverter itself to restart every 30 seconds. The inverter is just on, with no loads and green inverter light is on saying everything is fine. Every 30 seconds the invertere restarts by itself There is no shore power, it's just inverting. There are 3 Battle Born batteries the inverter is hooked to and the battery voltage is fine since there is no load or anything.
If you unplug the VE.Bus BT dongle the rebooting stops. I can hook up to the MK3 to the inverter/laptop using the exact same cable and everything is fine. The culprit appears to be the VE.Bus BT dongle, but I've never seen this before?

- Victron Multiplus MP1 12v/3000 with latest firmware
- Victron VE.Bus BT dongle with latest firmware
I swapped out the network cable (both are from Victron)
I tried both RJ45 ports on the Inverter
Restarted both devices
As long as the VE.Bus BT dongle is plugged in, the inverter reboots every 30 seconds. If you unplug the dongle, everything is fine.

bluelghtning asked
william-wright answered ·

2 Answers

Rpi with Reboot Device When No Contact causes reboot loop after graceful shutdown

I have a Rpi 3 B+ running Venus OS 2.66 running on a houseboat connected to a Battery Monitor. Works great most of the time. I've had some situations though where things would stop talking I suspect due to my cell connection going away. I'd like to use the Venus auto 'reboot when no connect feature'. Unfortunately when I enable this and then reboot the RPi (using a 'shutdown now' command from an ssh session to the RPi), when the RPi reboots the date displayed is about 5 days old. This triggers the auto reboot in Venus before the RPi has a chance to sync date/time with the internet. Is there any way to insert a sleep in front of the auto reboot watchdog feature so that after a reboot the RPi will have a chance to sync time/date before the auto reboot kicks off again? Not quite sure why the RPi comes up from a warm boot with the clock 5 days off but it seems to be consistent.

petej asked
kevgermany answered ·

1 Answer

Victron 500w inverter has started rebooting randomly


I’ve had a 500w inverter for about 18 months. It’s been used on a daily basis. I live full time in a motorhome.

it’s been working fine until recently where it now starts rebooting even under zero load. Just turned on with nothing connected.

Any ideas why?

Is this a fault that can be fixed?

I bought Victron and spent the extra money for value and I’ll be slightly miffed if it’s failed already.



Mathew Hamilton Green asked
Mathew Hamilton Green commented ·

4 Answers

System Reboots happen under certain circumstances...

I believe my RV's Victron setup has FIVE major components:

  • MPPT (1)
  • MPPT (2)
  • SmartBMV monitor
  • Color Control GX
  • MultiPlus (the big unit, inverter)
  • In addition, 4 x 100ah Battle Born batteries

In this RV, we also have an Onan 5500 generator (45amps) and when connected to shore power, has always been 50 amps. (We are configured as a 12v system, not 24v, in case that's a question one might ask.)

Frequently, when putting a heavy load on the power consumption (two good examples are the electric/hydraulic slides and extending (sometimes retracting) the hydraulic leveling jacks), the system will reboot. So far, we have only seen this on generator and/or shore power.

Reproducing the scenario is easy: While still plugged into shore power (or have genny on), retract slides or jacks. In addition, the generator will shut off if in use during these reboots. (The Victron system doesn't engage the generator, that's the RV's house "OneControl" system.) I think because the OneControl system is also rebooting, that is what kills the generator. (The Onan's have some weird "pulse" on/off system, and I don't have the gizmo that lets me wire that up to the Victron system.)

I have found that simply unplugging from shore power (or turning off the generator) and running solely on batteries usually prevents the reboots. Bear in mind that there are no A/C's on, no heaters, and minimal power consumption as we are either getting setup in a campground or preparing to leave.

Our sorta-vendor (not original installer, but did some fixes for us) doesn't have any clue why this might be happening. One would think that the 50amp shore power would be more than sufficient to be handle these operations. We do NOT have reboots even when running three air conditioners!

During the last time we experienced this, and I had disabled shore power to run solely on batteries, I watched the BMV while extending the jacks. The voltage did slip down to around 11 volts. The reboot doesn't happen, as I said earlier, when on batteries alone. The system did NOT reboot, however.

Does anyone have any suggestions as to what I can look for as a potential cause of this issue.

captainpalapa asked
captainpalapa commented ·

0 Answers

EasySolar event logging

Dear community, good afternoon

I have a question regarding event logging in an Easysolar device.

Does the CCGX keeps track of reboot events for himself and the Multiplus II connected to the VE.Bus?

If so where can I access this data?

Thanks for your support.

Best regards,

Javier Moran asked
Javier Moran answered ·

2 Answers

Mutiplus 24/500/10-16 wouldn't start up until VE.Bus cable was removed from Venus GX

Yesterday we had an issue at our site which has the MultiPlus 24/500/10-16 and Venus GX combo.

In a last resort to try and remotely fix the issue, I tired login to the VRM portal and using the Venus GX to reset the MultiPlus:


Instantly, as expected, I lost connectivity to the system (as this shut down the equipment connected to the LAN port of the Venus GX). However, it didn’t come back online – requiring an urgent site visit.

When I got to site, the MultiPlus was powered off. Turning the power switch off and on, and even unplugging the mains input to the unit did nothing. The Venus GX was still powered up directly off the battery bank. As soon as I disconnected the VE.Bus cable from between the two Victron devices, the MultiPlus powered up. I plugged the VE.Bus cable back in, and all was well.

I’m not sure the reasons why the VE.Bus would need to be unplugged in order for the MultiPlus unit to start up – which is why I would suspect a bug. Any ideas on why the initial system reset didn't work?

alistair-jeffcoat asked
Paul B answered ·

1 Answer

Color Control GX does not reboot after new version firmware

I have two Color Control GX's, both connected to internet via cable to a switch.

Both was set up with automatic check and install new version firmware

For a couple off months ago one of them did not reboot after the firmware was installed(ver 2.20).

The same happened when 2.22 was installed.

In both cases I had to restart the Color Control GX manually.

Have anybody else experienced this problem?

johniss asked
mvader (Victron Energy) answered ·

1 Answer

One VEDirect MPPT is turning off in parallel setup


I have a system with two similar MPPT from Victron, 250/60 connected to a Venus device via Ve. direct. Each MPPT has its own string of pannels. I noticed that very often one of the MPPT leaves float with no apparent reason... checking more deeply, it seems it goes OFF!!

I'm worried that it might be faulty.

I've changed everything that I can remember and swapped strings. The reseting continues to happen in the same MPPT controller. See graphs:

Just one or two OFF states are manual made by me, but check the number of times the MPPT [260] goes OFF with no apparent reason... the other one, 258 is normal in float state after 12h00.


Now, I add some more information from other parts of the system, and I noticed some worrying sign - the surge in current on the [260] MPPT right before it goes off:


And I do see some peak in AC side, but which AC is this? Other AC graphs don't show anything:


On these other AC graphs, it shows no peaks - 261 is my Multiplus Inverter:


I know the resolution might not be good enough to take serious conclusions, but... what can I conclude from all this?

I never saw similar rebooting on the [258] MPPT. All OFF states on the graph are manual, made by me while changing something. Any help or ideas is deeply appreciated...

Elimac asked
Elimac answered ·

4 Answers

Topic resources

Additional resources still need to be added for this topic
19 Posts
19 Users

Topic Experts

There are currently no experts identified for this topic. Can you answer questions in this topic area? Community members who provide answers that are marked as correct earn reputation and may become recognized as topic experts.