cerbo Image

cerbo

This topic has been merged into cerbo gx . Please use cerbo gx when editing or creating new content.

DVCC for DC charge current control from node red - Unintended effects?

Hi Folks,

I currently have a Multiplus and Smart Shunt hooked up, standard fission, to a Cerbo GX.
My batteries do not communicate, although they do have internal BMS's. The need to be handled like any other dumb battery, settings not withstanding.

For, non standard / unsupported, reasons I need to be able to control Charge current without limiting AC input. I am using the charge current control assistant, right now, which works well.
The above is set to disable the charger when I set 0 current and that results in a Passthru state leaving Assist enabled and ready... Which is great.

The analogue input associated with the CC assistant is currently physically connected to a voltage reference circuit, just a few diodes essentially, which in turn is driven by the Cerbo GX relays.

It works but is admittedly a messy solution. So...

Dose anyone know...

If enabling DVCC, which I should probably do anyway, will allow me to control charge current, with the Node Red node, and still have the Multi go into Passthrough, as opposed to Bulk/Float with 0 current?

Are there any red flags or DVCC setup, particularly when manipulating it that I should be aware of for my simple setup? Still reading the manual but so far all the complication seem to be around ESS and/or more complicated integrated stuff.

Will DVCC and the charge current assistant conflict with each other or is the current setpoint common? (Mainly asking so I know which order to do/test things)

lastly, if I haven't asked something I should have when considering this stuff.

Any and all comments welcome,

Cheers folks.



Alistair Warburton asked
Jeremy Albrecht commented ·

4 Answers

Where did my Node-red flows go? after firmware update node red is empty

Just installed new firmware on my Cerbo GX, updated from 2.80~21-large-23 (20210925...) to v2.90~12 (20220606...) which is also LARGE firmware.

After update, my node-red flows are EMPTY!! and even when I tried to start from backup, the older firmware, still empty FLOWS... Is there any way to return those?

Should the firmware upgrade clear flows from node-red or did I experience some major bug? I understand that node-red is updated a few versions up, was it 2.0.5 and after update 2.2.2 or something like that, but is it meant to clear all flows? Where to get them back...

timo-san asked
mrhappy commented ·

4 Answers

Cerbo GX send receive SMS via GSM ?

Has anyone used Node Red to send and receive SMS messages on their Cerbo GX For status and commands?

I have it working with an email plugin but sms would be nicer.
tks

david-ross asked
bo0om answered ·

1 Answer

Cerbo GX Storage Full?

Hi everyone,

I have a Cerbo GX installed in a remote system which includes a Multiplus, a few solar chargers and smart Lithium batteries. I have Venus OS Large installed and use Node-Red for some automation.

In general it has worked well and has accomplished what I need. But recently I have noticed some strange behaviours with the Cerbo not doing or reporting what is expected in certain situations.

In Node-Red, now when I go to make a change and redeploy, I get an 'out of space' error like so:

Error: ENOSPC: no space left on device, copyfile '/data/home/root/.node-red/flows_einstein.json' -> '/data/home/root/.node-red/.flows_einstein.json.backup'

I can't find any way to actually check and confirm the storage space situation and don't have physical access to the device for a little longer.

Has anyone had storage space issues with the Cerbo before? Why would it have filled up? Log files? And how can I review this?

Any insights appreciated - thanks!

liam-hogan asked
Stefanie commented ·

2 Answers

Reduce charge current based on SOC Multiplus

I want to reduce the charge current from the Multiplus II based on SOC from smartshunt using NodeRec via Cerbo.

I have tried in NodeRed but cannot find a setting to change charge current.
Have anyone tried this?
I see that I can reduce charge current via an analog in and use an assistant in the MP, but this is not a desired solution.

Any advice?

slapperia asked
netrange edited ·

4 Answers

Node-RED dashboard on Cerbo GX Touch 50?

@Guy Stewart (Victron Community Manager)

Is it possible to launch and display the Node-RED dashboard, directly on the Cerbo GX - Touch 50 display?

Like swiping left and right between different default Venus OS screen layouts, could the Node-RED dashboard perhaps be accessible this way, as a fourth screen layout?

Thanks, Anton

plaaspondok asked
Rene Mullie answered ·

2 Answers

No Output nodes available on multiplus

Hi! Just started a new Node red system on a Cerbo with a Multiplus -II 3000.

I've used both Node red and Multiplus-II before but with this installation its fighting back.

I can read input nodes from the multiples just fine, but when I try to use an output node on it, there's is none. The Solar charge output node works just fine.

What am I missing? The firmware is 481 (Newest is 489)

Skærmbillede 2021-11-02 kl. 13.55.54.png

philipr asked
philipr answered ·

2 Answers

Cerbo GX and Node-RED via Venus OS Large: dashboard functions?

Dear Victron-users,

I recently bought a Cerbo GX with touchscreen and after a few days of tweaking I decided I want more, for example a custom dashboard. Installing Venus OS Large was the best solution I was told so I installed it on the Cerbo and activated Node-RED. Via the URL and the specific port I can access Node-Red and put instances on the grid with connections etc. But..... that's where it stops for me ;-). I cannot create a custom dashboard. On all the YouTube films I watched, I see in the left column a submenu "dashboard" with for example gauges etc. but I don't see this menu and when I go to URL/ui I get a error there isn't a GUI. Can someone help me a little bit forward?

Kind regards,

Pim

pim asked
pim commented ·

1 Answer

Cerbo GX node red install

I would like some clarity please before I continue.

Which file do I use to do a manual firmware update, seems like this is not clearly stated in an easily accessible place. (I did look, maybe I am just unlucky in finding it.)

When one does a manual update what happens to all your settings? Do you require a settings backup before the update and then a restore of just the settings? If so then just to be clear how does one do this.

jaaksza asked
jaaksza commented ·

1 Answer

Followers

9 Posts
32 Users
1 Follower

Topic Experts