update Image


This topic has been merged into firmware update . Please use firmware update when editing or creating new content.

MulitPlus-II Firmware V495-V496 problem and Grid code explaination

I updated my MultiPlus-II 24/3000/70-32 inverter with the latest V496 and noted a number of unusual issues which have not been present previously.

1- I'm in Australia and use the local grid codes. In the software new Grid Code AS/NZS: 4777.2.2020 options are shown.

Where is the explanation of what A, B & C options are?

Just checking "no N bypass" = "AC Neutral path not externally joined"?


2- On updating the firmware with the VE bus connected to my local PC I've been getting a Low Voltage Alarm when the inverter goes into an inverter charge mode, charging the batteries from the Grid (which I normally do not do as the solar is the main charging source).

The battery voltage was nowhere near the low voltage limit, and the batteries then stopped charging.

I managed to reset the inverter and lowered the charge current to 20A and all worked mostly well. But again increasing the charger current to 25A caused the low Voltage alarm again.

The ESS has been set to use the Battery Monitor BMV712 Voltage (externally controlled) mode, but the inverter was only connected to the local PC.

This low voltage alarm did not make sense as I could see no reason for why it would be on. The inverter and batteries seem to supply the load without any issues. This problem seems to be new and only presented with V495-V496 firmware update.

I checked all the wiring connections and found no issues, nor voltage issues using an external meter, with everything seeming to function normally except for the activation of the low voltage alarm on the charge current above 20A. Is the problem possibly a firmware issue?



raymiller asked
Jason - UK commented ·

1 Answer

Simrad Evo3S SW Update 20.2 working with Victron App ?

Hello community,

I have a brand-new Victron MultiPlus installation on my boat including a Venus GX to display the charger/inverter data on the Simrad Evo3S MFD. A new SW version (20.2.0) for the MFD became available and should be installed. Will the Victron App still be available and running or is a re-installation necessary? No one from Simrad can answer this question, because it is a third-party SW.

Thanks for you help.

peter5189 asked
kevin-horn commented ·

0 Answers

Firmware updates

Good Morning

Im just trying to wrap my head around u pdates to victron ie.
Inverters, mppt, cerbos.... do these updates come out on a yearly bases or does this is it a monthly thing. Or is this just error based.

judd-1 asked
wkirby answered ·

2 Answers

Cerbo not booting - flashing orange light after failed firmware update

Good Morning,

This morning I started to install the Cerbo in my system. Booting the device with minimal connections went great, and we began to connect the Quattro, Solar via USB, and BMV via VE direct.

A firmware update was detected, and we chose to update to 2.60 - at some point after telling it to perform this update, the Cerbo will no longer boot. (I assume its not booting). We were using the wifi, and check for updates, under the system menu. When it found the 2.60 update, we told it to download and install. It didn't automatically install, but showed in the list of "alternative backup firmwares" to boot from. We chose to boot 2.60 instead of 2.57 and on the next restart, the Touch 50 GX remains blank, and the red / orange Wifi light will begin flashing after a few seconds, but nothing else appears to happen.

1.) Is there a hardware or backdoor way to force the Cerbo to reboot back to the 2.57 firmware?

2.) Is there a way to connect to the Cerbo via a computer and manually push a new firmware to it?

Unfortunately going back to the dealer is a VERY lengthy issue at this point. We're in the Caribbean, and floating in French Martinique at the moment. Anything we do would require weeks and weeks of shipping each way, so hopefully there's a technical way to solve this, as I believe it's just a bad firmware boot, and going back to the old one would be fine?

Thanks in advance for your help.

Bryan asked
stanhausc edited ·

6 Answers

Victron IP22 12/30 (3) fails update

I see others have had the similar problems but cannot see any solution. When I fitted my IP22 last week the update did, after several attempts, succeed. I have come down today and switched the unit on and it's asking to do the update again. This fails at 93%. The failure is X88 - Communications error. Vreg Ack timeout. I have tried both my mobile phone and a tablet both with the same result. I previously used a single output device for the house batteries with no problem. I have tried starting up with the batteries isolated. Always the same.

richard-parker asked
richard-parker commented ·

0 Answers

Can anyone help? ESS still not working.

I have had my Victron Multiplus 2 GX 5kVa unit for a week now of which it has only worked correctly for 2 days out of 7. When it did work correctly, it was perfect. ESS at its best but after 2 days I identified I needed to make a change to the settings in the config file. When i went to do so, the option to download the config file was missing form the VRM portal. Reading the forum and Victron self help guides, it appeared I needed a firmware update. I followed the instructions for the update to the point as best I could assuming all was well only to find out ESS had stopped working after I had finished the update. I have tried everything!. I have re-uploaded the config fil from EV Configure 3 several times, I have checked the settings in the remote console, I have previous posted on the Victron Community forum trying to resolve this issue which has given me other things to try but still no luck getting the inverter to invert automatically.


I have been directed to load my 'rvms' file into the VE Bus Configurator but I have no RVMS file and no one seems able to tell me where to find the file.

The company I purchased the unit from don't have a clue, they only know how to sell products so they are a waste of time. There is no apparent information on the Victron website on how to resole this specific issue.

List of relevant setting / info from within VRM Remote Portal

  • Multiplus-II 48/5000 / 70-50 / Switch / On
  • Product ID 2623 Firmware Version 496
  • VRM instance 275
  • VE Bus version 2623496
  • Mk2 version 1170212
  • Setting / Firmware / Firmware Version v2.85
  • Setting / Remote Console / Enable on VRM / 'On'
  • Setting / System setup / AC Input 1 / 'Grid'
  • Setting / VRM online portal / VRM two-way communication / 'ON'
  • Setting / ESS . Mode / Optimized (with batterylife)



List of relevant setting / info from within VE Configure 3 (Then uploaded via VRM)

  • General / External Current Sensor - tick
  • General / Enable Battery monitor - tick
  • General / shore input limit / 50A
  • General / Overruled by remote - unticked
  • Inverter / output voltage - 230v
  • Inverter / shutdown on SOC - tick + SOC shutdown 20%, low restart 50%
  • Charger / Enable charger - tick
  • VS / Do not use VS - tick
  • Assistants / ESS



Link to video showing settings used in the above


Again, any help in resolving this issue would be greatly appreciated. I thought the firmware update had failed as ESS stopped working after the firmware update but with the advice recieved and the information available on the Victron website, it now appears to be something different. Is there is inverter limiter hidden somewhere in a setting. Comments and suggestions please. I'd be happy to share my screen with some one via Teams or Zoom.

Jason - UK asked
Rob Duthie commented ·

3 Answers

Firmwareupdate MPII 3000/48 für Parallelbetrieb an MPII 3000/48 GX

Ich möchte einen zusätzlichen MPII parallel betreiben. Gibt es eine Möglichkeit über den vorhandenen MPII GX ein Firmwareupdate auf einem weiteren MPII (ohne GX) durchzuführen? Oder brauche ich zwingend ein VE.BUS Smart Dongle?

Ich habe den neuen MPII über VE.BUS an den bestehenden MPII angeschlossen (und auch AC In). Daraufhin schaltet sich der bestehende MPII ab wegen alter Firmware des neuen MP.

Ich hätte erwarte dass ich über das GX-Gerät (MPII) den über VE.BUS angeschlossenen neuen MPII konfigurieren und updaten kann....

behl asked
behl answered ·

5 Answers

Multiplus Firmware 1908142 Update for Lithium Batteries


will this old Multi be able to configure a Lithium charging profile with an update?
Is the shown 1908159 I found the newest?


303fa03c0e2a831fe69792e435ebfd39c562ede39e2111f8845143d8e897d392 2.jpg

Bildschirmfoto 2022-05-02 um 11.01.04.jpg

Martin asked
Paul B answered ·

1 Answer

ESS not working.

Im after some help as I am at a loss with this one. Yesterday I wanted to make a change to the VE configure settings by remotly download the file as i normally do but on this occasion, the option to download the file was missing. On reading up simular issues, it indicated to a required firmware upgrade required of which I carried out. Once I did the firmware upgrade, I made my change to the float voltage down a little, saved the file and uploaded the file. Then I noticed ESS would not work. The batteries were at or near 100% and as it was the evening, I was expecting the inverter to be running meeting my AC out load but all it would do was to keep charging in bulk, absorption or float.


The only way I could get the Multiplus to invert was to manually out it in 'invert' mode, not 'On' of which it disconnected the AC in as you would expect. I have reloaded the VE configure setting several time, tried making changes to the setting in the remote console but still it will not invert in ESS mode. Ive tried reading very forum post I can with similar issues but no luck with any suggestions.

EV config setting below / attached.

Any help greatly appreciated as currently I have a ESS system doing noting. I have the Multiplus 2 5kVa GX version.


Jason - UK asked
Jason - UK answered ·

4 Answers

Failed firmware update & how to fix?

So after spending the last 24h trying to work out why my ESS is not working, I have come to the conclusion that the firmware update filed. Does any one have a guide on ho to start again with a firm ware update? I did find one guide but it requires me to download my VE config file and load it into the VE Bus System configurator which doesn't work as the file types are not correct for VE Bus System config.

Jason - UK asked
Jason - UK answered ·

2 Answers

bmv-712 smart battery monitor won’t update (Bt200)
Like others the battery monitor was working fine until i tried using the Bluetooth function. Now it’s stuck on the bt200 error code screen and all buttons are unresponsive. I’ve tried several time deleting the Bluetooth device, the app, tried re installing the update but still no progress. It gets about as far as 18% and the restarts back to 3%. The current version is oddly saying: None

I have no troubles connecting to it but it simply wont update.

I have also tried updating with multiple ipads and even my laptop. Still the same result.

I have also unplugged the device from its power source multiple times, sometimes up to an hour hoping it would reset it but every time I plug it back in it reads the Bt200 error code


zane-jackson asked
zane-jackson commented ·

6 Answers

Smart Solar 150/60 firmware Upgrade not available in VRM - Product not in library

I have a SmartSolar Charger MPPT 150/60 and in VRM -> Device List -> Firmware update VRM shows "Product Not In library". Previously it had showed as "up to date" (a week or so ago). I also noticed it shows v1.59 while the Victron Professional shows a v3.1. I tried to upload this SmartSolar_MPPT_Charger_150_60_v3.10_A06B.xup file via VRM but I got an error:

"An error occured during the update process. Please try again later! Error Message: xupd-66." followed by a another error:

"The installation is already executing another request. Please wait and try again. Error 1391"

How can i update the firmware and what is the latest version?



joe-d asked
mvader (Victron Energy) answered ·

4 Answers

Victron Orion-Tr smart won't let me update version to latest.

I have firmware v1.06 and when I try to update it says I have the latest version. How do I get to v1.08?

dc4me asked
Stefanie commented ·

0 Answers

MultiPlus Firmware history

I have a MultiPus 3000 with firmware version v430. I see that version v494 is the latest. All is working well but am I missing out on new features I might benefit from?

andrecampeau asked
Matthias Lange - DE commented ·

4 Answers

New batteries installed: GX Error #48 DVCC with incompatible firmware: Warning

Below is my current installation. As you can see I‘m stuck on firmware v413. Any ideas how I can remove the GX Error? What firmware version should I be running and how can I update to that version?


MultiPlus 48/3000/35-50

Note - Firmware installed v413, latest v496, not updatable (1342)

BYD LV Flex Lite x 4

Note - BMU v1.22, BMS v1.13

mknoxc asked
mknoxc answered ·

2 Answers

521 Posts
40 Users

Topic Experts

0 Points
0 Points