charge controller error Image

charge controller error

Getting very low watts from charge controller

I bought 700 watts of solar to go along with the 100-30 amp charge controller and I have only seen the highest watts of 150 coming from the controller. I even got it replaced and i’m still seeing such low numbers when the panels are in direct sunlight. I also tested the panels individually and they are both working properly

zaczaller asked
pwfarnell commented ·

8 Answers

MPPT 150/70 unit has stopped charging batteries past 71%.

Hi guys, so I've got an issue with my easy solar 24v/3000va/70amp MPPT 150/70. The battery's wont charge fully so I'm running out of power every night. it is like the unit thinks the battery's are full as it will only let the amount of PV in as is being used at the time never getting over 71% of charge even in full sun. So if I put it under load it jumps right up to accommodate. The system was working fine a month ago but now won't charge? I'm using GS YUASA PWL 12V 100AH lead-acid battery's.

Would really appreciate any help that could be offered.

Kind regards

Leonardo

cappadonaleonardo asked
kevgermany edited ·

4 Answers

Has anyone’s SS MPPT 150/85 behaved erratically, blue light fluttering, off to bulk to off to bulk?

Last week, I updated the firmware for my SS MPPT 150/85, and the charger immediately began acting erratically. Not charging, blue light fluttering, off to bulk to off to bulk. I thought that it could’ve been a loose connection or bad circuit breaker. So I checked the connections, and the breaker. Everything is fine.
The only change that’s been made is the firmware update. Before that, the system ran flawlessly.

While it’s doing this, there are no error codes.

alia-a asked
jeffles answered ·

4 Answers

No stored power use.
  1. two 295w panels
  2. two 6v FLA batteries
  3. BMV-712 Smart
  4. MPPT 150/45-tr
  5. 2000 / 80-50 120v inverter
  6. surge protector

My remote off grid system was installed Oct. 2018. Has been having problems on and off for over a year. My service vendor has been out a few times but still cannot figure out what the problem is. I spent a lot of $ on this system to basically be able to not waste gas running a generator to run LED lights for a couple months of weekends in the fall. As soon as I turn on more than one light, the system goes into alarm mode. Batteries are showing full charge and tested to have 13.2v on meter. It seems the only time system works is when I run the generator or have lots of sun power. Not what I paid for. I am not receiving any stored power. I am being informed that it’s in the program of the controller but I am not skilled to program it. My authorized Victron installer cannot figure it out either. Its an hour from my house so not easy to troubleshoot. And when on site, we have poor cell coverage also. I do all firmware updates when I have been asked.


Thank you, TBell

tbell asked
Paul B answered ·

1 Answer

My 75/10 Charge Controller Stopped Showing Data in the App

Hi - I'm thinking this might end up being something simple, but I can't figure it out. I have 75/10 solar charge controller and a 712 monitor. Both worked fine with my Victron App. Now the main screen for the charge controller only shows the controller summary (version, firmware, etc). I can see the history or current stats. I think this happened when I was trying out the networking features. Any idea how to reset things so I can see the full details in both my monitor screen and solar charging screen? Thanks!

maxsteckler asked
Thiemo van Engelen (Victron Energy staff) commented ·

4 Answers

Boondocking with BMV-712: SOC error? Best practices?

I have the following setup: smaller 2015 Lance travel trailer with 2ea 12V lead acid flooded batteries in parallel, BMV-712 and the standard Honda 2kW generator. The trailer's battery charger seems modern (3-stage charging, lots of amps, etc.).

I plan to boon dock (no shore power) regularly and would like to tune the BMV-712 to help keep the batteries charged, healthy, and to know when and how long I should run the generator.

From research, I know I should always keep the batteries above 50% capacity to avoid premature replacement costs. Also, without many hours of charging (e.g., plugged in or on solar), I cannot expect battery capacity to rise above 90% while boon docking.

When charging from, for example, ~60%, the charger will be in the "bulk" mode with high current, and rising voltage. This charge mode is the quickest, but only gets to 80% capacity.

Then the charge mode changes to "absorption" where the charger voltage is held high (14.6v in my case) and then the amps fall off toward ~2amps (in my case) when the charge mode changes to "float" at which the battery capacity is at 90%. To charge from 90% to 100% capacity would take many hours and isn't reasonable while boon docking.

Therefore, while boon docking, I should expect to cycle the battery between 50% and 90% depending on loads and generator run-times.

However, AFAIK, the BMV-712 is designed to treat the 90% charge state as "100% SOC" (?) The BMV-712 decides that when the voltage is the high "absorption" mode, and then the current drops below a "tail current", it proclaims SOC = 100%. But in reality, the battery is at 90% capacity at that moment (i.e., at the end of the "absorption" mode).

If starting from a full-charge (i.e., batteries have been plugged in for a day), the SOC value will be fairly accurate. However, if not starting from a true full-charge (allowing the BMV-712 to auto-sync the 100% SOC value at the end of the absorption mode), the reported SOC value will be 10% lower than reality. So the accuracy of the reported SOC value depends on whether the previous charge completed the float mode? Is this true?

If that's true, then I must tweak other settings to make the SOC value match reality or add-in some fudge-factor or work-around.

I could:

  • tell the BMV-712 that the "battery capacity" is 10% lower than the battery specification.
  • set my "SOC relay (charge floor)" to 60% instead of 50%, and mentally never let the reported SOC value fall below 60%

Is this a known problem with the BMV-712 SOC value? What do others do to work-around this inaccuracy?

Do other boon dockers have tips on using the BMV-712 to stay confident that the generator is running for the right amount of time?

Thanks!

goodguy5000hd asked
captn-mike answered ·

2 Answers

error 67 BMS connection lost- worked fine for 6 months then randomly popped up.

I have a cerbo gx running my system connected to 1- 250/100 MPPT via direct cable 3-150/85 MPPT's connected via VE CAN to the CAN Bus port, I'm running a Batrium BMS connected via the BMS CAN port, and two 3000va multipluses. the system has been working perfectly fine for 6 to 8 months since i installed the 3 150/85s via VE CAN and the batrium BMS. This morning i found a error 67 and the three 150/85s wont charge, even though the bms is reading on the gx screen just fine without any errors.... was there a recent firmware update that may have messed with this? if not what can i do.

froste9 asked

0 Answers

MPPT 150/70 Error code #38 - Input shutdown due to battery over-voltage

My system has been happily running well (without error) for 6 months - 1 week ago started throwing #38 errors (this seems to correspond to updating firmware) during the peak of the day.

The systems includes;

  • Cerbo GX v2.71
  • BMV-712 v4.07
  • MPPT 150/70 rev 2 v 3.07
  • 800Ah lithium battery cells managed by Daly 4S 250 (Cells are Balanced - BMS appears to be working correctly.)

I captured reports from MPPT after each error yesterday;

1:48 pm

Days ago

Date

Yield(Wh)

Max. PV power(W)

Max. PV voltage(V)

Min. battery voltage(V)

Max. battery voltage(V)

0

12/08/2021

980

771

23.59

12.43

14.52


1:57pm

Days ago

Date

Yield(Wh)

Max. PV power(W)

Max. PV voltage(V)

Min. battery voltage(V)

Max. battery voltage(V)

0

12/08/2021

10

559

22.34

12.49

13.79


2:09 pm

Days ago

Date

Yield(Wh)

Max. PV power(W)

Max. PV voltage(V)

Min. battery voltage(V)

Max. battery voltage(V)

0

12/08/2021

30

559

22.34

12.49

14.05


The battery voltage is set correctly - 12v

There is a secondary MPPT 100/20 - setup is consistent and error occurs with this connected or not.

Not sure why this would only start occurring only a week ago? has something changed in the firmware?


Any advice would be greatly appreciated.

graychris2 asked
mvader (Victron Energy) answered ·

1 Answer

what is the required increasd of batteries voltage to activat the Error :#38 ?

Hi All

Our system consisted of 9 Quattro 15 Kva inverters, and 23 SmartSolar MPPT 250/100,

System working four months without problems, 6 days ago the Error Code: #38 appeared in our solar system and one of the MPPT Solar Charger burned and all remaining solar chargers stop working (no charge from the solar, no light flashing ) when we try to investigate about this we found 2.4V variation between the MPPT solar chargers, and inverters charge voltage setting. (MPPT setting : absorption =55.2V float=54V, equalization not active (disable))and inverter setting is ( absorption =57.6V,float=55.2V, equalization not active (disable )), So our concern is if this variation (2.4)V could cause error #38? , if this error could burn and make all solar mppt faulty.? If yes why has the system working for about 4 months with this configuration without any problems?

ziadabdullah asked
wkirby answered ·

1 Answer

Why is my solar in float mode when batteries are dead?

I have a mppt 100/50 charge controller. Woke up this morning to dead batteries. Charge controller has been in float mode for 6 hours now. I have 650w panels and it only brought in 30wh today and it's sunny. But shows my batteries have been as low as 0.01v and high of 12.4v. very confused but inverter will not power on. App says my current battery is 13.6v

thunt601 asked
christopher-maric commented ·

3 Answers

Status Bulk Charging w/Voltage, but Current at 0 Amps

Hello, I have a 100/15 MPPT connected to a small vehicle solar array. It currently shows a state of Bulk Charging, but it shows 0 amps under current PV and Batt.

I've checked all fuses and made sure it's set properly for my AMG battery. When I initially hooked up the MPPT it showed Amps for the current, but after about 1hour it went to 0 Amps and has never changed from there (multiple days).


Firmware has also been updated.

[image]

james-eaddy asked
james-eaddy answered ·

2 Answers

MPPT measuring wrong battery voltage

Dear all. My MPPT unit as stopped charging the battery's. On investigation my victron app is reporting the battery at 13.82v but the actual voltage is 12.56 at the battery terminals, the MPPT controller battery terminals and is also confirmed by my victron shunt at 12.56v

I've factory reset the MPPT with no effect, what do i do next please. Why would the app report an higher voltage and im assuming thats why im getting no charge

busdennis asked
wkirby commented ·

2 Answers

Smart solar 250/60 charger off?!

Bought new charge controller, connected panels. But the charger is not turning on.

I have checked all cables, fuses and rebooted.

i attach images


[image]

[image]

willowfarm asked
willowfarm commented ·

3 Answers

BlueSolar PWM Light charge controler Stopped working after only 3 months

I have a BlueSolar PWM Light charge controller connected to a 60w solar panel and a 70ah battery. Everything was working fine during 3 months, then the controller just stopped working. It just went off and I can’t switch it on anymore, I removed all the wires and put them back again, I checked the battery and solar panel and they both work. But the controller doesn’t even recognize the battery anymore and all the light are off.

Any insights?

crutzen-anne asked

0 Answers

SmartSolar MPPT 100/20 turning the load "On" then "Off" then back "On".

I purchased a Victron SmartSolar MPPT 100/20 Charge Controller. I am having a problem with the charge controller cycling the load "On" then "Off" then back "On".


Description of failure:

1. The charge controller will show that the load is set to "On".

2. A 12v fan is connected that draws a max of 9W of power or a car cell phone charger is plugged in (without the phone connected or charging)

3. The charger controller will show that the load is turned to "Off"

4. Have a pause for 1 to 2 seconds

5. The load will then be turned to "On"


Notes: The charge controller never shows a voltage below 12.6 volts from the battery so I know that it is not pulling a large load from the battery.


I don't see how a 12v phone charger without a phone connected could be tripping the 20A capacity of the controller.

sailboattn asked
tomvacek commented ·

2 Answers

MPPT Fault #21 & negative amps

Have been running my MPPT 100/20 for about 1.5 years without issue on my travel trailer. We are out on a trip now & I noticed one morning no charging & a fault #21.

I unplugged everything & replugged...worked fine. Next morning...same thing but went back to fault some time during the day...then I reset again... next morning no fault but was seeing battery bounce between negative amps & 0 at the MPPT battery with a bulk charge. When I disable charger (off state) & re-enable, it faults. Wont charge at all now.

Thankfully I'm at a plug in site for a week so don't need solar...but whats going on? Faulty MPPT?

[image]

ghostrider asked
Alexandra answered ·

1 Answer

Lost the MPPT 150/70 connection on the ColorControl

Good day, I just lost the"connection" between the 150/70 CC and the Color control ? Suddenly.

The Color control shows "not connected" for the Charge Controler .

Checked the cables and they seem OK.

Checked to "see" the CC with bluetooth and I do see it there .

Any idea what can have gone wrong ?

Thanks

Herve RV Nizard asked
michelg answered ·

4 Answers

voltage drops from solar panels once connected to MPPT

Hey guys so I have 3 sunpower e-series solar panels on the roof of my van. They are all ran into a fusebox/combiner which when the fuses are shut sends the power generated from the panels to the mppt 150/35 charge controller. When I test the voltage from the panels on the line side of the fuses I get 72.9 volts for each panel. When I close the fuse completing the circuit to the charge controller and the batteries the voltage drops to 1.9 volts tested at the load side of the fuses and at the pv +/- terminals on the charge controller. I don't get any lights on the controller, and no bluetooth connectivity. I'm not sure what is going on, I have 1 panel on each side of the van on it's own charge controller. I messed up on one and had the pos./neg. wires swapped so I accidentally blew the fuse on the 100/20 charge controller for the drivers side panel, but that passenger side 100/20 controller works fine, I can connect via bluetooth, I have lights on the front everything functions properly. So, my other small controller is bad (need to replace a fuse) but the big controller for the roof panels seems to be drawing the voltage from the panels down a lot. What can cause this?

airborneeyepatch asked
Matthias Lange - DE commented ·

3 Answers

No Float or Absorption!

Hi

After taking all wires off the charge controller to reset the Bluetooth and enter PUK code to get Bluetooth working on the app.

My Float and Absorption is now not showing anything just Bulk 100%. See attached pic. The battery does charge up!

Not sure why this is happening???


[image]


srowe asked
trip-tracks answered ·

1 Answer

Charge controller display displays "disconnected" on 100/30.

"Disconnected" scrolls across monitor. System not working. As far as I can tell, the connections and fuses are fine. I had 12.5v, moved my vehicle, and it said disconnected. I connected my spare 100/30 and it works fine.

wildernut asked
wildernut edited ·

0 Answers

Charge controller (MPPT 75/15) lights not turning on

I recently chose to replace an older PWM controller with a Victron MPPT 75/15 charge controller, and yesterday I hooked them up to my fully charged battery bank (12.85 V before starting). I followed the instructions, that say that I was to hook up the cables in this order:

  1. Hook up the load
  2. Hook up the batteries
  3. Hook up the PV

Nothing happened on 1, but some leds flashed for a second or so when I connected the batteries. After that, it has seemed dead :-/ I disconnected the various cables to see if it happened again, but they all remained "dead" (no light). Yesterday was overcast/grey, so was getting 16.5-17V from the PV cables (two panels of 140W total max), and I wonder if this is the reason? The manual says it needs Vbat + 5V to start, and I guess that means it would need a minimum of 12.85+5=17.85V from the PV cables to get a starting power? Am I right in understanding this "Vbat+5V" terminology? The system is in a remote location, 3 hours from my home, so I am not able to hang around for sunshine to appear to verify ... Just had to leave and hope for the best :-/

One indication that something was happening is that the initial voltage of the batteries (same reading from the battery terminals as on the screws on the controller) increased after connecting them to the controller, from 12.85V to 13.2V, after a little while. This indicates they were being charged, but I do not understand how, if the controller was inactive/powered off. The LED overview in the manual did not show what "all leds off" indicated, so I assume that would imply a non-functional state.

I read some threads on the same topic for this controller, but could not really glean much info from them (conclusion: hw error).

Points where I have deviated from the manual

  • Did not connect a earth/ground wire, basically because I have no idea how to do that when I did not find any diagram or specific terminal marked "GND" or something
  • Connected everything while the controller was not yet mounted. The manual says it should be mounted vertically, which I did after connecting everything, but I cannot see how/why this should matter.

Debugging info:

  • Voltage reading from BATT screws on controller: 12.85V
  • Voltage reading from LOAD screws on controller: 12.85V
  • Voltage reading from PV screws on controller: 16.8V
  • 4 Concorde Sun Xtender 2580 batteries in parallel connected to bus bar
  • Charge controller connected to 100A busbar (one per polarity)
  • All battery cables of equal length (1m) and terminated with cable lugs or similar.
  • Sufficient cable thickness. 10mm2 for batteries, 6mm2 to load, 35mm2 to PV (long length).

carl-erik-kopseng asked
carl-erik-kopseng answered ·

2 Answers

Victron 75/15 overcharging battery

Hi. So my alarm in motorhome was saying leisure battery was overcharging. A 120w panel and victron 75/15 charge controller as been powering up my leisure battery fine for around a month. I connected up to a spare battery and its going up to 15.1 before I disconnect it cause seems to much thanks steve


Steve asked
trollan answered ·

4 Answers

Charge controller data resets to the next day in the middle of the day?

I recently installed the victron mppt charge controller and BMV-712 on my camper with 600 watts of solar, and 200 AH of lithium batteries. Everything seems to work fine and I have everything programmed for the lithium’s but the history of all my solar data seems to reset to the “next day” at odd times. The first time was the day after installing it, it reset at 7pm. So I tried resetting it at midnight thinking there was a built in clock or something. Seemed to work fine for 3 days but now today it reset at roughly 1:00 in the afternoon with basically full sun. I can’t find anyone else having the same issue, any suggestions? Or does anyone know more about how the charge controller judges the time/day?

stranz4 asked
Jaco Reinecke answered ·

1 Answer

Will input high voltage damage the system?
  1. I have 5 12v panels in series feeding a 100/50 controller. Generally the voltage is between 85-95 volts, but does fluctuate a lot. Is this normal or are my second hand panels bad? Today i got a #33 input high voltage error as the voltage reached 100.5v momentarily. Should i be concerned about damaging the controller with high voltage?

iamjosh35 asked
dazey77 commented ·

1 Answer

MPPT 150/70 Shows Voltage But No Current

Just finished installing my solar set up in my camper and am having some issues with the MPPT 150/70 (I have no doubt it's installer error).


The blue light labeled "bulk" is flashing every few seconds. The other lights are not on. In the Victron app, it shows approx. 66V coming from the panels but 0W of solar, 0.0A of solar current, and 0.00A of battery current. Also, the battery state is off and virtual load output is off. Batteries seem to be connected properly since lights and fans are working.


Based on other posts in this forum, I have double checked the connections and they seem correct. I checked the polarity of the panels, and they are correct. Breakers are switched on. Connections are as follows (starting from controller):

  • Battery+ to 80A breaker to positive battery bus.
  • Battery- to Victron shunt (BMV 712)
  • PV- to negative PV connection
  • PV+ to 15A breaker to PV positive PV connection


Below are screen shots of the app and the wiring diagram of my system.


Any help is appreciated!

[image]

[image]

[image]

[image]

tennadam asked
tennadam commented ·

6 Answers

Trouble after firmware update fail

So time to ask for help. I did the latest update on the firmware for my VictronConnect Smart Solar MPPT 100/30 it took the first update then it said it needed another and halfway thru it an alert said unable to update due to unknown error. It now says it’s connected to another device ??? Not sure how to reset that in the charger as I’ve done everything to delete it on my phone

Now when I do a search for it on my iPhone thru the VictronConnect app it shows up but it’s shaded and has a connection error (see picture)


I’ve reset my iPhone, I’ve signed out of the app I’ve even deleted the app and still no joy any help would be much appreciated. PS this controller has only had a single point connection in the past and that is to my iPhone.

Thank you in advance

[image]

irhere47 asked
Matthias Lange - DE answered ·

1 Answer

Error 21 on 100/50 charge controller

Hey All,

I have a 100/50 MPPT connected to 1200 watt solar at 60volt and to a leaf battery. I get a error 21 shutdown on the charge controller. The dealer sent a new one and it worked 2 days and the error came back on this one too. I checked all wires and turned out good. Last time it happened the battery was at 98%. Dealer said there is some sparking going on in the solar wires. But how can if there is no current flowing anymore. On the battery side, there was no load on except the inverter (multi) was on. After some research i only find this error on 100/50s not on any other controllers.

can anybody shine some light on my problem?

texdoe asked

0 Answers

Mppt charge controller leaking battery voltage to pv input connectors?

Hi, I have a Mppt 150/70 Mc4 and it has been working great for the last 4 years. I have the Bluetooth dongle so I can monitor the PV array out put and then the load.


But now something strange is going on.....

When the sun was setting I noticed the voltage didn't drop to below ~25v. Even when I disconnected the Pv array the voltage is the same. For some reason the Pv voltage is more or less set to the same voltage as the batteries (24v).

It's like the battery voltage is leaking out to the PV connectors. Not until I disconnected the batteries, the controller stopped "charging" (blue light on). And now when I connected the batteries back the voltage for the PV array is again ~24V. I checked with voltmeter that the voltage I was reading on the app was coming to the Pv connectors and it is.... Please help! Is it still safe to use? Is it broken? What can I do?

gojs asked
Mark answered ·

1 Answer

Draining Battery?

My setup:

  • Victron SmartSolar MPPT 75/10
  • 100 Panel on the vehicle roof
  • Odyssey Group 31 battery.
  • 10 gauge wire on the PV and Battery side leads with a 10a fuse on the positive battery lead.
  • No load connected


When the vehicle is in the garage I use a CTEK (Odyssey approved) charger. So the vehicle normally leaves the garage with a full charge. I will drive to the store and turn the vehicle off with a fully battery (around 12.8/9) and look on my VictronConnect app that I am getting PV. I will come back a short time later (20 mins) and my battery is at 12.4 which shows both in the app and also in a separate volt meter I have installed. What in the world is going on?

guardcompany asked
Charlie Johnson answered ·

3 Answers

Controller oscillating power from 14 to 32 volts continuously

I’ve just installed a BMV 712 monitor and a Bluesolar 100/30 controller and I am seeing some very odd behaviour. First this is a dark, gloomy, rainy, windy day here in the Pacific Northwest. I have two hard panels wired in series and two semi flex panels wired in series, both sets wired in parallel to the charge controller. Each panel is 100 watts for a 400 watt total.

With everything connected the power and current from the charge controller oscillates from a low of 14 volts then rises to 32 volts before immediately dropping back to 14 volts. This pattern repeats every 30 seconds or so. The 14 and 32 volt thresholds might change by a volt or two on every cycle but the pattern is consistent. As the volts go up the amps go down. We’re talking 0 to .8 of an amp.

FYI the panels are one year old and worked just fine as configured with my old Epever controller. The wiring has not changed

has anyone seen or is familiar with this pattern? Any suggestions?

don-binns asked
don-binns answered ·

3 Answers

60 Posts
59 Users
0 Followers

Topic Experts

There are currently no experts identified for this topic. Can you answer questions in this topic area? Community members who provide answers that are marked as correct earn reputation and may become recognized as topic experts.