MPPT - Solar Charge Controller Image

MPPT - Solar Charge Controller

MPPT Control repeatedly into ‘connecting’ status after firmware update

After using the MPPT Control in conjunction with the Smart Solar 75/15 for about a year the MPPT Control had the ‘CONNECTING’ issue in november after updating the Smart Solar to firmware v1.53. Disconnecting/connecting the VE cable resolved the issue for about a day... Every time the ‘CONNECTING’ message renders the display inoperable. An update to v1.54 made no avail.

After contacting the dealer did an update at their workshop of the MPPT Control but afterwards the display mentioned ‘UNSUPPORTED F ’_’ VERSION’. In the end the display was swapped for a new one. The new display has functioned for a few days until I checked it again yesterday (11 days after installing).

some (maybe useful) info:

-The smart solar still runs v1.54 (VictronConnect v5.35) and has no problems.
-The camper unit is placed under a carport so the (2x 80wp solar panels parallel) have no input whatsoever.

-running a LiFePo4 4-cell Chinese brand fully balanced battery with a VictronConnect blue smart IP67 12V/17A mains charger. The battery is floating @ 13.52V.

Is this issue software or hardware related? Hopefully fixable with a new firmware?

hajok asked
Stephen Roche answered ·

8 Answers

MPPT Control “connecting”

I have the same issues as noted on several other threads. We have the MPPT 100/20 with the MPPT control. The first control ordered earlier this year showed "connecting" after a week or so of being installed and was replaced under warranty. The replacement did the same. Now the third unit, which the supplier said they updated before shipping it to me, now also simply says "connecting" after a week or so of being installed. I would be very grateful if Victron could please advise a final solution as 3 controls haven’t worked since bought new.

Thank you

joelscarr asked
Thiemo van Engelen (Victron Energy staff) answered ·

11 Answers

MPPT Charger 150/100 rev2 A059 v1.47 firmware stability issues

Good and sunny day to everyone,

I just upgraded my mppt charger via VRM Remote Firmware Update feature from v1.46 to v1.47 as usual and despite upgrade went as expected and successful (saw 1.47 as new firmware on dashboard), somehow the console PV Charger indicator started to show fluctuations between ~1400 watt and 0 (zero watt) in every 2-3 seconds in a loop.... 0-5x-8xx-14xx-0-5x-7xx-14xx....watt. something like MPPT is rebooting in a loop.

I thought that it may be the online upgrade which created this problem, and for a second time, I downloaded "Solar Charge Controller MPPT 150-100 rev2 SMART v1.47_A059.dup" file from Victron web and once again upgraded from VRM portal, this time by providing custom firmware file. it again upgraded successfully but did not solved the issue.

I had to return back to original firmware "Solar Charge Controller MPPT 150-100 rev2 SMART v1.46_A059.dup".... and now everything is stable like before....

[image]

12:48 - online upgrade to v1.47 from v1.46

12:58 - online upgrade with manual upload of dup file v1.47 to v1.47

13:21 - downgrade to v1.46

So anyone else faced similar issue before? I checked the firmware release notes and did not see any special instructions for v1.47. Also I did not see anything abnormal in the logs, no alert of warnings. Anyone knows where is the upgrade and mppt logs files and how to see them so that I can debug the issue?

Thx...


dolak asked
jeffles answered ·

4 Answers

My NMEA network looses instance ID when cerbo looses power.!
  1. Currently we use Cerbo GX to read data from the smart shunts (500A) and Bluesolar regulators (MPPT 75/15). The regulators data instance ID goes to default whenever I lose the power to the Cerbo GX. But this doesn't happen to the smart shunts, they come live and start to send data when it again powered. I got three smart shunts and 7 regulators. All my smart shunts are connected to Cerbo directly using VE direct cables and the regulators were connected through powered USB hub.
  2. ( Here, am using NMEA reader to set the data instance). Whenever I lose the power, I have to reconnect the actisense and set the data instance again.
  3. I'm using Empirbus system to monitor all these data and the end result is no info from regulators due to this. The PGN number is 127 508.
  4. From my understanding, the pgn is forgetting the data instance ID whenever a power outage happens in Cerbo. But this only happens with mppts.


Is there any fix for this?

edwin-earthcruiser asked

0 Answers

MPPT in ESS not ‘bms controlled’

I’m running a ESS system with new Multiplus 2 48/3000 And a MPPT 150/35 with VEdirect. It has 2-wire bms on it which all works fine. But when the multi is switched off or disconnected by loose cable or something the MPPT goes from network controlled to standalone and won’t stop charging. before I had an multigrid2 and everything was running well, when multi disconnected the MPPT stops and I get a warning ‘no bms’. Already updated everything, but how do I get the MPPT back to ‘bms controlled’?

[image]

[image]

tommas asked
tommas edited ·

2 Answers

100v 100a controller - ok to use different brand panels in different strings?

The controller I’m getting has inputs for three strings of panels. Is it ok to use different panels as long as they are the same wattage and in the same string? Or do all the panels have to be the same brand?

john-smith asked
JohnC answered ·

2 Answers

Smart Solar MPPT 75/15 on/off?

Hello Community,

I am figuring out my 12V solar system and plan to use a MPPT 75/15. My camper is parked in a garage for a few weeks at a time and I have all loads disconnected from the battery when in storage.

I'd like to fully turn off (not just the charging, but completely off so there is no draw either) the MPPT when the camper is in storage. Is that possible via the built in features on the MPPT?

If not, would I use the VE.Direct non inverting remote on/off cable? I can't exactly tell if the remote cable could just be connected to a 12V switch?

Thanks in advance

hksjza70 asked
Alexandra edited ·

1 Answer

Problem Report - Smart Solar MPPT sometimes sets Optimum Operating Point near Zero

Here is, I believe, a unique problem with the MPPT algorithm. (We don't have many cloudy days here in Phoenix (Arizona). So we never had opportunity to see this problem before.)

Hopefully my short video shows (and explains) the problem.

https://jmp.sh/ijkBgeh

Briefly, I was helping a buddy with his camper van conversion on an overcast day. He has a Smart Solar MPPT (latest firmware) and one 370 W solar panel on his roof. This day it was making about 60 W at best.

We were doing some load testing on his system, and so we were operating his Dometic brand Air Conditioner, which draws 2000+ Watts. (He has a Multiplus 12/3000.)

We had depleted his battery bank down to about 50% SOC during testing. (Battery Voltage at about 12.5 V when loaded.)

While we were testing, he decided to see how much power his MPPT was delivering. I was surprised when he showed me it was showing near Zero Watts.

I noticed that the battery voltage was dithering a lot. And so I hypothesized that the MPPT couldn't find an optimal operating point with one of the parameters moving around too much.

To test my hypothesis, I turned off the Air Conditioner. The output of the MPPT jumped almost immediately to 60 W.

Then to make sure this was consistent, I turned the Air Conditioner back on. And the output of the MPPT returned to near zero.

Now, I don't know if the root problem is that the voltage was dithering, or if the battery voltage was too low for the algorithm.

It's sunny outside today and his batteries have been recharged to 100% SOC. So I suppose that I should go to his house and perform another test to see if this "failure" mode only happens when the batteries are low.

I will plan to do that test tomorrow and report back here.

pmikep asked
pmikep commented ·

0 Answers

Low Temperature Cutoff not working

Hello

I have a Smart Shunt with latest firmware with a ve.smart networking setup to 2 MPPT 100/50 and 4 Ip22 12/30 chargers.

Everything is using the Lifepo4 profile with a low temp cutoff of 5 degrees C

It simply doesnt work with the charging continuing at 4 degrees C

Everythings firmware is up to date and the synchronised charging works perfectly but alas not so the low temperature cut off

Any ideas as to why?

duane asked
mvader (Victron Energy) commented ·

4 Answers

Victron App Reporting Incorrect Voltage

My Smart Solar MPPT 100/30 is reporting to the app 12.78 V while my multimeter reports 14.24V at charger's battery terminals. The multimeter also reports the same voltage at the battery terminal. What is causing the MPPT to report a lower voltage than the actual values?

I've uploaded a screenshot of the app and a photo of the multimeter reading for reference. Thanks for any help.


[image]


[image]

joe-m asked

0 Answers

Overpowered MPPT with Pylontech batteries?

Hello,

for my house I will install PV during next spring and I want to use Victron devices with Pylontech 48 V LiFePO4 batteries (4x US2000C or 3x US3000C). I will have 2 strings - one string to south-east (10 panels 330 Wp, 5S2P - 2 parallel sections with 5 panels in series, 3300 Wp in total) and one to south-west (12 panels 330 Wp, 4S3P, 3960 Wp in total).

I was planning to use MPPT SmartSolar 250/60 for S-E string and 250/70 for S-W string. For example type 250/70 is (according to datasheet) suitable for nominal power 4000 W, but its apparently valid for charge "absorption" voltage approx. 57 V. For this voltage max. output current of 70 A should be sufficient without any significant PV power limitation according to my calculations including losses (<70 A for panel temperature >10°C). If I will use Pylontech batteries I must set charge "absorption" voltage only to 52 V (due to problems with overvoltage warnings), so theoretical PV max. power with 250/70 will be only 3640 W (practically <3600 W due to MPPT efficiency.

So I must use more expensive 250/85 (which is only in VE.Can modification) instead of 250/70 only due to Pylontech batteries, if I am right? Similar situation is also for S-E string with 250/60...


Many thanks for you answers!

motylu asked
Murray van Graan answered ·

1 Answer

Changement de smartphone

Bonjour,
Je possède une petite installation solaire pour un usage personnel. J'ai installé l'ensemble des équipements et, tous fonctionnent très bien. Le problème que je rencontre est que j'avais installé le system avec un smartphone et depuis j'ai dû en changer. Avec le nouveau téléphone, je n'arrive pas à me connecter avec 'victron connect" via le bluetooch, à mon matériel, MPPT 75/10. J'ai essayé de désinstaller la liaison sur l'ancien appareil, je désactive bien mon wifi pour la connexion avec mon bluetooch, mais, rien n'y fait. Si vous pouvez m'aider, j'ai essayer de poser la question à mon revendeur, mais je reste sans réponse de sa part.

Merci de votre aide.

Cordialement

Michel

bazm asked
bazm answered ·

3 Answers

MPPT 100/50 not using VE Smart Networking voltage

Background:
I have an install where a customer wanted to charge their RV LiFePO4 batteries via solar panels mounted on their shed and also use the RV power for running fridges in the shed, but they did not want the solar regulator mounted in the RV. A SmartSolar MPPT 100/50 was mounted on the shed wall with a 10mm2 x 5m cable length (10m return) between the solar regulator and the batteries. I knew voltage drop under load was going to be an issue, so planned on using VE Smart Networking to resolve the issue.

The customer already had a BMV700 installed in their RV, so I added a Smart Dongle to provide the BT connectivity to the Smart Solar MPPT100/50, created the VE.Smart Network on the BMV700 and connected the 100/50 to the same network, and the displays on both devices verified the voltage and current were being used (apparently).

The absorption voltage was set to 14.2V and float to 13.5V.


Result:

The displayed battery voltage on the MPPT 100/50 was showing 14.21V almost immediately on switching on the charging, the displayed voltage on the BMV700 was 13.5V (13.88V on the captured image, but that still shows it as different). The 100/50 immediately went to absorption, ignoring the BMV voltage. I would have expected the MPPT to display the BMV voltage and stay in bulk until the absorption voltage was reached.


Firmware versions:

SmartSolar MPPT 100/50: v1.53 (latest) at the time (Oct 31 2020)
BMV: v3.10 - also latest at the time

I have included screen images to verify my testing and configuration.


There appears to be a bug in the software, if someone can have a look at this, please?


IMG_1572.PNGIMG_1574.PNGIMG_1578.PNGIMG_1581.PNGIMG_1582.PNGIMG_1583.PNGIMG_1584.PNG

trip-tracks asked
canalsman answered ·

2 Answers

Do I need an Anti-Islanding box for my ESS? (Sweden)

Greetings all, I'm in the process of getting my solar installation fully operational but after reading a bunch about Anti-Islanding I am still not sure if I need to have that. I'm planning to have a setup where I use all of my energy production locally with no feeding back to the grid. I do want the Quattro device to be able to leverage the grid when solar output is low. Diagram attached shows my setup. Anyone able to shed light on how to proceed?


[image]

mwerme asked
Matthias Lange - DE answered ·

2 Answers

Are there any repair centres in Australia?

I have a bluesolar 150/70 that needs the firmware flashing. There is nothing wrong with the hardware, it failed after a firmware update. It uses ve.can only and has no other method of communication. If powered up it flashes "boot" on it's screen. It doesn't communicate with my venus gx. The update was done through the victron website app thing.

john-lange asked
Alexandra edited ·

1 Answer

Correct Settings with SmartSolar MPPT for Ective AGM DC170S Batteries

Hi :)

Today I installed my first SmartSolar MPPT (100 / 30) and connected it to my AGM batteries (2x Ective DC 170S). Then I opened the mobile app and started with the configuration of the controller. Now I'd like to ask you whether I did well or if I'm just a stupid newb ;-)

First here you can see the battery specification:

[image]


In the app I customized the battery settings as follows (simple mode, not expert mode):

- Absorption voltage: 14.90V

- Floating voltage: 13.80V

- Compensation voltage: 16.20V (default value)

The other settings at the battery settings tab are still the default values.


Is this cone well so far? Shall I change something?

What about the setting for the load output? Shall I stay with the mode "BatteryLife"? I use the batteries inside a camper van and got also a alternative power suppliers that are loading the batteries, but I want to maximize the usage of solar power.

Thanks so far! Looking forward to your expert knowledge :-)

Julian

julsky asked
Paul B edited ·

1 Answer

MPPT sizing - over or under?

Using the online tool and specifying my panel params, it suggests the 150/70 mppt. However, when I use the excel calculator, the 150/100 seems to be "green" for all items. My question is: is it better to over or under size the controller? I would assume oversize allows for maximum power output in all conditions.


[image]


[image]

mjrobichaud asked
rainer answered ·

1 Answer

MPPT power drops when battery voltage drops due to high load

My cabin is equipped with 2x 100Ah LiFePo4 batteries, a SmartSolar 100/50 MPPT, and a Phoenix Inverter 12/1200. The system performs very well, but recently I noticed that the MPPT appears to get confused during high loads where the battery voltage sags a bit.

The below screenshot shows the effects of a induction cooktop cycling on and off in order to keep a certain temperature while boiling potatoes. The MPPT output is steady at maximum output until the cooktop turns on, at which point the output collapsed to 0 watts. At the same time the battery voltage drops due to the 1000w load of the cooktop. The MPPT output does not recover until the cooktop turn off again.

[image]

Once the potatoes were cooked and the cooktop turned off, the MPPT output returned to its maximum output level and the output remained stable.

[image]

Is this expected behavior? It would be ideal if the MPPT actually delivered maximum power when it is needed the most i.e. during high load.


mboye asked
mboye edited ·

2 Answers

MPPT 30/100 and 50/100 forces Cyrix Li Charge to go into overvoltage error

I have 2 MPPT Smart Solar charger (30/100 and 50/100) together with 3 Orion TR connected on a VE.Bus controlled LiFePo battery in van.

My idea was not to load up to 100% SOC all the time (goal is to charge up to 80%). Therefore I planned to interrupt charging based on SOC measured by a BMV700 and using the built in relais to interrupt the VE-Bus signal to the cyrix Li charge relais.

So far so good, stopping the charging process works fine, BUT ....

the MPPT charger has an ideling voltage on battery out terminals of about 16.2 V when battery is disconnected. Cyrix Li Charge recognize this an overvoltage (more than 16V) and prevent to reconnect chargers to the battery.


Any ideas, how to overcome this situation?

richi1230 asked
richi1230 commented ·

2 Answers

SmartSolar 100/20-48 disappears from VRM Portal

Hi, I am new to the forum and I need some advice on a problem that keeps popping up with my SmartSolar 100/20-48 charge controller connected to a Raspberry Pi.

Let me start off by saying that I am running the latest stable firmware on the Raspberry Pi (v2.66). I have also connected my Victron 500A smart shunt and SmartSolar 100/20-48 controller (both are running latest firmware) to the raspberry pi thru a USB adapter on each. The smart shunt works perfectly, and is always connected and transmitting data.

My problem is occurring with the solar charge controller. It will stop sending data to the VRM portal randomly throughout the day and consistently over night. The only way to get data flowing again is to restart the raspberry pi. Then the cycle starts over again.

Could there be some setting I missed in the solar controller that is causing it to stop transmitting data?

Thanks for the help!


simon-eric asked
herb commented ·

1 Answer

Help with MPPT and Shunt setup

I have watched the video’s and read trough the online manuals for setting up the Victron Smart 150/60 MPPT, and the Smart Shunt 500A. I am not sure I have the settings correct yet, as I seems as though some of the information is conflicting, or maybe it’s just me. I have 400AH of LifePo4 batteries and this is what I have for settings currently. Thank you!!

[image]

[image]


R Robinson asked
R Robinson commented ·

1 Answer

12 Volt Pump not working when connected to Victron SmartSolar Mppt Solar Charge Controller


I have a 12 Volt Pump

https://23bsolutions.com/product/everflo-ef5500-12v-diaphragm-pump-4-1-bar-20-8-lpm/

Connected to a Victron SmartSolar Mppt Solar Charge Controller 75/15

https://cosycampers.ie/victron-smartsolar-mppt-75-15-scc075015060r.html

My set up is 175 watt Solar Panel > MPPT > 12 VOLT Leisure Battery > MPPT > PUMP

When the pump is connected directly to the battery is works perfectly. But when it is connected like Battery > MPPT > Pump it doesn't work or is very week

BTW Connections are good and tight and I'm using 6mm cable

Do I just connect the pump straight to the battery?

nivek-nijinsky asked
nivek-nijinsky commented ·

1 Answer

Anyone having a Bluetooth pairing issue with new iPhone 12 Max Pro with Apple iOS 14-14.3 for Smart devices?

New iPhone 12 Max Pro not paring with my Victron Smart devices. Latest VictronConnect 5.35 app being used. Getting weird screen never seen before. It’s not the default PIN code. All devices are showing this type of screen.

[image]

buzz654t asked
rkuch4133 answered ·

6 Answers

MPPT 75/15 low input voltage

Hello to everyone,

I'm writing because recently I encountered an issue with my solar system (correctly working untill some months ago) and I hope that someone here can solve it.

My setup is as follow:

- Semi flexible MONOCRYSTALLINE solar panel 105W with this characteristics

V Pmax (V) 20,16
I Pmax (A) 5,26
Pmax (Watt) 105,99
Vca (V) 23.04
Icc (I) 5,63
Eff. cell % 15,42

- Victron energy MPPT 75/15

- Green Power AGM Battery 12V 100Ah

I live in north Italy and the results of a test made today at 2PM are these:

Mutimeter voltage directly out of the panel 19.6V

Current directly out of the panel 2.6A

Multimeter voltage at the end of the cables 19.5V

Current directly at the end of the cables circa 2.6A

The I connected the cables to the MPPT 75/15 (with battery not fully charged 12.8V connected and no loads) solar voltage displayed by MPPT is circa 14.6V, the same result with multimeter directly on the MPPT terminals. Current showed is 0.3A.

So the MPPT doesn't charge the battery..

After that I disconnected the battery from the MPPT and the voltage displayed is 19.2V and 0A.

Fuse is ok.


What could be the problem? Damaged solar panel or MPPT??

Thank you for your answer.


[image]



Emanuele D asked
Emanuele D answered ·

2 Answers

Battery Monitor

On day one after a night of sailing and depleting the 420Ah of batteries the MPPT chargers generated 980Wh, 61% bulk, 8% absorb and 30% float. The max V was 14.15V, min 11.99V. At the end of a sunny day the Mastervolt monitor said the batteries were at 100%.

By day 4 the MPPT chargers generated 450Wh, 38% bulk, 8%, absorb and 54% float. Max V 14.15V, min 12.35V. Same sort of sunny day. But the Mastervolt monitor said the batteries were only at 85%.

Are the batteries being fully charged and is the Mastervolt monitor losing its reference?


Andy Todd asked
Andy Todd answered ·

2 Answers

Wiring MPPT 100/20 and Orion 12/12 30 non-isolated

Hi everyone,

I installing the electricity in my van conversion and I'm looking for a little help on the wiring set up for my dc-dc charger and MPPT. I can't find a clear explanation of how these should actually be wired in practical terms. It's my first time and I'm just nervous about making a mistake.

Should they both be wired directly to the positive terminal on my battery bank (2x 180Ah AGM in parallel)? If so, how will they interact with one another so as not to over charge the battery? they are both smart units, so perhaps this all depends on the Victron connect app?

Any help would be much appreciated (including wire and fuse sizing!)

Thank you!

asinnobooks asked
asinnobooks edited ·

0 Answers

Simultaneous Charging, Orion and SmartSolar MPPT
After hours of searching, I cannot seem to find a clear answer surrounding simultaneous charging using the following two devices in parallel:
- SmartSolar MPPT Controller - 75|15
- Orion-Tr Smart DC-DC Charger Isolated - 12/12 |18


My questions are as follows:

  1. How can I configure both chargers to simultaneously OR individually charge a 100ah Lifepo4 battery?
  2. Would a great SmartShunt or 'Smart Battery Sense' be necessary to make this work effectively? Would it help? (even though I believe the SmartShunt/Smart Battery Sense will only communicate with the SmartSolar MPPT Controller.)


From my own research, it seems like the Orion and SmartSolar will not be able to charge simultaneously due to the lack of VE.Smart support for the Orion. https://www.victronenergy.com/media/pg/VE.Smart_Networking/en/ve-smart-product-compatibility.html
They cannot communicate with each other, nor can the Orion receive battery voltage data from a Victron SmartShunt/Smart Battery Sense.


repadventures asked
Bob K edited ·

3 Answers

Is there any Victron device that allows me to mix LiFeP04 battery sizes?

Hello,


I am dealing with a van upgrade that has a single existing 110 Ah LiFeP04 battery. The system will be upgraded with multiplus, smartsolar mppt, orion, cerbo

The target is to have a 200 Ah battery system and we are currently considering several options.

- Adding one 110 Ah battery. (The state of the current battery os unknown)

- Replacing the system with 2 x 100 Ah batteries (Space is limited and we would like to avoid this solution)

- Replacing the system with 1 x 200 Ah. (Preferred solution so far)


If we go we option 2 or 3, I was wondering if there is any way to re-use the old battery even if amp and size are not the same? Could it somehow be hooked up to the system without reducing the performance of the new battery(ies)?

Thanks

amidships asked
cpt-pat answered ·

2 Answers

Limit SOC for longer LiFePO lifetime

Is it possible in some way to limit the maximum SOC of my Pylontech US2000 Batteries wit the Cerbo GX?
The reason for my idea is to longer the lifetime and healt of my batteries by not charging them to 100% in the summer, because I have a very large battery storage, more than 20kWh, and thatswhy it would be enough to charge them to 80% at least.


robtor asked
pmikep answered ·

3 Answers

2522 Posts
1967 Users
61 Followers

Topic Experts

JohnC
3952 Points
Mark
1304 Points