bug report Image

bug report

Quattro-II measured AC output power drops 150w while charging from grid with constant AC load

I have Quattro-II 48/5000/70-2x50 + BMV-702 + SmarSolar MPPT 450/200 + LiFePO4 48V.

The 220V grid is connected to Quattro's AC In-1 and all load is connected to AC-Out-1 for now. There is no AC load bypassing the Quattro's AC Out.

I noticed that whenever I charge my battery from grid (both scheduled & unscheduled charge), I see that measured AC output power in VRM drops about 150w.

Which means that:

  • If I have AC output power about 150w and start charging the battery from grid, the measured AC output current & power fluctuates below & above zero.
  • If have output power about 1000w it will drop to about 850w. Which means that the inverter is capable of measuring output AC power while charging, but it is 150w off.

And the actual load does not change. This is measurement or calculation error.

Is this expected behavior? I can reproduce this consistently during day & night.

Also on the screenshot below you can see that input power is 3232w battery power measured by BMV-702 is 2781w. 3232-2781=451w. Output power is shown 14w but I know that it is fluctuates at about 150w.

If we do the math 2781/(3232-150)=0.90233614536 charger efficiency.

I have AC in limit set to 16A and grid charge power is about 3kW.

I did not limit inverter's output power via configuration. If I enable heavy load like 2kW and start charging, it charges at about 1kW not exceeding 16A which looks correct to me.

High resolution: https://community.victronenergy.com/storage/attachments/46894-1674030416850.png

[image]

High resolution: https://community.victronenergy.com/storage/attachments/46895-1674030427023.png

[image]



Alexander Bartash asked
Alexander Bartash edited ·

3 Answers

75/15 MPPT and insufficient PV error with Firmware 1.59 issue

Hi folks,


I have a victron 75/15 MPPT hooked up to a 160w panel and 200ah AGM leisure battery, the system has been working flawlessly for years, battery replaced when needed but no issues at all, however, suddenly after upgrading to firmware version 1.59 I constantly get the insufficient PV error.


I have tried using a different panel, and different battery to no difference, having discussed this on Reddit in the victron community there,‘I’ve come across two others who also seen the same issue after upgrading to 1.59


Is there anything I can do about this, have victron issued any statements about faulty firmware, or is there a way for me to roll back to previous version which worked without any issue at all?

David Kennedy asked
stuart-browning answered ·

29 Answers

Bug report: Victron EV charger unreachable at times

Hello,

I have been using the Victron EV Charging station for two months now and it is installed close to an Wifi Access point. My problem is, that the unit becomes unresponsive over the network at times and the solution is to reboot it. Now for example, the dashboard looks like this in my browser. It never finishes loading the page. When the problem occurs it is sometimes possible to ping the unit.

Installed fw is 1.23.

[image]

On my Gx device screen the following is shown, where it says that the EV charger is not currently connected:

[image]

I hope that this is resolved in the coming firmware, something is making the unit really sluggish!


//Sven F

s-forsberg asked
s-forsberg edited ·

14 Answers

Wrong kWh value in "From Grid"

Hello. Today I noticed a discrepancy in statistics. Right after midnight "From Grid" jumped from 0 to about 8 or 9kWh. It looks like a bug. Below you can find today's consumption report and endpoint's response JSON attached.

I am 100% sure I did not consume 10kWh from grid today.

It happened for the first time for me. It might be related to the fact that yesterday I've also tried to power the system from a generator.

I have Quattro-II 48/5000/70-2x50 + SmartSolar 450/200 and two custom-build LiFePo4 batteries 90Ah each with jikong bms.

Yesterday I was testing how system works from a generator, I've charged the battery from the generator from 0 to about 70%. Then after the midnight this happened.

I am not sure where else to send this so reporting here.

[image]


[image]

Report_20230110-0000_to_20230110-1516_kwh.zip

// https://vrmapi.victronenergy.com/v2/installations/xxx/stats?end=1673357399&interval=hours&start=1673301600&type=live_feed
{
  "success": true,
  "records": {
    "Pdc": [
      [
        1673301600000,
        0
      ],
      [
        1673305200000,
        0
      ],
      [
        1673308800000,
        0
      ],
      [
        1673312400000,
        0
      ],
      [
        1673316000000,
        0
      ],
      [
        1673319600000,
        0
      ],
      [
        1673323200000,
        0
      ],
      [
        1673326800000,
        -2.4204516620556675
      ],
      [
        1673330400000,
        136.43811444598487
      ],
      [
        1673334000000,
        328.8347167001883
      ],
      [
        1673337600000,
        466.5458233122296
      ],
      [
        1673341200000,
        428.15764941177486
      ],
      [
        1673344800000,
        397.91705975859963
      ],
      [
        1673348400000,
        413.07494108443257
      ],
      [
        1673352000000,
        477.42204866635007
      ],
      [
        1673355600000,
        241.39685359142445
      ]
    ],
    "bs": [
      [
        1673301600000,
        49.88833333333333,
        47.4,
        52.1
      ],
      [
        1673305200000,
        55.33809523809524,
        46.4,
        66.7
      ],
      [
        1673308800000,
        93.21044776119403,
        67.1,
        100
      ],
      [
        1673312400000,
        100,
        100,
        100
      ],
      [
        1673316000000,
        99.94918032786885,
        99.8,
        100
      ],
      [
        1673319600000,
        99.92166666666667,
        99.9,
        100
      ],
      [
        1673323200000,
        100,
        100,
        100
      ],
      [
        1673326800000,
        99.96290322580643,
        99.9,
        100
      ],
      [
        1673330400000,
        100,
        100,
        100
      ],
      [
        1673334000000,
        100,
        100,
        100
      ],
      [
        1673337600000,
        100,
        100,
        100
      ],
      [
        1673341200000,
        99.94603174603164,
        99.9,
        100
      ],
      [
        1673344800000,
        99.89999999999992,
        99.9,
        99.9
      ],
      [
        1673348400000,
        99.89999999999992,
        99.9,
        99.9
      ],
      [
        1673352000000,
        99.6766666666667,
        99.2,
        99.9
      ],
      [
        1673355600000,
        99.47407407407407,
        99,
        99.8
      ]
    ],
    "bv": [
      [
        1673301600000,
        52.28483333333334,
        51.59,
        52.36
      ],
      [
        1673305200000,
        53.853015873015856,
        51.49,
        54.44
      ],
      [
        1673308800000,
        53.99656716417911,
        53.23,
        54.62
      ],
      [
        1673312400000,
        54.77163934426228,
        53.99,
        55.56
      ],
      [
        1673316000000,
        54.690491803278704,
        53.54,
        55.44
      ],
      [
        1673319600000,
        53.60599999999999,
        53.56,
        53.65
      ],
      [
        1673323200000,
        53.60249999999998,
        53.56,
        53.66
      ],
      [
        1673326800000,
        53.63000000000001,
        53.55,
        54.09
      ],
      [
        1673330400000,
        53.608,
        53.54,
        53.69
      ],
      [
        1673334000000,
        53.96149999999999,
        53.6,
        54.01
      ],
      [
        1673337600000,
        54.00126984126984,
        53.93,
        54.02
      ],
      [
        1673341200000,
        53.77873015873016,
        53.49,
        54.02
      ],
      [
        1673344800000,
        53.59199999999999,
        53.54,
        53.61
      ],
      [
        1673348400000,
        53.60033333333332,
        53.58,
        53.62
      ],
      [
        1673352000000,
        53.384,
        52.91,
        53.61
      ],
      [
        1673355600000,
        53.274074074074086,
        52.86,
        53.64
      ]
    ],
    "total_solar_yield": [
      [
        1673330400000,
        0.1299896240234375
      ],
      [
        1673334000000,
        0.3400115966796875
      ],
      [
        1673337600000,
        0.4971742630004883
      ],
      [
        1673341200000,
        0.4471864700317383
      ],
      [
        1673344800000,
        0.410003662109375
      ],
      [
        1673348400000,
        0.42999267578125
      ],
      [
        1673352000000,
        0.525388240814209
      ],
      [
        1673355600000,
        0.100006103515625
      ]
    ],
    "total_consumption": [
      [
        1673301600000,
        0.4733154773712158
      ],
      [
        1673305200000,
        0.6735644340515137
      ],
      [
        1673308800000,
        0.6189512014389038
      ],
      [
        1673312400000,
        0.7645865678787231
      ],
      [
        1673316000000,
        0.4187021255493164
      ],
      [
        1673319600000,
        0.27306675910949707
      ],
      [
        1673323200000,
        0.364088773727417
      ],
      [
        1673326800000,
        0.473315954208374
      ],
      [
        1673330400000,
        0.3386850357055664
      ],
      [
        1673334000000,
        0.2794766426086426
      ],
      [
        1673337600000,
        0.4187021255493164
      ],
      [
        1673341200000,
        0.44255781173706055
      ],
      [
        1673344800000,
        0.37973451614379883
      ],
      [
        1673348400000,
        0.43357419967651367
      ],
      [
        1673352000000,
        0.5361380577087402
      ],
      [
        1673355600000,
        0.14563608169555664
      ]
    ],
    "total_genset": [],
    "grid_history_to": [
      [
        1673337600000,
        0.018204445019364357
      ]
    ],
    "grid_history_from": [
      [
        1673301600000,
        0.054613351821899414
      ],
      [
        1673305200000,
        2.9855289459228516
      ],
      [
        1673308800000,
        2.0388976335525513
      ],
      [
        1673312400000,
        2.730666756629944
      ],
      [
        1673316000000,
        0.5279288291931152
      ],
      [
        1673319600000,
        0.3094756603240967
      ],
      [
        1673323200000,
        0.4004976749420166
      ],
      [
        1673326800000,
        0.5279290676116943
      ],
      [
        1673330400000,
        0.25486183166503906
      ],
      [
        1673334000000,
        0.018204689025878906
      ],
      [
        1673337600000,
        0.018204212188720703
      ],
      [
        1673341200000,
        0.054613590240478516
      ],
      [
        1673344800000,
        0.036408424377441406
      ],
      [
        1673348400000,
        0.054613590240478516
      ],
      [
        1673352000000,
        0.05461311340332031
      ],
      [
        1673355600000,
        0.018204689025878906
      ]
    ],
    "iOI1": false
  },
  "totals": {
    "Pdc": 2887.366755308929,
    "bs": 1497.1673990397367,
    "bv": 859.6349549254766,
    "total_solar_yield": 2.8797526359558105,
    "total_consumption": 7.034095764160156,
    "total_genset": 0,
    "grid_history_to": 0.018204445019364357,
    "grid_history_from": 10.085262060165405,
    "iOI1": false
  }
}

Alexander Bartash asked
Alexander Bartash edited ·

0 Answers

pheonix inverter smart 12/3000 manual

The manual for the 12/3000 specifies 2*95mm2 cable for the battery side. 185mm2 seems an awful lot of copper for 250A. Fuse is 400A, so less than rating of 1*95mm2. Good support from dealer who suggests it is a typo. So - just checking and feeding back. Any views please. Thanks.

davedurkin asked
kevgermany commented ·

2 Answers

Android widget scaling problem.

Hello, on my Galaxy Tab S8 Ultra the widget does not scale properly. The fonts are almost not readable. If you need more info let me know.

[image]

mryoshii asked
jperez (Victron Energy Staff) commented ·

2 Answers

Smart Solar 75/15 charging issues


[image]

Hi there...can anybody explain this repetitive charging wobble I noticed today that occured exactly every 9 minutes. I include 2 screenshots. The first an overview and the second zooming in on the wobble. Needless to say there was nothing obstructing the panel, full sunshine with no cloud, no aircraft and load disconnected etc. The large singular momentary dip on the overview shot was the one legged seagull arriving for breakfast!

Any thoughts?

[image]

Image Caption


nods asked
klim8skeptic answered ·

1 Answer

VRM: alarm config in Celcius only

My Cerbo is running v2.92 and when creating a temperature alarm for my Ruuvi, the temperature is in celsius. Being from the US, my foundation is fahrenheit. Is there a way to change it for the alarm config? I changed my displays to F, it's just alarm creation that is still C.

[image]

jakes7196 asked
mvader (Victron Energy) answered ·

1 Answer

BUG: Modbus PVinverter device reports incorrect values for register 1052

Hello,


I'm the maintainer of the victron modbus integration for home assistant:

https://github.com/sfstar/hass-victron

This integration uses the spec of the Modbus-TCP register list to decode the values returned by the GX modbus server.

One of the registers (1052 for the pvinverter type) seems to report incorrect values.

According to the spec the register should return a value of type Kw with a scalefactor of 1.

However, if say for example the value was -7 watts, the register will return -7 instead of -0.007

Currently it is unclear as to whether the register is buggy or the modbus spec definition has a mistake in it.

Relevant issue link in the hass-victron github (with more information/screenshots): https://github.com/sfstar/hass-victron/issues/13

Could a dev at victron share a light as to how this value should be treated and/or whether this is a bug that requires a GX device patch?


Thanks in advance

sfstar asked

0 Answers

Zerogrid System massive feeding back to grid from battery since Firmware 500

Hi,

Since upgrade to version ...500 i have a massive problem with one of the phases feeding back to grid from the battery. Also the AC Critical Load in the screen of the cerbo is not actualized as it was before (now up to 3/4 Second instead of 0,5 seconds before). One day i had feeding back 5kwh to the grid from battery. Grid Point is set to 50 Watts.

It is also acting in that way when the battery is in Battery Life at Idle. Then it is playing around with getting power from grid and half a second later feeding the same amount back into the grid. Load is stable with about 500-700 Watts over all phases so no big switching loads like washing machines etc..

I flashed my devices twice with the new version but the issue persists. Maybe it's a firmware bug in the Version 500?


Regards Thomas


System Details:

3x Multiplus 230V 5000KVA 70A

4x MPPT 250/100

6x Pylontec US2000

1x Lynx Shunt

2x Lynx distribution

1x EM24

00schweizi asked
00schweizi commented ·

1 Answer

VRM Shows wrong energy flow direction
  • vrm shows a wrong energy flow into the invertor direction. But, technically there is no invertor connected in the system. Instead, I was expecting the energy flow into the DC Power direction (system is in bulk charge mode with DC load connected through smartshunt 500v).


  • Also, i can hear a buzzing high pitch noise from smartShunt 500 which is clearly audible in a noise free environment. is this an issue with my piece?. i can see some of the users reported the same with smartShunt 500 model.


** all negative connections (PV Charger & DC Load) go from smartShunt terminal

Can anyone please shed some light on what is going on here


[image]

jimz asked
jimz answered ·

2 Answers

bug vrm portal trends from fronius in custom widget

I wanted to signal a bug found in the custom widget creation in VRM portal advanced view.

If I select any values from victron environment : no issue

If I select values from my fronius inverter, then with the 1st selected value : ok

but then when I reopen this widget for editing, I find my selected fronius value twice and from that point the widget cannot be saved anymore unless I have deleted all values from fronius

If I add a value, then colors are messed up and cannot be changed either.

jeanmarie asked

0 Answers

VRM Dashboard scrolls back to the top by itself preventing access to history

Hi if i scroll down and select Consumption/Solar then the page will randomly snap back to the top?

So basically i can not watch the historical data because of that. Has anyone encountered this as well?


mryoshii asked
sharpener answered ·

6 Answers

VRM temperature display bug

VRM webpage and VRM app on Android do not refresh temperature.

I keep the website open, i come back after a few hours to check things, temp is the same, only when i reload page the temp gets updated.

[image]



jj-o-jj asked
jj-o-jj answered ·

5 Answers

Schematic visualization in VRM dasboard missing

Today I took a look into my VRM dashboard and I noticed, that the schematic visualization of my system is missing.

Do you know something about this?

re18 asked
Alexandra commented ·

0 Answers

Followers

117 Posts
102 Users
2 Followers

Topic Experts

s-forsberg
67 Points