mppt state Image

mppt state

MPPT smart solar not going into absorption

Hi, I have on off-grid system with 3x Pylontech US2000C batteries, Multiplus II GX 48/5000/70 and MPPT smart solar 250/100.

When I initially set up the system I hadn't changed the charging limits advised by Victron ie absorption 52V, float 51V through the VictronConnect App but had set the limits via the VE configure software Charger Settings tab.

I was getting high voltage alarms but the MPPT was going into absorption and float, and recording as such on the VictronConnect App.

I have since updated the settings in the VictronConnect app which has stopped the high voltage alarms but the MPPT now never goes into absorption or float.

Is this a problem and if so, how do I fix it?

kirs-ten-henson asked
Willem answered ·

1 Answer

MPPT show State OFF Virtual ON

Just got new TT and MPPT 100/30 show state off virtual on. Attached configuration file

sudduthfamily95 asked

0 Answers

MPPT state Bulk Protection?

Hi can someone tell me what the bulk protection mode does on the MPPT and why it is active?
Over VRM or the console is nothing apparent but via grafana is the solarcharger/State = Bulk Protection. Now I wonder if something is wrong with the system or if I reach a limit somewhere and therefore lose solar energy.

mryoshii asked
mryoshii commented ·

1 Answer

after two years of use, MPPT 75/15 switches to OFF-mode even in bright suns shine and does not start loading again

I am using a MPPT75/15 and a solar panel Wattstunde 120SPS (Voc 21,8V ISC 6,8A) to load the LiFePo battery of my camper. For the last two years everything worked well.

During the last trip the system stopped working in bright sunshine. The MPPT was switched off without any known reason and did not resume working. Sometimes this lasts one day, or even several days.

Firmware reset and disconnecting / reconnect both battery and solar panel did not solve the problem.

I checked all connections as well as the panel which delivers around 22V (open circuit) and 2 to 3A short current.

Yesterday I could record the strange behaviour (see attached screenshot). The MPPT starts to load the battery in the morning. During the day it reaches float voltage. In this state the loading current was reduced to nearly zero. But after some time the MPPT swithes off and shows a solar voltage equivalent to the battery voltage. Because I need some light to work in the car the battery was discharged. The voltage drops below bulk voltage (13,5V) minus bulk offset (0,1V) but the system does not start loading again. I disconnected the solar panel to measure the electrical values which have been ok. This time the MPPT starts working again after reconnecting. As described above the MPPT stays in Off-mode after reconnect.


May be this is a software problem?

Are there any suggestions how to sort out the problem?

xaver60 asked
klim8skeptic commented ·

0 Answers

DVCC Charge Mode


Hi there. I have 3 x MPPTs connected to VenusOS on a Pi. DVCC is enabled.

Not a massive issue but today, I had an issue where my smallest panel (Portable Array, 100W) was on Float but my other 2 sets were on Absorption (Aft and Coachroof 275W total). All were unshaded. This meant that the portable wasn’t providing any power output to help Absorption phase. Any idea what’s going on?


lawrence-craig asked
lawrence-craig commented ·

4 Answers

Invalid Solar Controller State in VRM

The lollypop on the VRM page shows the PV Charger state as "Off". However, the state of the solar charger is "Bulk". See attached photos. These pics were taken at basically the same time (within a few seconds). This behavior is easily reproduced on my system. IMHO, the VRM page is in error. An interesting side note that may help to track this down is that when I also energize the second solar controller, the VRM state changes to "Bulk".

@mvader do you guys have any insight on this behavior?



jonmarinello asked
jonmarinello commented ·

7 Answers

SmartSolar MPPT 100/20 (48V capable version) 24V or 48V battery system efficiency difference at low solar input?

I have designed a solar system for my RV that is focused to be as efficient as possible at low sun exposure as I live in Scandinavia and most often sun exposure is not great.

Current setup in short (for my particular usecase):

Solar array:
3x enjoysolar® PERC Monocrystalline Solarmodul 110W 12V connected in serial providing a operational voltage at full sun exposure with an ambient temperature of about 20 degrees centigrade just short of of 70-ish volts. Max voltage I seen is 75-ish volts.

Solar charge controller:
SmartSolar MPPT 100/20 (48V capable version).

Battery system:
95Ah AGM 12V Battery.

This system generates energy even at very low sun exposure and that I'm very pleased with. BUT as I designed the solar system I have done so with the plan to replace the 12V AGM battery, when it have served its purpose which is has at this point, with a either a 24V or a 48V lithium battery system and all the infrastructure around that. Naturally I like to go with a 48V battery for many reason but I believe I have come across a show stopper if l like to have as high efficiency as possible at low sun exposure in the future as well.

Monitoring the solar system today, through the Victorn Connect app, it seems like the solar charger will generate energy down to about 30-ish vols coming from the solar array. The solar array drops to low to no voltage with a quite steep curve when dropping below 30-ish volts. This gives that for a 12V and 24V battery system the solar charger will generate energy until the quick voltage drop below 30-ish volt coming of the solar array. As the solar charger requires a higher voltage coming from the solar array then the battery system it is to charge, a 48V battery system will, as it seems, not be able to gain any energy at low sun exposure and my solar array.

Am my assumption correct that a 48V battery system will not be able to gain any energy from the solar charger as its input voltage from the solar array drops below a 48V battery systems voltage, as it can sit at 58.4V fully charged, quite quick being not fully exposed by the sun? Or will the MPPT algorithm take the battery system voltage into consideration and keep the power point higher in voltage for a longer time before dropping it? I have not been able to test with any other battery system voltages to gain any further understanding on this topic. Hopefully someone here can help me understand this better. :-)

Please note that I do care for this energy generated at low sun exposure with my current system and as I see that a 24V battery system also would be gaining from my current setup. I know that for larger systems this is a no issue but for this small RV system it makes a difference. Another note is that it would be very hard to fit one more solar panel to up the array output voltage close to the solar chargers maximum voltage due to lack of roof space on my RV.

With kind regards


mr2web asked
JohnC answered ·

1 Answer

Is IP65 and MPPT 100/50 supposed to show different battery state when connected at the same time?

Since an update two months ago, from an MPPT 75/15 to 100/50, the IP65 and MPPT started to show different states for the battery while connected at the same time. Before that, it always showed the same state.

Can someone explain if this is correct, or if there is something faulty with the setup? (I haven't done the setup).

Sami Sin asked
Sami Sin commented ·

1 Answer

IP65 won't charge battery but MPPT 50/100 does

I would like to start with just giving some background on my situation (and that I have checked the other posts on why the BSC IP65 won't charge), and if my situation is the same (bad battery) and what the cause might be.

TLDR; I'm a novice and have not made this setup myself. IP65 stopped charging battery last week but my MPPT 100/50 does. I'm wondering if the company that made the installation has done something wrong which has caused damage to my battery and I now need a new one.

The full story (and sorry that it is long, but I really need help and doing my best to explain what's happened):

I bought a wagon home last year, and with it came one solar panel at 200W, connected to a Sunwind AGM 260Ah battery through a MPPT 75/15, plus an IP65 12V/25A charger, connected at the same time. Never had any issues, both displayed the same battery state, etc. When there was plenty of sun, the MPPT would charge the battery even though the IP65 was connected at the same, and so on. No complaints or issues.

Then during spring, as compensation for delays, and a lot of other issues with my new home, plus that the MPPT didn't provide enough amp to start an electrical devices they had connected to it, I got it upgraded to three 200W solar panels, same battery (AGM 260Ah), new MPPT 100/50, plus the same IP65 12V/25A charger and a SmartBMV 712. They also installed an 3000W inverter, so that I could use the solar power for my TV and some other 220V appliances.

First thing I noticed after the company had made the installation was that when both the MPPT and IP65 was connected was that it would show different status for the battery while charging. The MPPT would display FLOAT, while the IP65 would display ABSORPTION, and charge the battery, while almost no charge came from the MPPT, even though it was sunny outside.

I thought this is weird, but since I don't know much of this, and the company that made the installation said that's normal, I thought okay, I guess I have to trust them it's supposed to be that way. I even spoke to some representative at Victron in Finland who said that nothing can be done about that. Here are two screenshots I took from back then, after the update, during a sunny day:



I just thought it was weird that it had worked fine before, no issues getting a charge from the MPPT even though the IP65 was connected (plus both showed the same state), and now with the new MPPT and extra panels, I get almost no charge from the solar panels.

So I came up with a work-around, which was that I set the IP65 behind a timer, so that it would be turned off during day time, and get turned on for the nights. And I think it has worked really well, though I don't know if that might have caused some of my issues.

Then last week, the power was out one night so the IP65 wouldn't charge the battery, and it went down to around 11.21V during the night. Then next day, the MPPT started charging it again. I checked the IP65 during the afternoon, and now when I started it, it would do the TEST, BULK (for a few seconds) and then go straight to ABS, without charging the battery.

The MPPT though managed to charge the battery to full power next day, and keeps on doing it. On the meter though, the light BULK/ABS/FLOAT (respectively) does blink every 3 seconds, which according to the manual (I think) either in BULK mode means it can't charge (which it does), or in FLOAT mode means "Charger temperature too high" (not sure this is correct though, since it blinks every 3 seconds and the manual doesn't say if it should be constant blinking, or if it's the same as blinking once every 3 seconds).

For the MPPT the max charge current is 50A, which I understand shouldn't be too much for a 260Ah battery, i.e. 260/5=52, but if both the IP65 and MPPT would be connected at the same time, and provide charge, it could go over this value - unless there is some function built-in to prevent this (I saw something about this in one other post regarding combining the IP65 and an MPPT).

So summary: Right now the MPPT charges the battery, but the IP65 seems to indicate with that short BULK phase the battery has reached its end of life.

So what has gone wrong with this? The battery has been in use since about October last year, and for the first 6 months, before the new MPPT and the extra solar panels, it was not in use much, only for some LED lights, water pump, etc.

After the upgrade, with the inverter, it's been in use daily. I did read that the AGM battery I have is not made for constant use, so has all the use in past two months killed the battery? Or is there something else going on here? (I've been thinking of upgrading the battery to a better AGM with more Ah anyway, but I need to know if the company that made installation has done something wrong, so I can get compensation from them, or if this "somehow" is my own fault, because I've been using the battery daily, with the inverter, for my TV, etc. I'd like to add that during this two month period, there was also three weeks I was away traveling so the battery wasn't in use for anything else than my mini fridge, which uses about 150W. I.e. the battery has been in constant use for about 6-7 weeks.)

The company also advised me to set the MPPT Load output Operation mode to "Always on".

Here are some screenshots from the Victron app, how it looks currently:




Any advice is highly appreciated. Thanks.

Sami Sin asked
Sami Sin commented ·

1 Answer

negligble watt output


hi I have :

Problem a 3680 w ( 92v x 40 amp )system is only producing a few hundred watts ( 100- 400 W) output

  1. Victron multiplus ii
    • ,48/5000/70-50,
  2. Victron mppt charge controller
    • 150/70 tr 5 kva /5kw
    • 150 V max 50 Amp
  3. BAAG 200amp GEL/AGM battery, 4 x 12v in series to 48 V
  4. Renessys PV panels x 10 PV Panel fuse 32 A 1000v dc - df pmx
    • 10x wired =series (2) Parallel (5)
    • Each pair is 92 v ( 2x 46v) ,
    • 8 amps x 5 parallel = 40 amps
    • Tested on roof ie before cable down V (open) on every panel range from 41 to 42 v - winter.
  5. PV Panel fuse 32 A 1000v dc - df pmx 10x Each pair is 92 v ( 2x 46v) at 8 amps
  6. Cable down from roof at 10 m outer diameter( ie around insulation) is 5mm - could this be the problem ?
  7. System - Relay 1 state - open
  8. Winter ( OVERCAST) can see any shading problem on roof
    • no errors
    • no trees
    • Clean
    • may be slight blocking of some tips of panels by other panels in afternoon sun
    • but this cannot account for such a unacceptable output ie 10 %
    • see gateway and solar charger in vrm out put
    • solar charge v = 84 v approx
    • pv current 3.5 v ???
    • solar charger battery voltage max 57.5v
    • solar charger battery current max 4 amps
    • System - ESS Battery life state = stuck on restarting ??
    • solar charge summary battery
      • battery watts = 66w
      • charge state = float,
      • voltage = =55.6v ,
      • yield today = .26kwh, ???
      • yesterday .48 watts ??
    • MPPT state ( 258 )
      • off till 7 am
      • then till 10 am = bulk ,
      • after 10 am = float
    • solar charger battery volt battery went from 54 v - 51,6 v THEN DOWN TO 55.2 V
    • System battery power = no data
    • System battery voltage = 54 51 and 57 to 55.5 v
    • PV yield during blackout 8 am to 10 am today (ie grid blackout )
      • before blackout= 0 w
      • 8am - 10am = 200 watts ???
      • amps from .6 amps to 4 amps
      • after 10 am battery quickly went 50.4v - 57.6 v and amps went from 0 amps to 1.2 am
    • why such low watts and amps

georgebester asked
Mike Dorsett commented ·

0 Answers

Two 250/100 MPPT controllers in parallel - One staying dormant....

Hi there,

just installed a 10kWp PV system (6 parallel strings of 4 PV modules in series) feeding into 2 MPPT controllers (250/100), which again feeds a BYD LVL battery bank (2 parallel modules of 15.4 kWh each):


After firing up the system, only one of the 2 MPPT controllers is feeding into the batteries (solid blue BULK light on). The other one remains in an OFF state (blue BULK light blinking slowly), also as shown by the VictronConnect app:



I'm at a loss why this is happening.

The OFF MPPT controller is correctly connected to the battery bank and PV arrays and breakers / isolators are switch ON.

I have also made a "Smart Network" connection between the 2 controllers through the VictronConnect app, hoping this would have the 2 controllers talk to each other, but it didn't make any difference. One of them remains inactive.

I'm wondering whether the BYD BMU has anything to do with this, since that is the unit in overall control of the system.

Hoping anyone of you can shed some light on this. Thanks very much in advance! :-)

kiwisolarfuture asked
seb71 edited ·

2 Answers

Courant et puissance de PV très faible en entrée de MPPT

Bonjour, Je dois intervenir sur l'installation d'un client (faites en janvier 2021, par un constructeur de tiny house qui a fait faillite).

A distance, je lui ai fait vérifier la tension en sortie des string panneaux (2 string de 3 panneaux de 360W), et jusqu'à l'entré du régulateur, et rebooté l'ensemble (qui était en pleine rébellion, ca clignotait et claquait dans tout les sens, la charge fluctuais de manière anarchique au niveau de la batterie ).

la tension était donc largement acceptable et stable a chaque étape, 119V (pour un Voc de 126V et 22A de Isc sur un régul 150-35) et le MPPT a pu se remettre a faire sans boulot sans se plaindre.

le système est bien dimensionné et les différents éléments aussi (220ah de batterie en 48V, et le multiplus adapté)

Néanmoins, le souci étant une puissance de production ultra faible (autour de 150W), même au zenith, et un courant logiquement extrêmement bas (1.3A),

quelqu'un sait d'ou pourrais venir le problème ? panneau défaillants ? (il y a eu un jour apparemment, après un vent fort, une déconnexion sur les panneaux)

Je vais devoir prochainement passer les dépanner, et en profiter pour installer un Cerbo, mais si je pouvais avoir d'autres avis, et idées de procédure pour identifier la panne, ça sera ultra efficace.

Les pauvres vivent sur un site isolé.

par avance merci,



cyp asked
Thierry Cortassa (Victron Energy Staff) answered ·

3 Answers

14 Posts
13 Users

Topic Experts

71 Points
50 Points