24h MPPT data not syncing with VRM - why?

I have a small solar remote off grid setup with a Victron 75/15 MPPT. While sun is limited in winter I have a DC timer hooked up for disabling the load during most of the day. To track battery voltage and solar yield, I have Venus OS on a RPi installed. While the RPi also consumes load, it is not connected permanently (so it is placed after the timer). This is no option. It would drain the battery. Same for 4G router, and some small DC equipement. I noticed that when the setup is ‘on’ I can see stats on VRM but that seems to only show data from within the on-time frame. Via VictronConnect I can also connect to Venus OS and the MPPT and within the MPPT environment I can see all 24h data. Do you know why this is not synchronized with VRM?

Or is there an option to do so? Hope someone can help!

12 volt 20ah Lifepo4 battery - 60w panel - DC timer - VRM - RPi - Venus OS - 4G router

Tim asked
Paul B answered ·

1 Answer

Multiplus C 12/1600/70 (Old Hardware 1806133.VFF) communication with other components

Is this legacy Multiplus able to connect to VenusGX/VenusOS through an MK2 Adapter with the VE9bit RS485 protocol possible?

if not, is there any old legacy adapter available or is there any communication possible at all?

i would need to change the battery configuration for a new LifePo4.

Thanks in advance

ehspill asked
ehspill commented ·

2 Answers

Synchronize VE.Bus SOC with battery? Select on loss of communication source for genset

Synchronize VE.Bus SOC with battery

Has this item been rolled into dvcc? After some digging here it seems its been removed yet its still in the manual. The last mention of it in the changelog is in the v2.02 – 30 January 2017 Venus Os

Are you guys working on an update to the manual to remove redundant settings to avoid confusion?

loss of communication source for genset

I have a few systems I setup and support with auto start gensets, after a couple of weeks of bad weather one went into LVD during a sustained load at a low SOC. Voltage start timing settings were a bit too long to catch the voltage crash. LA batteries.

I had set start on loss of communication as a third fail safe to start the genset, and had the BMV as the source for genset SOC. However the genset didn't start as the BMV was still active yet the multi had shutdown. I had assumed that it would start on loss of comms to anything on the VE.bus. After rereading the manual, it's loss of communication to the SOC source.

Normally I disable the battery monitor in the multi to avoid the user accidentally changing the source.

I have now reenabled the monitor in the multi, which seems to be tracking the BMV and set the genset SOC source to the multi.

However Synchronize VE.Bus SOC with battery is completely missing so the only indication the SOC is being read by the BMV to the system is that its the same as the BMV.

Seems a rather complicated method, could we simply have this changed so we could select the loss of communication source?

This now raised another question, when performing remote configs through the portal the multi/quattro drops communications to the venus device for a moment. Will this cause a genset start?

alan asked
JohnC commented ·

1 Answer

Schedule between "keep batteries charged" and "self-consumption" in the ESS program

Good morning. Can someone please suggest me to schedule the change the state between "keep batteries charged" and "self-consumption" in the ESS program? Let me explain better, living in a country on the equator with 12 hours of sunshine and 12 hours of darkness a day all year round, I would like to use self-consumption during the day but switch to "keep the batteries charged at night.

My installation:

Victron Quattro 10KW 48V

Frunius 8.2

10Kw solar pannel

Small battery bank 200Ah (which will later be increased ).

Currently everything works well in "Keep the battery charge", and I'm happy, but during the day I waste a lot of energy coming from the panels, and at the same time I wish the batteries were 100% charged at night.

Kind regards

aldo asked
nickdb edited ·

3 Answers

Venus GX lose communication with Inverters (repetitive issue on different system for the last 4 months)


This problem has been happening to us relatively often in our sites for the last 3-4 months. At least 5 or 6 times, each time of different systems. Suddenly the Venus GX lose communication with the inverters despite the inverters are running and powering the load, there is no data on the remote console on the inverter side


How to solve the issue is quite simple, we reboot the Venus GX and straight away there is data on the console. So, seems like the problem is on the Venus device and not on the Inverters


Obviously, this is not something we can do manually every time that there is a problem and if there is no signal on site, there is no way we can solve the issue so I hope this issue is addressed on upcoming firmware updates.

All these GX devices are running v2.60 and the inverters on which this have happened were running different firmwares 475 and 430.

Is there any kind of watchdog feature that could reboot the Venus if it is not seeing data from the inverter? if there is not, I think that would be an interesting feature to add on. I am seeing this feature on the GX manual but I dont think this is what I am looking for:


Could this be a hardware issue? If we upgrade to the new Cerbo GX that has a more powerful CPU and more RAM, would it be less likely to get this crash? or might it be a pure software issue?

Jesus Mazo asked
Jesus Mazo edited ·

0 Answers

VE.Bus BMS, SmartSolar MPPT Ve.Can and Can verses VE.Direct connection

I have a 2 x SmartSolar MPPT VE.Can 150/70 rev2, Smart lithium, MultiPlus, BMS, Cervo, etc, all Victron.

I have not found any clear documentation about the functionality one gets when connecting the SmartSolar MPPT via VE.Can or VE.Direct.

I connected them originally via VE.Can and no screens on the VenusOS would show if the MPPT's where working as a single pair, networked and in sync, or would get BMS Charge Disable signals from the Cerbo.

I have them connected via VE.Direct at the moment, and in the Cerbo there is now a "Networked operation" screen, under each charge controller. However BMS control is still No.

Is there any documentation or guidance that exists about the best protocol to use to connect the controllers and the benefits and features of each.

I really want to know if the BMS Charge Disconnect signal is passed through from VE.Direct to the MPPT's, can they work as a synchronised pair, can they get charge current (non ESS setup) from the Cerbo, etc.

Many Thanks

bathnm asked

0 Answers

MPPT 150/60 + multiplus II GX 5000 : not charging suddenly while switching to absorption mode

Good afternoon,

I wish people reading an happy new hear, wishing you all the best, sunny days and success in your projects.

Since 11:52 am my solar installation stopped charging my batteries.

I checked remotly my installation as I wasn't at home and I noticed the PV charger was missing on the VRM online display.

My batteries stopped charging at 11:52 exactly when the installation switched from bulk to absoprtion mode.

before I had this view :


since this morning I have that one : chargeur PV is missing


when I look the graphs : the PV yield stops at 11:51 this morning


It matches with the end of bulk step and begin of absorption step


When I came back home (at night), I noticed the bulk led of the MPPT is blinking in blue on every 4 seconds


I check the PV field fuses, I even removed them all , i tryed to re search the MPPT charge controller via multiplus interface, and restarted the software in the multiplus interface. I also removed and plugged again the ve direct cable from multiplus and from MPPt solar charger... nothing managed to find again the standard display.

Note my intallation is around 7 months old, it works fine until today while I was away from home...

I am very afraid to kill my batteries.

What do you think I can do to solve this issue?

2 months ago, I changed my internet provider box, since then I cannot manage to get Lan connection, I only managed to setup wifi connection between multiplus and internet box. When I plug the cable the IP connection is on and off every seconds (when I do ping muliplus.IP. adress -t, I get 5 times ok, then 10 times tiemout, then 1 time ok, then 5 times out... not sure there is a link but maybe the communication interface has a failure and finished its life at 11:52.

Thank you again for your support : I am looking for a solution even to protect my batteries if I need to buy a need charge controller ( how can I charge them and switch off the installation until I receive the new MPPT charger) or a better solution : manage to recover the MPPT solar charger function.

Thank you for reading,


puech-antoine asked
seb71 commented ·

3 Answers

Connection lost between BM712 and Venus (on Raspberry Pi 3b+)

Hi there,

After a successful installation of Venus OS on a Raspberry Pi 3b+, I managed to configure the Remote Console, link it to VRM, and view the live data streamed. All worked OK...for a while: after more or less a couple of hours, I noticed that I was not getting updated data from the Battery Monitor. It seems that the issue is the connection between the gateway and the BM - see screenshot below:



Rebooting solved the issue...for a while. After another hour I had the same issue again. See below (three reboots):


In my current set-up, I only have a BMV712smart connected to the VRM. The Pi is connected to the router via network wire. The BM is of course plugged in to the Pi via USB.

Below please find more screenshots of the Remote Control.

Thanks for your help and guidance, I did a research but couldn't find any thread on this specific topic.




flavio-dim asked
flavio-dim edited ·

1 Answer

New to Lithium and Cycling to 28.4 every day

Hi All,

I am new to Lithium and the Smart Lithium 12,8 batteries vponfigurtbed 2S2P. My boat is not accessible at the moment due to lock down and I have CANBus connected Smart Solar MPPTs.

When I left the boat, I forgot to adjust the MPPT controllers to charge to 27v, therefore maintaining the batteries at float. As there is very little load it means that my Solar charge controllers are cycling the batteries through absorption, and the Victron set 2hr's each day.

Is there anyway to reconfigure the CANBus MPPTs remotely? Will doing this for what is likely a month going to damage the cells.

Many Thanks


bathnm asked
bathnm commented ·

1 Answer

Pair of VE.Can Enabled and Connected Smart Solar MPPT

I have a Cerbo and 2 x VECan enabled Smart Solar controllers. I expected these two be working a s network pair, but they do not seem to be. They each report their own System Yield and not a combined yield for system, see attached,



Should the system yield actually be the combination of the Total from each unit? How does one tell if they are working as a synchronised network pair. I have been unable to find any detail on the web or gain access to the Cerbo itself to look at the dBus data elements to see how they are interacting with the system.

Any guidance.

Many Thanks

bathnm asked

0 Answers

Looking for input - 4 to 20mA and 0 to 10V senders

Hello Community!

We’re considering to add a USB accessory to our GX product range, to add 0 to 10V, as well 4 to 20mA inputs.

But since all of us have very limited experience with 4 to 20mA tank senders, we're looking for some input:

  1. Is it always 4mA = tank empty, and 20mA is tank is full? Or do the empty and full levels need to be configurable in a software setting on the GX Device?
  2. And how important is it that the transducer can be powered by our device?
  3. Anything else we should keep in mind when designing a 4 to 20mA input? Good features you have seen else where?

Also, if you are using 4 to 20 mA senders, please post a link to a datasheet or specs below. And if you have an opinion on the sender, what you like/don't like, welcome to add that.

Lastly, most questions above are for 4 to 20mA, not for 0 to 10V - but if you have special comments about 0 to 10V, welcome as well - obviously. The product we have in mind will have inputs that can be used for both types.

Note, that this is quite early in the product development, I can’t say anything for now with regards to availability dates.

All the best and thank you! Matthijs

ps. just to prevent any question about this: we'll soon launch a new Venus OS version that can work with irregular tank shapes, as well as naming tanks and some more features: all those features will also available for the 0 to 10V and 4 to 20mA inputs. Details here.

mvader (Victron Energy) asked
modian answered ·

10 Answers

Has DC System - Incorrect Consumption in VRM when Phoenix Inverter is run on DC

Hey everyone,

I am running an off-grid system with a GX Device and an MPPT, BMV and Phoenix Inverter 12/800. I also have DC loads connected to the system. As long as the inverter is not running, the consumption values in VRM are perfectly valid, but as the inverter runs, the values measured are off, as the inverter power is just added ON TOP of the DC Load Power which already includes all the current drawn by the inverter.

Is there a way to configure the GX Device to ignore the AC Power measurements, as they are already included in the DC Load? If not: it'd be great to have an option in the menu that states that the inverter is run on the DC system. Otherwise I am unable to reliably log the system consumption...



steffend asked
Wes Humpage commented ·

2 Answers

Cerbo GX FW 2.60 and GX 4G Connection Issue

Hi All,

I installed a GX LTE 4G today and found that an icon was trying to display on the top right by the clock, and that the system was reporting internet Offline, when the system was clearly online and communicating with VRM. See screen shots

I also logged in via ssh and found that the ppp0 interface had received an IP address and was able to do DNS lookups and ping.

I wasn't able to do any further investigation. Since I have got home what I have noticed is that the location symbol moves one to the right and back again.





bathnm asked
bathnm commented ·

4 Answers

BMS Control Setting under System Settings / System Status

I am remote so cant fully debug or investigate so need to understand if my understanding is correct. I believe that the VenusOS will provide the Solar Controllers charge enable status through VE.Direct or CanBus.

When I look at the settings it shows BMS Control as disabled. See below.


However the VE.Bus BMS is reporting "Allow to charge" and "Allow to discharge". See Below.


I would therefore have expected BMS Control to be Yes. This is driven by the dBus path

"com.victronenergy.system/Control/BmsParameters" within by dbus-systemcalc, but cant track down how it then sets within.

If using the Ve.BUS and having the "Allow to charge" and "Allow to discharge", should the BMS control be yes?

bathnm asked
bathnm commented ·

0 Answers

VE.Bus BMS and Multiplus, remote switch off off Multiplus

Good afternoon,

Is there any configuration or assistant that can be applied that will allow for a remote switch off of the MultiPlus when used with the VE.Bus BMS and Cerbo GX. I know that in this configuration a DMC will allow this to happen, but I really do not want yet another panel to install (cost and space). I had hopped that a switch between the Left and Middle pins of the remote switch on the main board would work, but no luck. I am sure at some stage the ability to turn the inverter on and off through the Cerbo will be available, just as it is when no VE.Bus BMS is used.

My reason for asking is that when I leave the boat the MultiPlus, even with AES applied has been the biggest parasitic load causing a drain of 158Ah in just a week. Having turned the Multiplus off at the switch on the front the parasitic load has dropped to just under 0.2A. With the Multiplus on and in ~AES Search mode the system was drawing between .4A and .8A, occasionally going as high as 1.2A.

OK, I know I can turn the inverter off on the front panel, but that is a pain due to it's location.

bathnm asked
andrea-collecchia commented ·

4 Answers

Future of LoRaWan module

I noticed in the documentation that there was mentioned in the LORAWAN module docs the release of the LTE-M module. Is the long term plan to drop the LORAWAN? I know the TTN network is spotty in places but the technology is sound. The Helium LongFi network uses the same tech and seems to be quickly becoming a dominate player in LORAWAN and I would love to connect my LORAWAN module to that network. Would it be possible for Victron to open source the config to allow for the community to re-program these devices (effectively just a nicely packaged LoPy4) to use whatever network we choose to send data back to your servers?

kclendaniel asked
Lasse answered ·

2 Answers

ESS is not selling excess PV to the grid, while it is charing the battery.


Two Quattros 10K-120V- setup in SplitPhase, ACin1 has a generator, ACin2 has the grid

Four MPPT SmartSolar 150/100 controllers with a total of 14 365W panels per string.

Large 1400Ah Lithium Battery managed by Batterie's internal BMS that communicates with Venus via CAN-BUS. The BMS is a REC-BMS.

Venus is configure:


Mode:Optimized without BatteryLife

Grid metering: Inverter/Charger

Multiphase regulation: Total of all phases

Limit inverter per:OFF

Grid setpoint: 0W

Grid Feed-in:

AC-coupled PV:off

DC-coupled PV : ON

Limit system feed-in : ON

Max feed-in: 15000W

Scheduled charging: Disable



1- System will curtail the PV been generated to match the sum of the AC-load plus the BMS requires to charge the battery. When it should produce as much PV as it can and sell to Grid all that is not needed by the BMS to charge the battery.

2-Once the BMS has reached 100% SOC it sends parameter to Venus to charge at 1A, the system does not pay attention to it and send at least 20 to 50A, but now starts to allow the PV to produce the maximum PV and sells to the grid. Any variations in the AC-load make the battery charging amps to spike to up to 100A, at which point the DC Volt also rise to 65VDC. The batteries BMS send a voltage high ALARM and it it happens several times, the BMS goes into protection mode and disconnects the Battery. this also triggers an alarm38 in the Smart Controllers disabling them, and requiring a full disconnect.

Carlo asked
Carlo commented ·

2 Answers

Can an energy meter ET112 provide similar functionnality to a new CPU Multiplus on Venus OS and VRM ?

I have an older multiplus with a legacy CPU and control board that cannot report cumulated energy from its AC inputs/outputs. Because of that, I cannot see nice graphs in VRM about the energy used from the grid and thd energy obtained from the PV.

I would like to keep my Multiplus because it works well otherwise. I was wondering if I could install an ET112 energy meter at the AC input of the multiplus to get the same functionnality.

I'm not adverse at writing a service to generate proper data stream in Venus OS. My questions are:

- Theorically, if I mkdify VenusOS, can the ET112 provide simikar functionnality?

- Does it work out of the box ?


mildred asked
yuwire answered ·

2 Answers

Victron MPPT Bluesolar 150/35 and Venus GX signal map


I am looking for the signal map, or data model, of these two products: Victron MPPT Bluesolar 150/35 and Venus GX.

I want to check what kind of signal the charge controller is providing (input current, output current, battery state of charge, etc) and the modbus address of each one, its unit, its scale, etc.

Can anyone help me to find this document, please?

paula asked

0 Answers

Victron Remote Console on Head Unit (Cerbo GX and Android Car Audio interface)

Hi guys. Anyone managed to get VRC to work on your car audio interface? I came across this YT video on the Venus GX and was wondering if Cerbo GX interface could be accessed via an Android car audio interface?


Any tips on how to do this would be highly appreciated! Thanks!

mako74 asked

0 Answers

modbus tcp python library?

Hey guys, has anyone built a python library for running modbus tcp commands?

mike-casey asked
farriaza answered ·

2 Answers

Phoenix Smart IP43 Charge, VenusOS and Lithium

I have been searching the internet to understand how the IP43 Smart Charge integrates into a VenusOS and Lithium based system. There seems to be a lack of information, or I'm looking in the wrong place ;)

Does anyone know if the VenusOS will via the VE.Direct port turn the charge on and off based on the BMS state information, as it does for the MPPT Smart Solar?

I don't believe that it is included in part of the DVCC Maximum Charge current yet.

Dose anyone know if the VenusOS can supply voltage sense information, through DVCC.

I don't really want to just buy a unit to test and find these things do not yet work. Anyone have any ideas on how well the VenusOS and Phoenix Smart IP43 Charge work over VE.Direct?

bathnm asked

0 Answers

VE.Bus BMS and MultiPlus / Cerbo combination

I have wanted to be able to control the Multiplus via the Cerbo, but the VE.Bus BMS and VE.Bus BMS Assistant on the Multiplus block the Cerbo from changing the invert state between On / Off / Invert Only / Charge Only.

Having done some testing I have reverted to the 2-Wire BMS assistant on the Multiplus and wired the VE.Bus BMS Charge Disconnect to the Aux 1 port and Pre-Alarm to Aux 2, using an Inverting remote on-off cable. I am now able to change the status of the Multiplus from within the Cerbo Screens. The Cerbo correctly shows the VE.Bus BMS status through the relevant MultiPlus screen. Both disconnected at the moment.


I also had a VE.Bus Smart Dongle and found I could modify the status of the Multiplus via my phone as well. When status changed the Cerbo reflected that changed status. So I have a system working as I would like, but not using any functionality of the VE.Bus. I guess I could have achieved the same thing using the smallBMS with pre-alarm.

What I was wondering is if anyone can advise what functionality I might have lost by disconnecting the VE.Bus BMS from the VE.Bus?

I have noticed during my testing today that there is no Alarm or Error that is logged when the VE.Bus BMS signals load or charge disconnect, simulated by disconnecting the signal. The Cerbo clearly isn't triggering on the change of the Multiplus VE.Bus BMS status. I am not sure if it ever did alarm/alert when the VE.Bus BMS was connected via the VE.Bus port to know if I lost functionality. I do know a few weeks back I had a VE.Bus BMS Charge disconnect event and never saw anything on the Cerbo.

Hope people find this useful and it would be good to understand what functionality has been lost by taking this approach and not have the VE.Bus BMS communicating on the bus.

bathnm asked
bathnm commented ·

0 Answers

Modbus TCP 'Temperature' Register for Freedomwon Battery?

Does anyone know what SlaveID and Register holds the Freedomwon Battery Temperature? I just replaced my lead-acids with a Freedomwon Lite and would like to poll the general battery temperature via Modbus. Oh, it's all via a Venus GX.

Ingo asked
Ingo answered ·

1 Answer

VRM not talking to my Venus, is VRM down?

My Venus install has been working great, today though the usage stopped showing in the portal and I've rebooted my device several times.

The VRM settings show an error:


I am able to SSH into my device and ping https://vrm.victronenergy.com/ successfully.

Is VRM down or what's going on with my device?

madsci1016 asked
madsci1016 answered ·

2 Answers

Blue Sea 7603 Replacement - MultiPlus, Cyrix-ct, SmartShunt & RPi


I’ve currently got a ‘Blue Sea 7603 - 10A BatteryLink Charger’ and an APC UPS. I purchased the Blue Sea because it can use AC shore power to charge two isolated battery banks with a 3 Stage 10A battery charger but also it can use DC power from the alternator to charge both the Start and the Auxiliary battery through an integrated 65A ACR (Automatic Charging Relay - Automatically combines batteries during charging, isolates batteries when discharging and when starting engines).

The problem with it though is that there is no monitoring or visibility of what's going on apart from a panel mount 'display' consisting of a couple of LEDs. I've recently had a problem with my Auxiliary battery not seeming to hold charge and I'm struggling to troubleshoot and having to use a multimeter, etc.

I recently learnt that the MultiPlus 12/500/20-16 has a second output intended for charging a starter battery albeit limited to 1A. Therefore would a MultiPlus and a Cyrix-ct be a suitable replacement for the Blue Sea and an APC UPS?

I've added a SmartShunt, VE.Direct to USB Interface (for the SmartShunt), MK3-USB (for VE.Bus on MultiPlus) and a Raspberry Pi with Venus OS to meet my requirement of greater monitoring and visibility of what's going on. However how will I know the status of the Cyrix-ct?

Is there a panel mount display which can interface to my configuration?

Thanks in advance for your advice.



knotty asked

0 Answers

How to reset SOC to 100%?

There is one past thread about this issue in which I participated, but it seems the recipes mentioned (and that I've been using) for some reason don't work anymore:


For the last weeks I never got my system to show 100% again (or 85% for that matter). I've set MPPTs to have absorve voltage higher than what is set on Multiplus, I also made sure the absorption time was higher, but nothing seems to work. Never get to the 85% or whatever is set on the Multi.

I have run out of ideas...

My system is Venus based, no BMV, but no DC loads or charges.

Current Multi Settings are like this:



MPPT vales are what you wish.. tried even with 28.8V in absorption today.

See graph:


Why can't the SOC be recognized as 90% ?

Venus is running 2.60, not since too long ago. Could be something within Venus OS?

I also tried Multi connecting to GRID -> Goes straight to FLOAT, SOC continues at ~30%

This is an old issue... but for the moment, besides trying to figure out the root cause for the system not resetting every day to 85/90%, what I would like to ask now - as a workaround - is how to manually force the system to reset to 100% ?

I used to do the trick of commanding the Multi to Equalize from Grid and then Interrupt -> go to absorption / Float. It used to reset to 85% (that was at the time set). But now even this is not working.

elimac asked
rubas commented ·

6 Answers

capacitance tank monitor

Been looking forever for a way to monitor my captivate tank sensors with Venus but only thing I have found is restive.

Short of anything thing from Victron when SiMarine adds NMEA2000 to PICO and their tank senders do you think I will be able to interface. NMEA2000 is a standard protocol right?

philcollins asked
charles-riley answered ·

4 Answers

generator for automatic Start and Stop
Has anyone connected a MASE Marine IS 5.0 generator for automatic Start and Stop with Raspberry Pi with Venus OS? Can you tell me connection diagram, thanks


gs1200adv asked
trevor-bird answered ·

2 Answers