Need firmware 1.53 to revert back as 1.54 is giving problems

The system worked fine for 2 months and then started this erratic disconnecting and reconnecting, checked all fuses and crimping. Have 2 other exact systems running and working fine. The only difference between the systems to this one giving problems is that this one is using v1.54 on the controller. I need to put 1.53 back

solarbackup asked
solarbackup commented ·

4 Answers

Multiplus C 12/1600/70 (Old Hardware 1806133.VFF) communication with other components

Is this legacy Multiplus able to connect to VenusGX/VenusOS through an MK2 Adapter with the VE9bit RS485 protocol possible?

if not, is there any old legacy adapter available or is there any communication possible at all?

i would need to change the battery configuration for a new LifePo4.

Thanks in advance

ehspill asked
ehspill commented ·

2 Answers

Does anyone have firmware 1.53 for smartsolar 150/100 vedirect only???

version 1.54 broke my system and no one seems to be able to help

solarbackup asked
seb71 commented ·

2 Answers

Overload with 15kva Quattro 3 phase

I have a number site where we have installed Quattros in three phase set up.

We are having an issue that when the main supply goes down, (fairly often at the moment in South Africa) one of the phases will report an overload alarm and shut down. There is nowhere near enough loads to cause the overload. It has happened on three of our systems and it doesn't always over load the same phase.

What could be causing this issue?



Any idea what could be causing this issue?


adamdovale asked
Guy Stewart (Victron Community Manager) answered ·

5 Answers

Can’t upgrade VE.BUS firmware with BMS connected

I have a Multi 5000/48 with SmartLithium batteries connected with the Victron VE.BUS BMS. AFAIK there’s no information regarding BMS in the VE.BUS FW Upgrade documentation. VictronConnect says I can’t upgrade the FW when there’s a BMS connected, so I wonder what’s the recommended procedure in order to install the FW upgrade?

The reason for the upgrade is that I get “VE.BUS Error 11 reporting requiring minimum VE.BUS firmware version 454.”. I’m running v430.

rallyhagge asked
Daniël Boekel (Victron Energy Staff) answered ·

1 Answer

Can I update SmartSolar firmware with the Mac OSX app, or only mobile?

I see I can upload a firmware file via the OSX app for my SmartSolar MPPT + Bluetooth, but where do I get that firmware file?
Or, can I only update the firmware connecting with the iOS/Android app?

rk31 asked
Guy Stewart (Victron Community Manager) commented ·

2 Answers

Firmware update old MultiPlus

I have an old Multi Plus 3000/70/24 from ca 2015 that I need to update the firmware on number 2612157 VFD. If you could email the answer to

Thank you

kerpa asked
kerpa commented ·

1 Answer

Cerbo GX dead after update to 2.60


I am reading here already for a long time but now my first question.

I have a new Cerbo GX since yesterday,everything was ok but after the update to 2.60 nothing works.

I have no access any more,the wifi led is orange,sometimes blinking or off or steady ?

The bluetooth led never lights any more.

I tried the reset button,and try to connect by cable to my router nothing helps.

Any ideas ?

Regards Eric

liopleuredon asked
liopleuredon answered ·

2 Answers

Phoenix Smart Charger IP43 12/30 (1+1): Wrong/Inaccurate output current


I have a Phoenix Smart Charger IP43 12/30 (1+1) in Li-ion mode.

When I set the maximum charge current to 14 A the output current is 13.6 A in the status of VictronConnectApp. This looks correct for me, because 14 A is the maximum.

But in real, the output current is 14.7 A, measured with an ampere meter and a BMV-712.

When the current drops under 1 A in the absorption phase, the output current in the status of VictronConnectApp show for the Charger 0.0A.

In my opinion, there are one of the following reasons:

  1. Firmware bug in current view or current calculation
  2. Inaccurate current measurement (if there is a current measurement in the charger)
  3. A faulty unit

I hope, someone can help or comment.


Best regards


felixsteinbeis asked
felixsteinbeis edited ·

0 Answers

SmartSolar Charger 150/35 - still experiencing zero output issues after firmware 1.53 and 1.54 updates


After updating the firmware on my 3 SmartSolar 150/35 devices from 1.51 I have been experiencing issues where the PV power drops close to zero. In some instances the situation rectifies itself other times I need to disable/enable via the VictronConnect app. I saw there was an issue with the 1.53 firmware and hoped the 1.54 firmware would rectify the situation but unfortunately the issue still persists. Today device 260 was off for 2 hours before I disabled/enabled it via the app.


  1. Quattro 48/8000/100-2x100 - firmware 469
  2. 4 x Pylontech US3000
  3. 3 x SmartSolar 150/35 - firmware 1.54
  4. 2 sets of 6 x JA Solar JAP72S01-330/SC
  5. 1 set of 6 x JA Solar JAM72S01-380/PR
  6. Venus GX - firmware 260



Is Victron aware that some devices still have this "drop out "issue even with the 1.54 firmware?


jkkm asked
jkkm commented ·

1 Answer

SMART SOLAR 75/15 will not update to 1.54 firmware

When, using a bluetooth connection, I ask my SmartController 75/15 to update its firmware, it tells me that version 1.53 is the latest version and that no update can be done. I can find no way to update to 1.54. It was suggested that I update to 1.54 to solve the controller momentarily turning off the load twice a day. What am I doing wrong?

rjkepple asked
Justin Cook - Bay Marine Supply USA commented ·

2 Answers

Cerbo not booting - flashing orange light after failed firmware update

Good Morning,

This morning I started to install the Cerbo in my system. Booting the device with minimal connections went great, and we began to connect the Quattro, Solar via USB, and BMV via VE direct.

A firmware update was detected, and we chose to update to 2.60 - at some point after telling it to perform this update, the Cerbo will no longer boot. (I assume its not booting). We were using the wifi, and check for updates, under the system menu. When it found the 2.60 update, we told it to download and install. It didn't automatically install, but showed in the list of "alternative backup firmwares" to boot from. We chose to boot 2.60 instead of 2.57 and on the next restart, the Touch 50 GX remains blank, and the red / orange Wifi light will begin flashing after a few seconds, but nothing else appears to happen.

1.) Is there a hardware or backdoor way to force the Cerbo to reboot back to the 2.57 firmware?

2.) Is there a way to connect to the Cerbo via a computer and manually push a new firmware to it?

Unfortunately going back to the dealer is a VERY lengthy issue at this point. We're in the Caribbean, and floating in French Martinique at the moment. Anything we do would require weeks and weeks of shipping each way, so hopefully there's a technical way to solve this, as I believe it's just a bad firmware boot, and going back to the old one would be fine?

Thanks in advance for your help.

Bryan asked
mvader (Victron Energy) commented ·

3 Answers

BMV 700 firmware update fail?

I tried to use Victron Connect via my Samsung phone to get some data and it started to update the firmware. Now my monitor reads bL 102 and no amount of uninstalling/reinstalling the app will fix the situation. It's completely stuck. I've also tried with Windows laptop app but it can't find the device, even though it's paired with my laptop.

This monitor is basically useless now. I can't even manually restore the monitor with the buttons. How can I update the firmware? So frustrating.

drewbru asked
phurstone commented ·

2 Answers

Daily load output outage after update of SmartSolar 100/20 to firmware v1.53

After updating the firmware of my SmartSolar MPPT 100|20 (0xA05F) from v1.50 to v1.53 I have the following issue with the solar charge controller: every 24 hours at around 17:30 the load output automatically turns off for a short moment, leading to a sudden power outage for my off-grid system's loads (LTE router etc).

I don't know if the charge controller just performs a restart, or if only the load output is toggled. This never happened with former firmware versions.

Other than the firmware update nothing was changed on the setup at that time. BTW, the update was performed on 25.10.2020 at 15:47, and on the very same day at 17:35 the first load output outage happened. And from then on every 24 hours, every day.

There are no loads with high inrush current connected, the actual load is well below 1A at that time, no load is switch.

And it seems that I'm not the only one with this issue (see another Google Play review on 28.10.2020).


heikoffm asked
heikoffm commented ·

3 Answers

Urgent: When will MPPT firmware 1.54 be available?

When will be the fw avaiable for public?

I need to solve the load output outage of my communication towers.



tkmbe asked
tkmbe answered ·

2 Answers

MPPT 100/20 - FW 1.53 - fixed absorption time defined in the settings is no longer adhered to


since FW 1.53 the fixed absorption time defined in the settings is no longer adhered to.

A couple of seconds after reaching absorption voltage the MPPT jumps directly from Bulk to Float.

Tested with two different MPPT's.

Could you please fix this?

ulfertg asked
ulfertg answered ·

2 Answers

MPPT 100/20 turning load on/off every second

Good afternoon,

after the firmware update few days ago, the solar MPPT controller now turns load on/off every second. It happens most often in voltage scenarios around 11.5V or lower. My Custom minimum voltage is set to 11.0V so before it used to keep load on until Voltage dropped below 11.0V for about 1-2 minutes.

The connected load is light with only some LED light bulbs about 10W. After the MPPT turns load off, the voltage goes up a bit (for example from 11.5 to 11.6V) and the MMPT turns load on again one second later which causes Voltage to drop a bit and the MPPT turns load off again. This repeats every 1-2 seconds. Even turning Load Output to "Always On" continues this repeating cycle.

tomvacek asked
ddickov answered ·

3 Answers

Issue after Update to FW 1.53 Update Smartsolar MPPT 100/50

After updating both my Smartplus MPPT 100/50 from FW 1.50 to 1.53 the Network Total Power is not accurate and even the Current solar coming in seems off. One MPPT is showing output of 259W with network output of 259w. Second MPPT is showing output of 146W with network of 154W and my BMV 712 shows watts coming in at 578W. All devices still show on the VE. Smart Network and linked.

brentdchapman asked

0 Answers

MultiPlus Compact 24/1600/40-16 firmware update

Hello All,

I have a MultiPlus 24/1600 Product ID 2616 with firmware 154. I have it connected to VenusGX with vOS v2.42. I need to update the firmware to support ESS. I have no easy access to MK3 cable.

Is firmware update with vbdub possible? Documentation ( says minimum firmware 2xx is required. Is documentation current and correct?

I am familiar with Linux and not afraid of command line. I am afraid of bricking my MultiPlus though.

I also have USB RS232 or USB RS485 for other option to connect to MultiPlus.

I hope I am not stuck buying MK3 cable for single use.

taygsdb asked
solarsun commented ·

2 Answers

NMEA 2000 SOC no longer showing on Maretron DSM 410 after Venus 2.60 firmware upgrade


I just upgraded my Cerbo GX to 2.6 from 2.51 and am no longer getting the Battery SOC and Time Remaining displayed on my Maretron DSM 410.

If I revert back to 2.51 both values display correctly but if I promote to 2.6 I lose those values. Voltage and Current work in both scenarios. I looked through the settings on the Cerbo GX, but could not find specifically a setting that would affect this.

On the Maretron I am picking up "Any" device instance, I also tried to specify a specific battery monitor rather than "Any" on the Cerbo.

I have the Smart Shunt, and two Multiplus' in parallel. There is a BMS as well on 3 Victron Lithium SmartBatteries (300ah) for a total house bank of 1200ah.

It is definitely a change from the firmware as I can toggle between the firmware versions consistently to get it to work on 2.51 and not on 2.6. Any thoughts?



tony-castagno asked
tony-castagno commented ·

1 Answer

Has there been an update for the colorcontrol around 12-09-2020 ?

My Colorcontrol changed setting options in the ESS system somewhere around 12-09-2020 . Also inverter power was set back to 1000 Watt. Was this possible because of an update ? Can this be done without informing the customer ?

aqua-volta asked
aqua-volta answered ·

2 Answers

phoenix inverter victronconnect VA power output incorrect

The new firmware verssion is show incorrect VA values by more than 50%. This has been tested on two new . This should have aunits 12/375 and 12/500. With a 240ah battery bank and no other loads and solar disconnected. BMV712 shows watts going out as 250w. Phoenix inverter through victron connect on a PC is showing 65VA. (dial is at around 20% capacity). The reading should be around 250VA and the dial at 50%.

The previous firmware version only showed a percentage of capacity which I felt was more accurate. Is this a bug in the new firmware?

trendbuck asked

0 Answers

Victron Quattro 48v/10000va/140-2x100 How to Firmware Update


I Have Victron Quattro 48v/10000va/140-2x100 with VE.Bus version 2653413 and need to update it , so I can access ESS (to setup battery charge only from PV).

I have Color Control GX too.

I can't update it vía VRM.



hans-georgi asked
hans-georgi answered ·

2 Answers

What is the latest firmware version for the MultiPlus 12V/3000A/120A-50/120V?

The sticker on the control panel says 2702430.VDF

This seems so difficult to figure out...

cissabrandao asked
cissabrandao commented ·

1 Answer

Updating firmware MPPT 150/100 VE.Can using VE.Direct + PC software


MPPT 150/100-Tr VE.Can connected to PC using VE.Direct port & Victron serial adapter cable.


When connecting to Equipment via the VE.Direct port with Victron serial cable + PC with VictronConnect software, we are prompted to update the firmware on the device, which then fails (see attached error message: "Update failed! Result: X88 - Communication Error. Vreg Ack timeout. Please check the connection and try again". See photo for error screen.



Any idea how to fix this so we can update firmware via PC and configure settings?


  • We are able to connect with the Android App and perform the update via Bluetooth. Subsequently the connection using the VE.Direct port + PC works fine.
  • We're using the latest version of both the PC VictronConnect software as well as the Android app

If you have any ideas on how to fix this it would be appreciated, as we're expecting to be programming many of these devices and doing so via bluetooth is very time consuming.

Thanks kindly,


allen-upward asked
michelg edited ·

1 Answer

Cerbo CX stuck at 60% when trying to connect via bluetooth

Hi everybody !

After upgrading from 2.58 to 2.60 the Cerbo GX firmware, I have an issue trying to connect with Bluetooth. It connects up to 60% and remains stuck at it. The other Victron hardware (mppt, battery protect, etc) have no issues.

I have also been searching for the "eject" MicroSD card, and not found it.

I also did not find the setting in order to perform an equalization from the Cerbo GX on the mppt SmartSolar 150/100.

Being 100% off-grid, is there an option to disable the "red" square providing the information for the Grid / Generator input ?

Thanks for your comments and help.


michelg asked
Guy Stewart (Victron Community Manager) commented ·

1 Answer

Firmwares Not Updating... Timing out.

I have a BMV702 and a solar controller 100/30.both with Bluetooth dongles. The batteries on this system died and have been dead for about six months. I installed a new fully charged battery today, removing the dead batteries. Now Both dongles are flashing both lights rapidly. I tried to update firmware using latest Victron Connect app and it timed out during upgrade. On both dongles. I Used my Samsung Note 20 Ultra. I even tried loading the Victron Connect app on my MacBook and I got the same error. Timed out. How can I upgrade my firmware? Is this a common problem? Spent $100 on these two dongles now both won't work at all because Victron connect app is making. E update firmware which fails over and over. Thanks.

houstonphotog asked
Peter Buijs - NL answered ·

1 Answer

smart solar 75/15 not remembering the software/firmware update to V1.50 and switching off load output

I have mutiple Victron Energy MPPT 75/15 Solar controllers in Solar Battery systems that I operate in Australia. I have a serious issue with many of them that I need help with.

Many of the systems are just switching off the load output. When we go to the system and open the application to access the solar controller it them prompts for a software update v2.23 to v2.25 once this update is done it then prompts for the update v1.46 to v1.50. The power / load output immediately works as it should do.

The issue I have is that the update is not storing in the solar controller and this issue is repeatedly happening in the same solar controllers.

  • They are not remembering the software/firmware update to V1.50
  • They switch off the load output while in the field for no reason.

paul-k asked

0 Answers

Control Console / Firmware Update /Error 1392 on Raspberry pi3+

Good day to you all..

I wondered if there are any experts out there who is able to help me with the issues I am currently experiencing as i'm no expert in these matters.

Background info: I'm running VOS v2.57 on a RPi3+ connected to a mppt 100/50. RPi is connected on a lan network. No issues since installation the first time round (about 3 months ago).

Here are the issues:

1) VRM stopped (on the 12/08/20) logging data at the predefined interval and instead only logged the information on an hourly basis.

2) I checked the VRM and saw that the summary stated it was "Old Data! go to Device List" which was not there before??


3) I clicked on the Device list and there was a 'Update Firmware" notification which was not there before (at the bottom of photo).


The following error came up:


It states Error 1392 however, 2-way communication is enabled as seen below:


4) With the above failing, I tried to logged onto the Control Console in the VRM to update the firmware and the following came up: (Failed to connect to GX Device). So as you can imagine, there was a lot of head scratching by myself at this point in time.


5) On failing so far, I re-installed VOS v2.57 and then see if I was able to acquire VRM using the IP address but, this was not possible.

Tried the following:

1) Wait a day to see if the error would go away - just in case it was a one-off.

2) Rebooting RPi - nothing happened.

3) Re-installing VOS - nothing happened.

4) Rebooted modem (even though I know it was working perfectly all the time) - nothing happened.

5??) I was thinking about deleting my devices from VRM and start all over again but, I didn't want to lose all the captured data.

So, if there are any experts out there your help is much appreciated...

trungt asked
trungt answered ·

4 Answers